]> git.pld-linux.org Git - packages/python-libvirt.git/blobdiff - python-libvirt.spec
up to 5.1.0
[packages/python-libvirt.git] / python-libvirt.spec
index 6b554bb48ef83879264ef5960273693ec56df5bf..96b7f518d291a270193e299eabd9ef9578013e0c 100644 (file)
@@ -2,61 +2,89 @@
 # Conditional build:
 %bcond_without lxc             # LXC support
 %bcond_without qemu            # Qemu support
+%bcond_without python3         # CPython 3.x module
 
 # qemu available only on x86 and ppc
-%ifnarch %{ix86} %{x8664} ppc
+%ifnarch %{ix86} %{x8664} x32 ppc
 %undefine      with_qemu
 %endif
 
 %define                origname        libvirt-python
-Summary:       Python bindings to interact with virtualization capabilities
-Summary(pl.UTF-8):     Wiązania Pythona do współpracy z funkcjami wirtualizacji
+Summary:       Python 2.x bindings to interact with virtualization capabilities
+Summary(pl.UTF-8):     Wiązania Pythona 2.x do współpracy z funkcjami wirtualizacji
 Name:          python-libvirt
-Version:       1.2.0
+Version:       5.1.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Development/Languages/Python
 Source0:       ftp://ftp.libvirt.org/libvirt/python/%{origname}-%{version}.tar.gz
-# Source0-md5: 38158e5740be65f17eef9f99ffa5dadf
+# Source0-md5: 0885bce90c98a80571fc5472eb683937
 URL:           http://www.libvirt.org/
-BuildRequires: libvirt-devel >= 1.0.2
+BuildRequires: libvirt-devel >= 4.5.0
 BuildRequires: pkgconfig
-BuildRequires: python >= 2
-BuildRequires: python-devel >= 2
+BuildRequires: python >= 1:2.4
+BuildRequires: python-devel >= 1:2.4
+%if %{with python3}
+BuildRequires: python3 >= 1:3
+BuildRequires: python3-devel >= 1:3
+%endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.627
-Requires:      libvirt >= 1.0.2
+BuildRequires: rpmbuild(macros) >= 1.710
+BuildConflicts:        python-PyXML < 0.8.4-13
+Requires:      libvirt >= 4.5.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Libvirt is a C toolkit to interact with the virtualization
 capabilities of recent versions of Linux.
 
-This package contains the Python bindings for the libvirt library.
+This package contains the Python 2.x bindings for the libvirt library.
 
 %description -l pl.UTF-8
 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
 obecnych wersji Linuksa.
 
-Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
+Ten pakiet zawiera wiązania Pythona 2.x do biblioteki libvirt.
+
+%package -n python3-libvirt
+Summary:       Python 3.x bindings to interact with virtualization capabilities
+Summary(pl.UTF-8):     Wiązania Pythona 3.x do współpracy z funkcjami wirtualizacji
+Group:         Development/Languages/Python
+Requires:      libvirt >= 1.0.2
+
+%description -n python3-libvirt
+Libvirt is a C toolkit to interact with the virtualization
+capabilities of recent versions of Linux.
+
+This package contains the Python 3.x bindings for the libvirt library.
+
+%description -n python3-libvirt -l pl.UTF-8
+Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
+obecnych wersji Linuksa.
+
+Ten pakiet zawiera wiązania Pythona 3.x do biblioteki libvirt.
 
 %prep
 %setup -q -n %{origname}-%{version}
 
 %build
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build
+%py_build
+
+%if %{with python3}
+%py3_build
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__python} setup.py install \
-       --root=$RPM_BUILD_ROOT
 
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_install
+
 %py_postclean
 
+%if %{with python3}
+%py3_install
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -74,3 +102,25 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/libvirt_qemu.py[co]
 %endif
 %{py_sitedir}/libvirt_python-%{version}-py*.egg-info
+
+%if %{with python3}
+%files -n python3-libvirt
+%defattr(644,root,root,755)
+%doc AUTHORS ChangeLog README NEWS
+%attr(755,root,root) %{py3_sitedir}/libvirtmod.*.so
+%{py3_sitedir}/libvirt.py
+%{py3_sitedir}/__pycache__/libvirt.*.py[co]
+%{py3_sitedir}/libvirtaio.py
+%{py3_sitedir}/__pycache__/libvirtaio.*.py[co]
+%if %{with lxc}
+%attr(755,root,root) %{py3_sitedir}/libvirtmod_lxc.*.so
+%{py3_sitedir}/libvirt_lxc.py
+%{py3_sitedir}/__pycache__/libvirt_lxc.*.py[co]
+%endif
+%if %{with qemu}
+%attr(755,root,root) %{py3_sitedir}/libvirtmod_qemu.*.so
+%{py3_sitedir}/libvirt_qemu.py
+%{py3_sitedir}/__pycache__/libvirt_qemu.*.py[co]
+%endif
+%{py3_sitedir}/libvirt_python-%{version}-py*.egg-info
+%endif
This page took 0.091004 seconds and 4 git commands to generate.