]> git.pld-linux.org Git - packages/python-keyring.git/blob - python-keyring.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-keyring.git] / python-keyring.spec
1 %define         module  keyring
2 Summary:        Python library to access the system keyring service
3 Name:           python-%{module}
4 Version:        0.6.2
5 Release:        2
6 Source0:        http://pypi.python.org/packages/source/k/keyring/%{module}-%{version}.tar.gz
7 # Source0-md5:  b21b5783c375fc09abdc060b4edc062f
8 License:        Python
9 Group:          Development/Libraries
10 URL:            http://pypi.python.org/pypi/keyring
11 BuildRequires:  python-devel
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 # CryptedFileKeyring
14 Suggests:       python-Crypto
15 # KDEKWallet
16 Suggests:       python-PyKDE4
17 # GnomeKeyring
18 Suggests:       python-gnome-desktop-keyring
19 Obsoletes:      python-keyring-gnome < 0.5.1
20 Obsoletes:      python-keyring-kwallet < 0.5.1
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Python keyring lib provides a easy way to access the system
26 keyring service from python. It can be used in any application that
27 needs safe password storage.
28
29 This package only provides file-based pseudo-keyrings. To interface
30 with gnome-keyring or KWallet, please install one of
31 python-keyring-gnome or python-keyring-kwallet.
32
33 %prep
34 %setup -q -n %{module}-%{version}
35
36 %build
37 %py_build
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %py_install
42
43 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
44
45 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46 cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CHANGES.txt CONTRIBUTORS.txt README
56 %{py_sitescriptdir}/%{module}
57 %{py_sitescriptdir}/%{module}-*.egg-info
58 %{_examplesdir}/%{name}-%{version}
This page took 0.057142 seconds and 4 git commands to generate.