]> git.pld-linux.org Git - packages/python-keyring.git/blob - python-keyring.spec
- new
[packages/python-keyring.git] / python-keyring.spec
1 %define         module  keyring
2 Summary:        Python library to access the system keyring service
3 Name:           python-%{module}
4 Version:        0.5.1
5 Release:        1
6 Source0:        http://pypi.python.org/packages/source/k/keyring/%{module}-%{version}.tar.gz
7 # Source0-md5:  a2f0dcea7185580c163ef2db1f4fbe0c
8 License:        Python
9 Group:          Development/Libraries
10 URL:            http://pypi.python.org/pypi/keyring
11 BuildRequires:  python-devel
12 BuildRequires:  rpmbuild(macros) >= 1.219
13 Obsoletes:      python-keyring-gnome < 0.5.1
14 Obsoletes:      python-keyring-kwallet < 0.5.1
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The Python keyring lib provides a easy way to access the system
20 keyring service from python. It can be used in any application that
21 needs safe password storage.
22
23 This package only provides file-based pseudo-keyrings. To interface
24 with gnome-keyring or KWallet, please install one of
25 python-keyring-gnome or python-keyring-kwallet.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 %build
31 %{__python} setup.py build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 %{__python} setup.py install \
36         --skip-build \
37         --optimize=2 \
38         --root=$RPM_BUILD_ROOT
39
40 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
41
42 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
43 cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
44
45 %py_postclean
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README.txt
53 %{py_sitescriptdir}/%{module}
54 %{py_sitescriptdir}/%{module}-*.egg-info
55 %{_examplesdir}/%{name}-%{version}
This page took 0.097021 seconds and 3 git commands to generate.