]> git.pld-linux.org Git - packages/python-isort.git/commitdiff
- updated to 4.3.21 auto/th/python-isort-4.3.21-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 20 Oct 2019 16:07:55 +0000 (18:07 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 20 Oct 2019 16:07:55 +0000 (18:07 +0200)
- filled test dependencies (not all available in PLD)

python-isort.spec

index 52994749b578f2bd07c8178a69da5eeef674fe86..ce563f872e6505203e6a4b59d8e2809162782739 100644 (file)
@@ -1,28 +1,46 @@
 #
 # Conditional build:
-%bcond_with    tests   # do perform tests (broken in 4.2.15)
+%bcond_with    tests   # unit tests (needs more dependencies in PLD)
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 %define                module  isort
-Summary:       Python utility / library to sort imports alphabetically
+Summary:       Python 2 library to sort imports alphabetically
+Summary(pl.UTF-8):     Narzędzie Pythona 2 do alfabetycznego sortowania listy importów
 Name:          python-%{module}
-Version:       4.2.15
-Release:       2
+Version:       4.3.21
+Release:       1
 License:       MIT
 Group:         Libraries/Python
-Source0:       https://files.pythonhosted.org/packages/source/i/%{module}/%{module}-%{version}.tar.gz
-# Source0-md5: 34915a2ce60e6fe3dbcbf5982deef9b4
+#Source0Download: https://pypi.org/simple/isort/
+Source0:       https://files.pythonhosted.org/packages/source/i/isort/%{module}-%{version}.tar.gz
+# Source0-md5: 05d66f2eb7ce2c2d702e86bac24bf9e4
 URL:           https://github.com/timothycrosley/isort
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-backports.functools_lru_cache
+BuildRequires: python-futures
+BuildRequires: python-pip-api
+BuildRequires: python-pipreqs
+BuildRequires: python-pytest
+BuildRequires: python-requirementslib
+%endif
 %endif
 %if %{with python3}
+BuildRequires: python3-modules >= 1:3.4
 BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-pip-api
+BuildRequires: python3-pipreqs
+BuildRequires: python3-pytest
+BuildRequires: python3-requirementslib
+%endif
 %endif
-Requires:      python-modules
+Requires:      python-modules >= 1:2.7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -30,23 +48,47 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 isort is a Python utility / library to sort imports alphabetically,
 and automatically separated into sections. It provides a command line
 utility, Python library and plugins for various editors to quickly
-sort all your imports. It currently cleanly supports Python 2.7 - 3.6
-without any dependencies.
+sort all your imports. It currently cleanly supports Python 2.7 and
+3.4+ without any dependencies.
+
+This package contains Python 2 library.
+
+%description -l pl.UTF-8
+isort to pythonowe narzędzie/biblioteka do alfabetycznego sortowania
+importów i automatycznego dzielenia ich na sekcje. Udostępnia
+narzędzie wiersza poleceń, bibliotekę Pythona i wtyczki do różnych
+edytorów, pozwalające szybko posortować importy. Obecnie obsługuje
+czysto wersje Pythona 2.7 i 3.4+ bez zewnętrznych zależności.
+
+Ten pakiet zawiera bibliotekę Pythona 2.
 
 %package -n python3-%{module}
-Summary:       Python utility / library to sort imports alphabetically
+Summary:       Python 3 library to sort imports alphabetically
+Summary(pl.UTF-8):     Biblioteka Pythona 3 do alfabetycznego sortowania listy importów
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.4
 
 %description -n python3-%{module}
 isort is a Python utility / library to sort imports alphabetically,
 and automatically separated into sections. It provides a command line
 utility, Python library and plugins for various editors to quickly
-sort all your imports. It currently cleanly supports Python 2.7 - 3.6
-without any dependencies.
+sort all your imports. It currently cleanly supports Python 2.7 and
+3.4+ without any dependencies.
+
+This package contains Python 3 library.
+
+%description -n python3-%{module} -l pl.UTF-8
+isort to pythonowe narzędzie/biblioteka do alfabetycznego sortowania
+importów i automatycznego dzielenia ich na sekcje. Udostępnia
+narzędzie wiersza poleceń, bibliotekę Pythona i wtyczki do różnych
+edytorów, pozwalające szybko posortować importy. Obecnie obsługuje
+czysto wersje Pythona 2.7 i 3.4+ bez zewnętrznych zależności.
+
+Ten pakiet zawiera bibliotekę Pythona 3.
 
 %package -n isort
-Summary:       Python utility / library to sort imports alphabetically
+Summary:       Python utility to sort imports alphabetically
+Summary(pl.UTF-8):     Pythonowe narzędzie do alfabetycznego sortowania listy importów
 Group:         Development/Tools
 %if %{with python3}
 Requires:      python3-%{module} = %{version}-%{release}
@@ -58,19 +100,38 @@ Requires:  python-%{module} = %{version}-%{release}
 isort is a Python utility / library to sort imports alphabetically,
 and automatically separated into sections. It provides a command line
 utility, Python library and plugins for various editors to quickly
-sort all your imports. It currently cleanly supports Python 2.7 - 3.6
-without any dependencies.
+sort all your imports. It currently cleanly supports Python 2.7 and
+3.4+ without any dependencies.
+
+This package contains command line utility.
+
+%description -n isort -l pl.UTF-8
+isort to pythonowe narzędzie/biblioteka do alfabetycznego sortowania
+importów i automatycznego dzielenia ich na sekcje. Udostępnia
+narzędzie wiersza poleceń, bibliotekę Pythona i wtyczki do różnych
+edytorów, pozwalające szybko posortować importy. Obecnie obsługuje
+czysto wersje Pythona 2.7 i 3.4+ bez zewnętrznych zależności.
+
+Ten pakiet zawiera narzędzie wiersza poleceń.
 
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%if %{with tests}
+%{__python} -m pytest test_isort.py
+%endif
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
+
+%if %{with tests}
+%{__python3} -m pytest test_isort.py
+%endif
 %endif
 
 %install
@@ -92,7 +153,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS.md CHANGELOG.md README.rst
+%doc ACKNOWLEDGEMENTS.md CHANGELOG.md LICENSE README.rst
 %{py_sitescriptdir}/%{module}
 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
@@ -100,7 +161,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc ACKNOWLEDGEMENTS.md CHANGELOG.md README.rst
+%doc ACKNOWLEDGEMENTS.md CHANGELOG.md LICENSE README.rst
 %{py3_sitescriptdir}/%{module}
 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
This page took 0.13553 seconds and 4 git commands to generate.