]> git.pld-linux.org Git - packages/python-geventhttpclient.git/blame - python-geventhttpclient.spec
- updated to 1.5.5
[packages/python-geventhttpclient.git] / python-geventhttpclient.spec
CommitLineData
07e55034
AM
1#
2# Conditional build:
7b4d93cb 3%bcond_with tests # py.test tests [use network]
07e55034 4%bcond_without python2 # CPython 2.x module
99278cda 5%bcond_without python3 # CPython 3.x module
07e55034
AM
6
7%define module geventhttpclient
8Summary: A high performance, concurrent HTTP client library
99278cda 9Summary(pl.UTF-8): Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP
07e55034 10Name: python-%{module}
22966547
JB
11# keep 1.x here for python2 support
12Version: 1.5.5
13Release: 1
07e55034
AM
14License: MIT
15Group: Libraries/Python
d1cc782e 16#Source0Download: https://pypi.org/simple/geventhttpclient/
99278cda 17Source0: https://files.pythonhosted.org/packages/source/g/geventhttpclient/geventhttpclient-%{version}.tar.gz
22966547 18# Source0-md5: 921c99dae79636616b4826423a870c9a
d1cc782e 19URL: https://pypi.org/project/geventhttpclient/
07e55034 20BuildRequires: rpm-pythonprov
99278cda 21BuildRequires: rpmbuild(macros) >= 1.714
07e55034 22%if %{with python2}
99278cda
JB
23# older versions generate pythonegg(backports.ssl_match_hostname) dependency
24BuildRequires: python-devel >= 1:2.7.9
25BuildRequires: python-modules >= 1:2.7.9
07e55034
AM
26BuildRequires: python-setuptools
27%if %{with tests}
ca83ee43 28BuildRequires: python-brotli
07e55034 29BuildRequires: python-certifi
ca83ee43 30BuildRequires: python-dpkt
99278cda
JB
31BuildRequires: python-gevent >= 0.13
32BuildRequires: python-pytest
33BuildRequires: python-six
07e55034
AM
34%endif
35%endif
36%if %{with python3}
99278cda
JB
37BuildRequires: python3-devel >= 1:3.4
38BuildRequires: python3-modules >= 1:3.4
07e55034
AM
39BuildRequires: python3-setuptools
40%if %{with tests}
ca83ee43 41BuildRequires: python3-brotli
07e55034 42BuildRequires: python3-certifi
ca83ee43 43BuildRequires: python3-dpkt
99278cda
JB
44BuildRequires: python3-gevent >= 0.13
45BuildRequires: python3-pytest
46BuildRequires: python3-six
07e55034
AM
47%endif
48%endif
99278cda 49Requires: python-modules >= 1:2.7.9
07e55034
AM
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
99278cda 53A high performance, concurrent HTTP client library for Python 2 using
07e55034
AM
54gevent.
55
871575a9 56geventhttpclient use a fast HTTP parser, written in C, originating
07e55034
AM
57from nginx, extracted and modified by Joyent.
58
59geventhttpclient has been specifically designed for high concurrency,
60streaming and support HTTP 1.1 persistent connections. More generally
61it is designed for efficiently pulling from REST APIs and streaming
871575a9 62API's like Twitter's.
07e55034
AM
63
64Safe SSL support is provided by default.
65
99278cda
JB
66%description -l pl.UTF-8
67Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP dla Pythona
682, wykorzystująca gevent.
69
70geventhttpclient wykorzystuje szybki parser HTTP, napisany w C,
71pochodzący z serwera nginx, wyciągniety i zmodyfikowany przez Joyenta.
72
73geventhttpclient został zaprojektowany w szczególności z myślą o
74dużym zrównolegleniu, przesyłaniu strumieni i obsłudze trwałych
75połączeń HTTP 1.1. Bardziej ogólnie, jest przeznaczony do wydajnego
76pobierania z API REST-owych oraz strumieniowych, takich jak Twitter.
77
78Domyślnie dostępna jest obsługa bezpiecznego SSL.
79
07e55034
AM
80%package -n python3-%{module}
81Summary: A high performance, concurrent HTTP client library
99278cda 82Summary(pl.UTF-8): Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP
07e55034 83Group: Libraries/Python
99278cda 84Requires: python3-modules >= 1:3.4
07e55034
AM
85
86%description -n python3-%{module}
99278cda 87A high performance, concurrent HTTP client library for Python 3 using
07e55034
AM
88gevent.
89
871575a9 90geventhttpclient use a fast HTTP parser, written in C, originating
07e55034
AM
91from nginx, extracted and modified by Joyent.
92
93geventhttpclient has been specifically designed for high concurrency,
94streaming and support HTTP 1.1 persistent connections. More generally
95it is designed for efficiently pulling from REST APIs and streaming
871575a9 96API's like Twitter's.
07e55034
AM
97
98Safe SSL support is provided by default.
99
99278cda
JB
100%description -n python3-%{module} -l pl.UTF-8
101Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP dla Pythona
1023, wykorzystująca gevent.
103
104geventhttpclient wykorzystuje szybki parser HTTP, napisany w C,
105pochodzący z serwera nginx, wyciągniety i zmodyfikowany przez Joyenta.
106
107geventhttpclient został zaprojektowany w szczególności z myślą o
108dużym zrównolegleniu, przesyłaniu strumieni i obsłudze trwałych
109połączeń HTTP 1.1. Bardziej ogólnie, jest przeznaczony do wydajnego
110pobierania z API REST-owych oraz strumieniowych, takich jak Twitter.
111
112Domyślnie dostępna jest obsługa bezpiecznego SSL.
113
07e55034
AM
114%prep
115%setup -q -n %{module}-%{version}
116
ca83ee43 117%{__rm} -r src/geventhttpclient.egg-info
99278cda 118
07e55034
AM
119%build
120%if %{with python2}
99278cda
JB
121%py_build
122
ca83ee43
JB
123%if %{with tests}
124PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
125PYTHONPATH=$(pwd)/$(echo build-2/lib.*) \
126%{__python} -m pytest src
127%endif
07e55034
AM
128%endif
129
130%if %{with python3}
99278cda
JB
131%py3_build
132
ca83ee43
JB
133%if %{with tests}
134PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
135PYTHONPATH=$(pwd)/$(echo build-3/lib.*) \
136%{__python3} -m pytest src
137%endif
07e55034
AM
138%endif
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
143%if %{with python2}
799dc142 144%py_install
07e55034
AM
145
146%py_postclean
147%endif
148
149%if %{with python3}
799dc142 150%py3_install
07e55034
AM
151%endif
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%if %{with python2}
157%files
158%defattr(644,root,root,755)
22966547 159%doc LICENSE.txt README.mdown
07e55034
AM
160%dir %{py_sitedir}/geventhttpclient
161%{py_sitedir}/geventhttpclient/*.py[co]
99278cda
JB
162%attr(755,root,root) %{py_sitedir}/geventhttpclient/_parser.so
163%{py_sitedir}/geventhttpclient-%{version}-py*.egg-info
07e55034 164%endif
07e55034
AM
165
166%if %{with python3}
167%files -n python3-%{module}
168%defattr(644,root,root,755)
22966547 169%doc LICENSE.txt README.mdown
99278cda
JB
170%dir %{py3_sitedir}/geventhttpclient
171%{py3_sitedir}/geventhttpclient/*.py
172%{py3_sitedir}/geventhttpclient/__pycache__
173%attr(755,root,root) %{py3_sitedir}/geventhttpclient/_parser.cpython-*.so
174%{py3_sitedir}/geventhttpclient-%{version}-py*.egg-info
07e55034 175%endif
This page took 0.142041 seconds and 4 git commands to generate.