]> git.pld-linux.org Git - packages/python-gevent.git/commitdiff
- up to 1.3.4 auto/th/python-gevent-1.3.4-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 2 Jul 2018 18:23:41 +0000 (20:23 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 2 Jul 2018 18:23:41 +0000 (20:23 +0200)
python-gevent-tests.patch
python-gevent.spec

index 82910fe461e9ca5c013674f0ed1e28cd5e58e1b3..04a07c3548aa3349588dd8f6db82e568ebc665b4 100644 (file)
          ))
  
          tests_count = 0
---- gevent-1.2.1/src/greentest/test__signal.py.orig    2017-01-12 14:15:25.000000000 +0100
-+++ gevent-1.2.1/src/greentest/test__signal.py 2017-03-15 15:48:49.582871992 +0100
-@@ -71,7 +71,6 @@
-                 reload_module(site)
-             except TypeError:
-                 assert greentest.PY36
--                assert greentest.RUNNING_ON_CI
-                 import sys
-                 for m in set(sys.modules.values()):
-                     try:
+
index 946d9fb489c83b009eff59933c938a634a6f6a23..58bff9693a85efc2e98eb19cc8c13c151c01d0b3 100644 (file)
 Summary:       A coroutine-based Python 2 networking library
 Summary(pl.UTF-8):     Biblioteka sieciowa dla Pythona 2 oparta na korutynach
 Name:          python-%{module}
-Version:       1.2.2
-Release:       3
+Version:       1.3.4
+Release:       1
 Epoch:         1
 License:       MIT
 Group:         Development/Languages
 #Source0Download: https://pypi.python.org/simple/gevent
 Source0:       https://files.pythonhosted.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
-# Source0-md5: 7f0baf355384fe5ff2ecf66853422554
+# Source0-md5: 97deaf53196ba430808e8f18b731112a
 Patch0:                known_failures-pld.patch
 Patch1:                %{name}-tests.patch
 URL:           http://www.gevent.org/
@@ -39,6 +39,7 @@ BuildRequires:        python-devel >= 1:2.7
 BuildRequires: python-coverage >= 4.0
 BuildRequires: python-devel-src >= 1:2.7
 BuildRequires: python-greenlet >= 0.4.10
+BuildRequires:  python-objgraph
 BuildRequires: python-setuptools
 BuildRequires: python-test
 %endif
@@ -49,6 +50,7 @@ BuildRequires:        python3-devel >= 1:3.3
 %if %{with tests}
 BuildRequires: python3-coverage >= 4.0
 BuildRequires: python3-greenlet >= 0.4.10
+BuildRequires:  python3-objgraph
 BuildRequires: python3-setuptools
 BuildRequires: python3-test
 %endif
@@ -156,15 +158,15 @@ rm -rf $RPM_BUILD_ROOT
 %py_install
 
 %py_postclean
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gevent/*.{c,h,pyx}
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gevent/libev/*.{c,h,pyx,ppyx}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gevent/*.c
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gevent/*/*.{c,h,pyx}
 %endif
 
 %if %{with python3}
 %py3_install
 
-%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gevent/*.{c,h,pyx}
-%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gevent/libev/*.{c,h,pyx,ppyx}
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gevent/*.c
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gevent/*/*.{c,h,pyx}
 %endif
 
 %clean
@@ -175,15 +177,23 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS LICENSE NOTICE README.rst TODO
 %dir %{py_sitedir}/gevent
-%attr(755,root,root) %{py_sitedir}/gevent/_semaphore.so
-%attr(755,root,root) %{py_sitedir}/gevent/ares.so
+%attr(755,root,root) %{py_sitedir}/gevent/*.so
 %{py_sitedir}/gevent/*.pxd
 %{py_sitedir}/gevent/*.py[co]
+%dir %{py_sitedir}/gevent/_ffi
+%{py_sitedir}/gevent/_ffi/*.py[co]
 %dir %{py_sitedir}/gevent/libev
 %attr(755,root,root) %{py_sitedir}/gevent/libev/_corecffi.so
 %attr(755,root,root) %{py_sitedir}/gevent/libev/corecext.so
 %{py_sitedir}/gevent/libev/libev.pxd
 %{py_sitedir}/gevent/libev/*.py[co]
+%dir %{py_sitedir}/gevent/libuv
+%{py_sitedir}/gevent/libuv/*.py[co]
+%attr(755,root,root) %{py_sitedir}/gevent/libuv/_corecffi.so
+%dir %{py_sitedir}/gevent/resolver
+%{py_sitedir}/gevent/resolver/libcares.pxd
+%{py_sitedir}/gevent/resolver/*.py[co]
+%attr(755,root,root) %{py_sitedir}/gevent/resolver/cares.so
 %{py_sitedir}/gevent-%{version}-py%{py_ver}.egg-info
 %endif
 
@@ -192,16 +202,27 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS LICENSE NOTICE README.rst TODO
 %dir %{py3_sitedir}/gevent
-%attr(755,root,root) %{py3_sitedir}/gevent/_semaphore.cpython-*.so
-%attr(755,root,root) %{py3_sitedir}/gevent/ares.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/gevent/*.cpython-*.so
 %{py3_sitedir}/gevent/__pycache__
 %{py3_sitedir}/gevent/*.pxd
 %{py3_sitedir}/gevent/*.py
+%dir %{py3_sitedir}/gevent/_ffi
+%{py3_sitedir}/gevent/_ffi/__pycache__
+%{py3_sitedir}/gevent/_ffi/*.py
+%dir %{py3_sitedir}/gevent/libuv
+%{py3_sitedir}/gevent/libuv/__pycache__
+%{py3_sitedir}/gevent/libuv/*.py
+%attr(755,root,root) %{py3_sitedir}/gevent/libuv/_corecffi.*.so
 %dir %{py3_sitedir}/gevent/libev
 %attr(755,root,root) %{py3_sitedir}/gevent/libev/_corecffi.abi3.so
 %attr(755,root,root) %{py3_sitedir}/gevent/libev/corecext.cpython-*.so
 %{py3_sitedir}/gevent/libev/__pycache__
 %{py3_sitedir}/gevent/libev/libev.pxd
 %{py3_sitedir}/gevent/libev/*.py
+%dir %{py3_sitedir}/gevent/resolver
+%{py3_sitedir}/gevent/resolver/__pycache__
+%{py3_sitedir}/gevent/resolver/*.py
+%{py3_sitedir}/gevent/resolver/libcares.pxd
+%attr(755,root,root) %{py3_sitedir}/gevent/resolver/cares.*.so
 %{py3_sitedir}/gevent-%{version}-py*.egg-info
 %endif
This page took 0.208897 seconds and 4 git commands to generate.