]> git.pld-linux.org Git - packages/python-flask-login.git/blob - python-flask-login.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-flask-login.git] / python-flask-login.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  flask-login
7 Summary:        Flask-Login provides user session management for Flask
8 Summary(pl.UTF-8):      Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask
9 Name:           python-%{module}
10 Version:        0.2.11
11 Release:        3
12 License:        MIT
13 Group:          Libraries/Python
14 Source0:        https://pypi.python.org/packages/source/F/Flask-Login/Flask-Login-%{version}.tar.gz
15 # Source0-md5:  c0a7eaf28623f0aeac4929dc05a7a064
16 URL:            https://github.com/maxcountryman/flask-login/
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 %if %{with python2}
20 BuildRequires:  python-distribute
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-distribute
24 BuildRequires:  python3-modules
25 %endif
26 Requires:       python-modules
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Flask-Login provides user session management for Flask. It handles the
32 common tasks of logging in, logging out, and remembering your users'
33 sessions over extended periods of time.
34
35 %description -l pl.UTF-8
36 Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask. Plugin
37 obsluguje najpopularniejsze przypadki uzycia: logowanie, wylogowanie,
38 zapamietywanie sesji uzytkownikow przez okreslony czas.
39
40 %package -n python3-%{module}
41 Summary:        Flask-Login provides user session management for Flask
42 Summary(pl.UTF-8):      Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask
43 Group:          Libraries/Python
44 Requires:       python3-modules
45
46 %description -n python3-%{module}
47 Flask-Login provides user session management for Flask. It handles the
48 common tasks of logging in, logging out, and remembering your users'
49 sessions over extended periods of time.
50
51 %description -n python3-%{module} -l pl.UTF-8
52 Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask. Plugin
53 obsluguje najpopularniejsze przypadki uzycia: logowanie, wylogowanie,
54 zapamietywanie sesji uzytkownikow przez okreslony czas.
55
56 %prep
57 %setup -q -n Flask-Login-%{version}
58
59 %build
60 %if %{with python2}
61 %py_build
62 %endif
63
64 %if %{with python3}
65 %py3_build
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %if %{with python2}
72 %py_install
73
74 %py_postclean
75 %endif
76
77 %if %{with python3}
78 %py3_install
79 %endif
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %if %{with python2}
85 %files
86 %defattr(644,root,root,755)
87 %doc README.markdown LICENSE
88 %{py_sitescriptdir}/flask_login.py[co]
89 %if "%{py_ver}" > "2.4"
90 %{py_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
91 %endif
92 %endif
93
94 %if %{with python3}
95 %files -n python3-%{module}
96 %defattr(644,root,root,755)
97 %doc README.markdown LICENSE
98 %{py3_sitescriptdir}/flask_login.py
99 %{py3_sitescriptdir}/__pycache__/flask_login.*.py[co]
100 %{py3_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
101 %endif
102
This page took 0.056819 seconds and 3 git commands to generate.