]> git.pld-linux.org Git - packages/python-flask-login.git/blob - python-flask-login.spec
- python 3.5 rebuild
[packages/python-flask-login.git] / python-flask-login.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  flask-login
7 Summary:        Flask-Login provides user session management for Flask
8 Summary(pl.UTF-8):      Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask
9 Name:           python-%{module}
10 Version:        0.2.11
11 Release:        2
12 License:        MIT
13 Group:          Libraries/Python
14 Source0:        https://pypi.python.org/packages/source/F/Flask-Login/Flask-Login-%{version}.tar.gz
15 # Source0-md5:  c0a7eaf28623f0aeac4929dc05a7a064
16 URL:            https://github.com/maxcountryman/flask-login/
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 %if %{with python2}
20 BuildRequires:  python-distribute
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-distribute
24 BuildRequires:  python3-modules
25 %endif
26 Requires:       python-modules
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Flask-Login provides user session management for Flask. It handles the
32 common tasks of logging in, logging out, and remembering your users'
33 sessions over extended periods of time.
34
35 %description -l pl.UTF-8
36 Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask. Plugin
37 obsluguje najpopularniejsze przypadki uzycia: logowanie, wylogowanie,
38 zapamietywanie sesji uzytkownikow przez okreslony czas.
39
40 %package -n python3-%{module}
41 Summary:        Flask-Login provides user session management for Flask
42 Summary(pl.UTF-8):      Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask
43 Group:          Libraries/Python
44 Requires:       python3-modules
45
46 %description -n python3-%{module}
47 Flask-Login provides user session management for Flask. It handles the
48 common tasks of logging in, logging out, and remembering your users'
49 sessions over extended periods of time.
50
51 %description -n python3-%{module} -l pl.UTF-8
52 Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask. Plugin
53 obsluguje najpopularniejsze przypadki uzycia: logowanie, wylogowanie,
54 zapamietywanie sesji uzytkownikow przez okreslony czas.
55
56 %prep
57 %setup -q -n Flask-Login-%{version}
58
59 %build
60 %if %{with python2}
61 %{__python} setup.py build --build-base build-2
62 %endif
63
64 %if %{with python3}
65 %{__python3} setup.py build --build-base build-3
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %if %{with python2}
72 %{__python} setup.py \
73         build --build-base build-2 \
74         install --skip-build \
75         --optimize=2 \
76         --root=$RPM_BUILD_ROOT
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %{__python3} setup.py \
83         build --build-base build-3 \
84         install --skip-build \
85         --optimize=2 \
86         --root=$RPM_BUILD_ROOT
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{with python2}
93 %files
94 %defattr(644,root,root,755)
95 %doc README.markdown LICENSE
96 %{py_sitescriptdir}/flask_login.py[co]
97 %if "%{py_ver}" > "2.4"
98 %{py_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
99 %endif
100 %endif
101
102 %if %{with python3}
103 %files -n python3-%{module}
104 %defattr(644,root,root,755)
105 %doc README.markdown LICENSE
106 %{py3_sitescriptdir}/flask_login.py
107 %{py3_sitescriptdir}/__pycache__/flask_login.*.py[co]
108 %{py3_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
109 %endif
110
This page took 0.065414 seconds and 3 git commands to generate.