]> git.pld-linux.org Git - packages/python-flask-login.git/blame - python-flask-login.spec
Release 4 (by relup.sh)
[packages/python-flask-login.git] / python-flask-login.spec
CommitLineData
44af3ef0
MK
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module flask-login
7Summary: Flask-Login provides user session management for Flask
8Summary(pl.UTF-8): Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask
9Name: python-%{module}
662a3fd3 10Version: 0.5.0
cfe7efb2 11Release: 4
44af3ef0
MK
12License: MIT
13Group: Libraries/Python
14Source0: https://pypi.python.org/packages/source/F/Flask-Login/Flask-Login-%{version}.tar.gz
662a3fd3 15# Source0-md5: a2d94aa6ae935345ebc68eb3cbb5fccd
44af3ef0
MK
16URL: https://github.com/maxcountryman/flask-login/
17BuildRequires: rpm-pythonprov
be9f8f3d 18BuildRequires: rpmbuild(macros) >= 1.710
44af3ef0
MK
19%if %{with python2}
20BuildRequires: python-distribute
21%endif
22%if %{with python3}
44af3ef0
MK
23BuildRequires: python3-modules
24%endif
25Requires: python-modules
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Flask-Login provides user session management for Flask. It handles the
31common tasks of logging in, logging out, and remembering your users'
32sessions over extended periods of time.
33
34%description -l pl.UTF-8
35Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask. Plugin
36obsluguje najpopularniejsze przypadki uzycia: logowanie, wylogowanie,
37zapamietywanie sesji uzytkownikow przez okreslony czas.
38
39%package -n python3-%{module}
40Summary: Flask-Login provides user session management for Flask
41Summary(pl.UTF-8): Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask
42Group: Libraries/Python
43Requires: python3-modules
44
45%description -n python3-%{module}
46Flask-Login provides user session management for Flask. It handles the
47common tasks of logging in, logging out, and remembering your users'
48sessions over extended periods of time.
49
50%description -n python3-%{module} -l pl.UTF-8
51Wsparcie dla zarzadzania sesja uzytkownika w aplikacjach Flask. Plugin
52obsluguje najpopularniejsze przypadki uzycia: logowanie, wylogowanie,
53zapamietywanie sesji uzytkownikow przez okreslony czas.
54
55%prep
56%setup -q -n Flask-Login-%{version}
57
58%build
59%if %{with python2}
38d6fd04 60%py_build
44af3ef0
MK
61%endif
62
63%if %{with python3}
38d6fd04 64%py3_build
44af3ef0
MK
65%endif
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%if %{with python2}
38d6fd04 71%py_install
44af3ef0
MK
72
73%py_postclean
74%endif
75
76%if %{with python3}
38d6fd04 77%py3_install
44af3ef0
MK
78%endif
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%if %{with python2}
84%files
85%defattr(644,root,root,755)
8d90d76c
AM
86%doc README.md LICENSE
87%{py_sitescriptdir}/flask_login
44af3ef0
MK
88%if "%{py_ver}" > "2.4"
89%{py_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
90%endif
91%endif
92
93%if %{with python3}
94%files -n python3-%{module}
95%defattr(644,root,root,755)
8d90d76c
AM
96%doc README.md LICENSE
97%{py3_sitescriptdir}/flask_login
44af3ef0
MK
98%{py3_sitescriptdir}/Flask_Login-%{version}-py*.egg-info
99%endif
100
This page took 0.113574 seconds and 4 git commands to generate.