]> git.pld-linux.org Git - packages/python-dulwich.git/blame - python-dulwich.spec
update url
[packages/python-dulwich.git] / python-dulwich.spec
CommitLineData
44b0d135
ER
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
91739a9d 4%bcond_without doc # don't build doc
44b0d135
ER
5
6%define module dulwich
e156b51f 7Summary: A Python implementation of the Git file formats and protocols
44b0d135
ER
8Name: python-%{module}
9Version: 0.11.2
10Release: 1
11License: GPLv2+ or ASL 2.0
12Group: Libraries/Python
13Source0: https://pypi.python.org/packages/source/d/%{module}/%{module}-%{version}.tar.gz
14# Source0-md5: ef70dce05422015373ca2704ddf281e7
2bf830f1 15URL: https://www.dulwich.io/
b7468a68 16BuildRequires: python-devel
44b0d135
ER
17BuildRequires: python-setuptools
18BuildRequires: rpm-pythonprov
56eaeb62 19BuildRequires: rpmbuild(macros) >= 1.710
91739a9d
ER
20%if %{with tests}
21BuildRequires: python-nose
22%endif
23%if %{with doc}
24BuildRequires: python-docutils
44b0d135 25BuildRequires: sphinx-pdg
91739a9d 26%endif
44b0d135
ER
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
e156b51f
ER
30Dulwich is a Python implementation of the Git file formats and
31protocols, which does not depend on Git itself.
32
33All functionality is available in pure Python. Optional C extensions
34can be built for improved performance.
35
36The project is named after the village in which Mr. and Mrs. Git live
37in the Monty Python sketch.
44b0d135
ER
38
39%prep
40%setup -q -n %{module}-%{version}
41rm -r %{module}.egg-info
42
43%build
44CC="%{__cc}" \
45CFLAGS="%{rpmcppflags} %{rpmcflags}" \
2dfc2e3a 46%py_build
44b0d135
ER
47
48%if %{with tests}
49cd dulwich/tests
50nosetests-%{py_ver} test*.py
51%endif
52
91739a9d 53%if %{with doc}
44b0d135
ER
54# sphinx fails with it from time to time with parallel build
55%{__make} -C docs -j html
56rm -r docs/build/html/_sources
91739a9d
ER
57rm docs/build/html/{.buildinfo,objects.inv}
58%endif
44b0d135
ER
59
60%install
61rm -rf $RPM_BUILD_ROOT
2dfc2e3a 62%py_install
44b0d135
ER
63
64%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*.[ch]
65%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/%{module}/tests
66%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/%{module}/contrib/test_*.py*
67%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/docs/tutorial
68
69%py_postclean
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
91739a9d 76%doc AUTHORS COPYING %{?with_doc:docs/build/html}
44b0d135
ER
77%attr(755,root,root) %{_bindir}/dul-receive-pack
78%attr(755,root,root) %{_bindir}/dul-upload-pack
79%attr(755,root,root) %{_bindir}/dulwich
80%dir %{py_sitedir}/%{module}
81%dir %{py_sitedir}/%{module}/contrib
82%{py_sitedir}/%{module}/*.py[co]
83%attr(755,root,root) %{py_sitedir}/%{module}/_*.so
84%{py_sitedir}/%{module}-%{version}-py*.egg-info
85%{py_sitedir}/%{module}/contrib/*.py[co]
This page took 0.693753 seconds and 4 git commands to generate.