]> git.pld-linux.org Git - packages/python-docker.git/blame - python-docker.spec
up to 4.3.1
[packages/python-docker.git] / python-docker.spec
CommitLineData
bdab460e
ER
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
b76f207d 5%bcond_without python3 # CPython 3.x module
bdab460e 6
72030b27 7%define module docker
b7e5dc8d 8%define egg_name docker
6f952153
ER
9%define pypi_name docker
10Summary: A Python library for the Docker Engine API
bdab460e 11Name: python-%{module}
fe1861ef 12Version: 4.3.1
039bb210 13Release: 1
bdab460e
ER
14License: Apache v2.0
15Group: Libraries/Python
8bddbbdb 16Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
fe1861ef 17# Source0-md5: ce28bd52fe2e33a26394693f01199e6c
b3671e57 18Patch0: unpin-requirements.patch
bdab460e 19URL: http://docker-py.readthedocs.org/
bdab460e 20BuildRequires: rpm-pythonprov
14f49d80 21BuildRequires: rpmbuild(macros) >= 1.710
bdab460e 22%if %{with python2}
057b22e9
ER
23BuildRequires: python-modules
24BuildRequires: python-pip
bdab460e 25BuildRequires: python-setuptools
2492f669 26BuildConflicts: python-docker < 2.0
bdab460e
ER
27%endif
28%if %{with python3}
932cfb73 29BuildRequires: python3-modules
057b22e9 30BuildRequires: python3-pip
bdab460e 31BuildRequires: python3-setuptools
2492f669 32BuildConflicts: python3-docker < 2.0
bdab460e 33%endif
99b90030
ER
34# Docker can be remote, so suggest only
35Suggests: docker >= 1.3.3
e0043ac3
JP
36# optional dep for ssh support (required by docker-compose)
37Suggests: python-paramiko >= 2.4.2
bdab460e
ER
38BuildArch: noarch
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
b76f207d 41# http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2016-May/024868.html
72030b27 42%define _noautoreq_py3egg backports.ssl-match-hostname ipaddress
b76f207d 43
bdab460e 44%description
6f952153
ER
45A Python 2 library for the Docker Engine API. It lets you do anything
46the `docker` command does, but from within Python apps - run
47containers, manage containers, manage Swarms, etc.
bdab460e
ER
48
49%package -n python3-%{module}
50Summary: An API client for docker written in Python 3
fd4f3d6f 51Group: Libraries/Python
99b90030
ER
52# Docker can be remote, so suggest only
53Suggests: docker >= 1.3.3
e0043ac3
JP
54# optional dep for ssh support (required by docker-compose)
55Suggests: python3-paramiko >= 2.4.2
bdab460e
ER
56
57%description -n python3-%{module}
6f952153
ER
58A Python 3 library for the Docker Engine API. It lets you do anything
59the `docker` command does, but from within Python apps - run
60containers, manage containers, manage Swarms, etc.
bdab460e
ER
61
62%prep
6f952153 63%setup -q -n %{pypi_name}-%{version}
99b90030 64%patch0 -p1
bdab460e 65
bdab460e
ER
66%build
67%if %{with python2}
e1c7d18e 68%py_build %{?with_tests:test}
bdab460e
ER
69%endif
70
71%if %{with python3}
e1c7d18e 72%py3_build %{?with_tests:test}
bdab460e
ER
73%endif
74
75%install
76rm -rf $RPM_BUILD_ROOT
77%if %{with python2}
e1c7d18e 78%py_install
bdab460e
ER
79%py_postclean
80%endif
81
82%if %{with python3}
e1c7d18e 83%py3_install
bdab460e
ER
84%endif
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%if %{with python2}
90%files
91%defattr(644,root,root,755)
92%doc LICENSE README.md
93%{py_sitescriptdir}/%{module}
72030b27 94%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
bdab460e
ER
95%endif
96
97%if %{with python3}
98%files -n python3-%{module}
99%defattr(644,root,root,755)
100%doc LICENSE README.md
101%{py3_sitescriptdir}/%{module}
72030b27 102%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
bdab460e 103%endif
This page took 0.19289 seconds and 4 git commands to generate.