]> git.pld-linux.org Git - packages/python-cryptography.git/blobdiff - python-cryptography.spec
update BR
[packages/python-cryptography.git] / python-cryptography.spec
index ec181e8e31cf42822d45104e6e784239fa111afa..eee5c4389054b670ff53ff718c4f681890172f87 100644 (file)
@@ -6,26 +6,31 @@
 Summary:       Crypthography library for Python 2
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 2
 Name:          python-cryptography
-Version:       0.2.2
+Version:       0.8.2
 Release:       1
-License:       Apache v2.0
+License:       Apache v2.0 or BSD
 Group:         Libraries/Python
 Source0:       https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
-# Source0-md5: f002a442c8c5c7463bf8d2f11f6c3128
+# Source0-md5: 7d33499e851300c194cbb0396de72462
 URL:           https://cryptography.io/
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 0.9.8
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.612
 %if %{with python2}
-BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-cffi >= 0.8
+BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-enum34
+BuildRequires: python-pyasn1
+BuildRequires: python-setuptools
 BuildRequires: python-six >= 1.4.1
 %endif
 %if %{with python3}
-BuildRequires: python3-devel >= 3.2
 BuildRequires: python3-cffi >= 0.8
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-pyasn1
+BuildRequires: python3-setuptools
 BuildRequires: python3-six >= 1.4.1
 %endif
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.612
 Requires:      python-cffi >= 0.8
 Requires:      python-six >= 1.4.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -50,7 +55,7 @@ Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
-takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
+takich jak szyfry symetryczne, skróty wiadomości czy funkcje
 wyprowadzające klucze.
 
 Ten pakiet zawiera moduły Pythona 2.
@@ -82,7 +87,7 @@ Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
-takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
+takich jak szyfry symetryczne, skróty wiadomości czy funkcje
 wyprowadzające klucze.
 
 Ten pakiet zawiera moduły Pythona 3.
@@ -108,22 +113,24 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %{__python} setup.py \
-       build \
-               --build-base build-2 \
-       install \
+       build   --build-base build-2 \
+       install --skip-build \
                --optimize=2 \
                --root=$RPM_BUILD_ROOT
 
 %py_postclean
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/bindings/__pycache__/*.c
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
 %endif
 
 %if %{with python3}
 %{__python3} setup.py \
-       build \
-               --build-base build-3 \
-       install \
+       build   --build-base build-3 \
+       install --skip-build \
                --optimize=2 \
                --root=$RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
 %endif
 
 %clean
@@ -132,9 +139,9 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst
+%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
 %dir %{py_sitedir}/cryptography
-%attr(755,root,root) %{py_sitedir}/cryptography/_cffi__*.so
+%attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
 %{py_sitedir}/cryptography/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat
 %{py_sitedir}/cryptography/hazmat/*.py[co]
@@ -150,6 +157,8 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
+%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
+%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives
 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
@@ -158,15 +167,17 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
 %{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
+%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
+%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
 %{py_sitedir}/cryptography-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-cryptography
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst
+%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
 %dir %{py3_sitedir}/cryptography
-%attr(755,root,root) %{py3_sitedir}/cryptography/_cffi__*.so
+%attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
 %{py3_sitedir}/cryptography/*.py
 %{py3_sitedir}/cryptography/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat
@@ -190,6 +201,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
+%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
+%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
+%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/primitives
 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
@@ -202,5 +216,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
+%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
+%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
+%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
 %endif
This page took 0.078554 seconds and 4 git commands to generate.