]> git.pld-linux.org Git - packages/python-cryptography.git/blobdiff - python-cryptography.spec
update BR
[packages/python-cryptography.git] / python-cryptography.spec
index 8685dba7534cbf1b5c3220a8b7006aa32bdebcc2..eee5c4389054b670ff53ff718c4f681890172f87 100644 (file)
@@ -6,26 +6,31 @@
 Summary:       Crypthography library for Python 2
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 2
 Name:          python-cryptography
-Version:       0.5
+Version:       0.8.2
 Release:       1
-License:       Apache v2.0
+License:       Apache v2.0 or BSD
 Group:         Libraries/Python
 Source0:       https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
-# Source0-md5: 584e5be4cc02be01e04d0fbdd5ea1e72
+# Source0-md5: 7d33499e851300c194cbb0396de72462
 URL:           https://cryptography.io/
 BuildRequires: openssl-devel >= 0.9.8
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.612
 %if %{with python2}
-BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-cffi >= 0.8
+BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-enum34
+BuildRequires: python-pyasn1
+BuildRequires: python-setuptools
 BuildRequires: python-six >= 1.4.1
 %endif
 %if %{with python3}
-BuildRequires: python3-devel >= 1:3.2
 BuildRequires: python3-cffi >= 0.8
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-pyasn1
+BuildRequires: python3-setuptools
 BuildRequires: python3-six >= 1.4.1
 %endif
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.612
 Requires:      python-cffi >= 0.8
 Requires:      python-six >= 1.4.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -50,7 +55,7 @@ Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
-takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
+takich jak szyfry symetryczne, skróty wiadomości czy funkcje
 wyprowadzające klucze.
 
 Ten pakiet zawiera moduły Pythona 2.
@@ -82,7 +87,7 @@ Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
-takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
+takich jak szyfry symetryczne, skróty wiadomości czy funkcje
 wyprowadzające klucze.
 
 Ten pakiet zawiera moduły Pythona 3.
@@ -114,6 +119,8 @@ rm -rf $RPM_BUILD_ROOT
                --root=$RPM_BUILD_ROOT
 
 %py_postclean
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/bindings/__pycache__/*.c
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
 %endif
 
 %if %{with python3}
@@ -122,6 +129,8 @@ rm -rf $RPM_BUILD_ROOT
        install --skip-build \
                --optimize=2 \
                --root=$RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
 %endif
 
 %clean
@@ -130,7 +139,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst
+%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
 %dir %{py_sitedir}/cryptography
 %attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
 %{py_sitedir}/cryptography/*.py[co]
@@ -148,6 +157,8 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
+%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
+%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives
 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
@@ -164,7 +175,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-cryptography
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst
+%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
 %dir %{py3_sitedir}/cryptography
 %attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
 %{py3_sitedir}/cryptography/*.py
@@ -190,6 +201,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
+%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
+%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
+%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/primitives
 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
This page took 0.058966 seconds and 4 git commands to generate.