]> git.pld-linux.org Git - packages/python-cryptography.git/blobdiff - python-cryptography.spec
- unconditional noarch subpackages
[packages/python-cryptography.git] / python-cryptography.spec
index e5356f5a7f8a00899b65546363a64487d5aebc04..6066d5e6645fef5ebbd5aee6abe4f2802cac365d 100644 (file)
@@ -3,36 +3,36 @@
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 %bcond_without doc     # Sphinx documentation
-%bcond_with    tests   # test target [not all dependencies are currently available in PLD]
+%bcond_without tests   # unit test
 
 Summary:       Crypthography library for Python 2
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 2
 Name:          python-cryptography
-Version:       2.7
-Release:       1
+Version:       3.3.1
+Release:       3
 License:       Apache v2.0 or BSD
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/cryptography/
 Source0:       https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
-# Source0-md5: 7dfe1035cae43569e571318f000462a4
+# Source0-md5: 6faa1a7125c500c0e1586ad342ba3b30
+#Source1Download: https://pypi.org/simple/cryptography_vectors/
+Source1:       https://files.pythonhosted.org/packages/source/c/cryptography-vectors/cryptography_vectors-%{version}.tar.gz
+# Source1-md5: 2a23fd073fc1f95a697ee96fc991e419
 URL:           https://cryptography.io/
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.1.0
 BuildRequires: rpm-pythonprov >= 5.4.15-48
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-cffi >= 1.8
+BuildRequires: python-cffi >= 1.12
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-enum34
 BuildRequires: python-pytz
 BuildRequires: python-setuptools >= 18.5
 BuildRequires: python-six >= 1.4.1
 %if %{with tests}
-BuildRequires: python-asn1crypto >= 0.21.0
-BuildRequires: python-cryptography_vectors
 %if "%{py_ver}" >= "2.7"
 BuildRequires: python-hypothesis >= 1.11.4
 %endif
-BuildRequires: python-idna >= 2.1
 BuildRequires: python-ipaddress
 BuildRequires: python-iso8601
 BuildRequires: python-pretend
@@ -41,15 +41,12 @@ BuildRequires:      python-pytz
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-cffi >= 1.8
-BuildRequires: python3-devel >= 1:3.4
+BuildRequires: python3-cffi >= 1.12
+BuildRequires: python3-devel >= 1:3.6
 BuildRequires: python3-setuptools >= 18.5
 BuildRequires: python3-six >= 1.4.1
 %if %{with tests}
-BuildRequires: python3-asn1crypto >= 0.21.0
-BuildRequires: python3-cryptography_vectors
 BuildRequires: python3-hypothesis >= 1.11.4
-BuildRequires: python3-idna >= 2.1
 BuildRequires: python3-iso8601
 BuildRequires: python3-pretend
 BuildRequires: python3-pytest >= 3.6.0
@@ -60,14 +57,14 @@ BuildRequires:      python3-pytz
 BuildRequires: python3-sphinx_rtd_theme
 BuildRequires: sphinx-pdg-3 >= 1.6.5
 %endif
-Requires:      openssl >= 1.0.1
+Requires:      openssl >= 1.1.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 cryptography is a package designed to expose cryptographic recipes and
 primitives to Python developers. Our goal is for it to be your
-"cryptographic standard library". It supports Python 2.6-2.7, Python
-3.2+, and PyPy.
+"cryptographic standard library". It supports Python 2.7, Python 3.4+,
+and PyPy.
 
 cryptography includes both high level recipes, and low level
 interfaces to common cryptographic algorithms such as symmetric
@@ -79,7 +76,7 @@ This package contains Python 2 modules.
 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
 obiektów kryptograficznych programistom Pythona. Celem jest
 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
-Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
+Pythona 2.7, Pythona 3.4+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
@@ -92,13 +89,13 @@ Ten pakiet zawiera moduły Pythona 2.
 Summary:       Crypthography library for Python 3
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 3
 Group:         Libraries/Python
-Requires:      openssl >= 1.0.1
+Requires:      openssl >= 1.1.0
 
 %description -n python3-cryptography
 cryptography is a package designed to expose cryptographic recipes and
 primitives to Python developers. Our goal is for it to be your
-"cryptographic standard library". It supports Python 2.6-2.7, Python
-3.2+, and PyPy.
+"cryptographic standard library". It supports Python 2.7, Python 3.4+,
+and PyPy.
 
 cryptography includes both high level recipes, and low level
 interfaces to common cryptographic algorithms such as symmetric
@@ -110,7 +107,7 @@ This package contains Python 3 modules.
 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
 obiektów kryptograficznych programistom Pythona. Celem jest
 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
-Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
+Pythona 2.7, Pythona 3.4+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
@@ -123,9 +120,7 @@ Ten pakiet zawiera moduły Pythona 3.
 Summary:       API documentation for cryptography module
 Summary(pl.UTF-8):     Dokumentacja API modułu cryptography
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 API documentation for cryptography module.
@@ -134,17 +129,31 @@ API documentation for cryptography module.
 Dokumentacja API modułu cryptography.
 
 %prep
-%setup -q -n cryptography-%{version}
+%setup -q -n cryptography-%{version} %{?with_tests:-a1}
+
+%if %{with tests}
+%{__mv} cryptography_vectors-%{version}/cryptography_vectors .
+%endif
 
 %build
 export CFLAGS="%{rpmcflags}"
 
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%if %{with tests}
+PYTHONPATH=$(echo $(pwd)/build-2/lib.*) \
+%{__python} -m pytest tests
+%endif
 %endif
 
-%if %{with python2}
-%py3_build %{?with_tests:test}
+%if %{with python3}
+%py3_build
+
+%if %{with tests}
+PYTHONPATH=$(echo $(pwd)/build-3/lib.*) \
+%{__python3} -m pytest tests
+%endif
 %endif
 
 %if %{with doc}
@@ -252,5 +261,5 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with doc}
 %files apidocs
 %defattr(644,root,root,755)
-%doc docs/_build/html/{_downloads,_modules,_static,development,hazmat,x509,*.html,*.js}
+%doc docs/_build/html/{_downloads,_static,development,hazmat,x509,*.html,*.js}
 %endif
This page took 0.050072 seconds and 4 git commands to generate.