]> git.pld-linux.org Git - packages/python-chardet.git/blobdiff - python-chardet.spec
- rebuild with python 3.8
[packages/python-chardet.git] / python-chardet.spec
index 0d11777c88bb650a72a96976e6276a9d7bc979fe..1764979a2a73c77fa7b4fe741bbca2af71bd7b1c 100644 (file)
@@ -1,20 +1,47 @@
-%define                module  chardet
+#
+# Conditional build:
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+%bcond_without doc     # Sphinx documentation
+%bcond_without tests   # unit tets
 
-Summary:       Character encoding auto-detection in Python
-Summary(pl.UTF-8):     Automatyczne wykrywanie kodowania znaków w Pythonie
+%define                module  chardet
+Summary:       Character encoding auto-detection in Python 2
+Summary(pl.UTF-8):     Automatyczne wykrywanie kodowania znaków w Pythonie 2
 Name:          python-%{module}
-Version:       1.0.1
-Release:       6
-License:       LGPL
+Version:       3.0.4
+Release:       3
+License:       LGPL v2.1+
 Group:         Libraries/Python
-Source0:       http://chardet.feedparser.org/download/%{module}-%{version}.tgz
-# Source0-md5: f8c510a6fac300fe0ac9a0c24a76a7ba
-URL:           http://chardet.feedparser.org/
-BuildRequires: python >= 1:2.4
-BuildRequires: python-devel >= 1:2.4
+#Source0Download: https://pypi.org/simple/chardet/
+Source0:       https://files.pythonhosted.org/packages/source/c/chardet/%{module}-%{version}.tar.gz
+# Source0-md5: 7dd1ba7f9c77e32351b0a0cfacf4055c
+URL:           https://pypi.org/project/chardet/
+%if %{with python2}
+BuildRequires: python >= 1:2.6
+BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-hypothesis
+BuildRequires: python-pytest
+%endif
+%endif
+%if %{with python3}
+BuildRequires: python3 >= 1:3.3
+BuildRequires: python3-devel >= 1:3.3
+BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-hypothesis
+BuildRequires: python3-pytest
+%endif
+%endif
+%if %{with doc}
+BuildRequires: sphinx-pdg
+%endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
-%pyrequires_eq python-modules
+BuildRequires: rpmbuild(macros) >= 1.714
+Requires:      python-modules >= 1:2.6
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -24,29 +51,82 @@ Character encoding auto-detection in Python. As smart as your browser.
 Automatyczne wykrywanie kodowania znaków w Pythonie. Tak zmyślne jak w
 przeglądarce.
 
+%package -n python3-chardet
+Summary:       Character encoding auto-detection in Python 3
+Summary(pl.UTF-8):     Automatyczne wykrywanie kodowania znaków w Pythonie 3
+Group:         Libraries/Python
+Requires:      python3-modules >= 1:3.3
+
+%description -n python3-chardet
+Character encoding auto-detection in Python. As smart as your browser.
+
+%description -n python3-chardet -l pl.UTF-8
+Automatyczne wykrywanie kodowania znaków w Pythonie. Tak zmyślne jak w
+przeglądarce.
+
+%package apidocs
+Summary:       API documentation for Python chardet module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona chardet
+Group:         Documentation
+
+%description apidocs
+API documentation for Python chardet module.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API modułu Pythona chardet.
+
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
-%{__python} setup.py build
+%if %{with python2}
+%py_build %{?with_tests:test}
+%endif
+
+%if %{with python3}
+%py3_build %{?with_tests:test}
+%endif
+
+%if %{with doc}
+PYTHONPATH=$(pwd) \
+%{__make} -C docs html
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__python} setup.py install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+%if %{with python3}
+%py3_install
+%endif
+
+%if %{with python2}
+%py_install
 
 %py_postclean
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc docs/*
-%dir %{py_sitescriptdir}/chardet
-%{py_sitescriptdir}/chardet/*.py[co]
-%if "%{py_ver}" > "2.4"
-%{py_sitescriptdir}/*.egg-info
+%doc README.rst
+%attr(755,root,root) %{_bindir}/chardetect
+%{py_sitescriptdir}/chardet
+%{py_sitescriptdir}/chardet-%{version}-py*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-chardet
+%defattr(644,root,root,755)
+%doc README.rst
+%{py3_sitescriptdir}/chardet
+%{py3_sitescriptdir}/chardet-%{version}-py*.egg-info
+%endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/_build/html/{_modules,_static,api,*.html,*.js}
 %endif
This page took 0.103059 seconds and 4 git commands to generate.