]> git.pld-linux.org Git - packages/python-bs4.git/commitdiff
- added lxml patch (fix for lxml 4.4+); release 3 auto/th/python-bs4-4.6.0-3
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Jan 2021 20:31:03 +0000 (21:31 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Jan 2021 20:31:03 +0000 (21:31 +0100)
python-bs4-lxml.patch [new file with mode: 0644]
python-bs4.spec

diff --git a/python-bs4-lxml.patch b/python-bs4-lxml.patch
new file mode 100644 (file)
index 0000000..4a2ce43
--- /dev/null
@@ -0,0 +1,14 @@
+--- beautifulsoup4-4.6.0/bs4/element.py.orig   2017-05-07 14:15:39.000000000 +0200
++++ beautifulsoup4-4.6.0/bs4/element.py        2021-01-23 20:55:10.229088076 +0100
+@@ -29,6 +29,11 @@
+ class NamespacedAttribute(unicode):
+     def __new__(cls, prefix, name, namespace=None):
++        if not name:
++            # This is the default namespace. Its name "has no value"
++            # per https://www.w3.org/TR/xml-names/#defaulting
++            name = None
++
+         if name is None:
+             obj = unicode.__new__(cls, prefix)
+         elif prefix is None:
index f98a8949dae056e4ab4d025c11062d941c0880e4..ad4660518699012881169166f7512819708591e4 100644 (file)
@@ -10,13 +10,14 @@ Summary:    beautifulsoup4 - Screen-scraping library
 Summary(pl.UTF-8):     beautifulsoup4 - biblioteka przechwytująca wyjście
 Name:          python-%{module}
 Version:       4.6.0
-Release:       2
+Release:       3
 License:       MIT
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/beautifulsoup4/
 Source0:       https://files.pythonhosted.org/packages/source/b/beautifulsoup4/beautifulsoup4-%{version}.tar.gz
 # Source0-md5: c17714d0f91a23b708a592cb3c697728
 Patch0:                test_suite.patch
+Patch1:                %{name}-lxml.patch
 URL:           https://www.crummy.com/software/BeautifulSoup/
 BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: rpm-pythonprov
@@ -73,6 +74,7 @@ Dokumentacja API modułu Pythona beautifulsoup4.
 %prep
 %setup -q -n beautifulsoup4-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %if %{with python2}
This page took 0.152676 seconds and 4 git commands to generate.