]> git.pld-linux.org Git - packages/python-billiard.git/blob - python-billiard.spec
86122ab364310c52621be7ab285cfc61da931865
[packages/python-billiard.git] / python-billiard.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  billiard
9 Summary:        Multiprocessing Pool Extensions
10 Name:           python-%{module}
11 Version:        3.3.0.21
12 Release:        5
13 License:        BSD
14 Group:          Libraries/Python
15 Source0:        https://pypi.python.org/packages/source/b/billiard/%{module}-%{version}.tar.gz
16 # Source0-md5:  5304a48344d8f7e821d06f57da8af1f4
17 Patch0:         unittest2.patch
18 URL:            https://github.com/celery/billiard
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 %if %{with python2}
22 BuildRequires:  python-devel >= 1:2.7
23 BuildRequires:  python-setuptools
24 %if %{with tests}
25 BuildRequires:  python-mock
26 BuildRequires:  python-nose
27 %endif
28 %if %{with doc}
29 BuildRequires:  sphinx-pdg
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-devel
34 BuildRequires:  python3-setuptools
35 %if %{with tests}
36 BuildRequires:  python3-nose
37 %endif
38 %endif
39 Requires:       python-modules
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 billiard is a fork of the Python 2.7 multiprocessing package. The
44 multiprocessing package itself is a renamed and updated version of R
45 Oudkerk's pyprocessing package. This standalone variant is intended to
46 be compatible with Python 2.4 and 2.5, and will draw its
47 fixes/improvements from python-trunk.
48
49 %package -n python3-%{module}
50 Summary:        Multiprocessing Pool Extensions
51 Group:          Libraries/Python
52 Requires:       python3-modules
53 BuildArch:      noarch
54
55 %description -n python3-%{module}
56 billiard is a fork of the Python 2.7 multiprocessing package. The
57 multiprocessing package itself is a renamed and updated version of R
58 Oudkerk's pyprocessing package. This standalone variant is intended to
59 be compatible with Python 2.4 and 2.5, and will draw its
60 fixes/improvements from python-trunk.
61
62 %package apidocs
63 Summary:        %{module} API documentation
64 Summary(pl.UTF-8):      Dokumentacja API %{module}
65 Group:          Documentation
66 %if "%{_rpmversion}" >= "5"
67 BuildArch:      noarch
68 %endif
69
70 %description apidocs
71 API documentation for %{module}.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API %{module}.
75
76 %prep
77 %setup -q -n %{module}-%{version}
78 %patch0 -p1
79
80 %build
81 %if %{with python2}
82 CC="%{__cc}" \
83 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
84 %py_build %{?with_tests:test}
85
86 %if %{with doc}
87 cd Doc
88 PYTHONPATH=../build-2/lib sphinx-build -b html -d .build/doctrees . .build/html
89 rm -rf .build/html/_sources
90 cd ..
91 %endif
92 %endif
93
94 %if %{with python3}
95 CC="%{__cc}" \
96 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
97 %py3_build %{?with_tests:test}
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %if %{with python2}
104 %py_install
105
106 %py_postclean
107 %endif
108
109 %if %{with python3}
110 %py3_install
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %if %{with python2}
117 %files
118 %defattr(644,root,root,755)
119 %doc *.txt README.rst
120 %dir %{py_sitedir}/%{module}
121 %{py_sitedir}/%{module}/*.py[co]
122 %dir %{py_sitedir}/%{module}/dummy
123 %{py_sitedir}/%{module}/dummy/*.py[co]
124 %dir %{py_sitedir}/%{module}/py2
125 %{py_sitedir}/%{module}/py2/*.py[co]
126 %dir %{py_sitedir}/%{module}/tests
127 %{py_sitedir}/%{module}/tests/*.py[co]
128 %{py_sitedir}/_%{module}.so
129 %{py_sitedir}/%{module}-%{version}-py*.egg-info
130 %endif
131
132 %if %{with python3}
133 %files -n python3-%{module}
134 %defattr(644,root,root,755)
135 %doc *.txt README.rst
136 %{py3_sitescriptdir}/%{module}
137 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
138 %endif
139
140 %if %{with doc}
141 %files apidocs
142 %defattr(644,root,root,755)
143 %doc Doc/.build/html/*
144 %endif
This page took 0.075022 seconds and 2 git commands to generate.