]> git.pld-linux.org Git - packages/python-billiard.git/blame - python-billiard.spec
- release 2 (by relup.sh)
[packages/python-billiard.git] / python-billiard.spec
CommitLineData
365e6511
JK
1#
2# Conditional build:
5a836b5c
JB
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
365e6511
JK
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module billiard
9Summary: Multiprocessing Pool Extensions
5a836b5c 10Summary(pl.UTF-8): Rozszerzenia puli procesów
365e6511 11Name: python-%{module}
5a836b5c 12Version: 3.6.3.0
a2f3b60e 13Release: 2
365e6511
JK
14License: BSD
15Group: Libraries/Python
5a836b5c
JB
16#Source0Download: https://pypi.org/simple/billiard/
17Source0: https://files.pythonhosted.org/packages/source/b/billiard/%{module}-%{version}.tar.gz
18# Source0-md5: 49f47bc7c6868e17591d8018d542b984
365e6511
JK
19URL: https://github.com/celery/billiard
20BuildRequires: rpm-pythonprov
5a836b5c 21BuildRequires: rpmbuild(macros) >= 1.752
365e6511 22%if %{with python2}
0c138dae 23BuildRequires: python-devel >= 1:2.7
5a836b5c 24BuildRequires: python-setuptools >= 40.0.0
365e6511 25%if %{with tests}
5a836b5c
JB
26BuildRequires: python-case >= 1.3.1
27BuildRequires: python-psutil
28BuildRequires: python-pytest
365e6511
JK
29%endif
30%if %{with doc}
31BuildRequires: sphinx-pdg
32%endif
33%endif
34%if %{with python3}
5a836b5c
JB
35BuildRequires: python3-devel >= 1:3.5
36BuildRequires: python3-setuptools >= 40.0.0
365e6511 37%if %{with tests}
5a836b5c
JB
38BuildRequires: python3-case >= 1.3.1
39BuildRequires: python3-psutil
40BuildRequires: python3-pytest
365e6511
JK
41%endif
42%endif
5a836b5c 43Requires: python-modules >= 1:2.7
365e6511
JK
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47billiard is a fork of the Python 2.7 multiprocessing package. The
48multiprocessing package itself is a renamed and updated version of R
5a836b5c
JB
49Oudkerk's pyprocessing package. This standalone variant draws its
50fixes/improvements from python-trunk and provides additional bug fixes
51and improvements.
52
53%description -l pl.UTF-8
54billiard to odgałęzienie pakietu multiprocessing z Pythona 2.7. Pakiet
55multiprocessing to uaktualniona wersja pakietu pyprocessing R Oudkerka
56ze zmienioną nazwą. Samodzielny wariant czerpie poprawki i
57usprawnienia z najświeższego Pythona, ponadto zawiera dodatkowe
58poprawki błędów i ulepszenia.
365e6511
JK
59
60%package -n python3-%{module}
61Summary: Multiprocessing Pool Extensions
5a836b5c 62Summary(pl.UTF-8): Rozszerzenia puli procesów
365e6511 63Group: Libraries/Python
5a836b5c
JB
64Requires: python3-modules >= 1:3.5
65%{?noarchpackage}
365e6511
JK
66
67%description -n python3-%{module}
68billiard is a fork of the Python 2.7 multiprocessing package. The
69multiprocessing package itself is a renamed and updated version of R
5a836b5c
JB
70Oudkerk's pyprocessing package. This standalone variant draws its
71fixes/improvements from python-trunk and provides additional bug fixes
72and improvements.
73
74%description -n python3-%{module} -l pl.UTF-8
75billiard to odgałęzienie pakietu multiprocessing z Pythona 2.7. Pakiet
76multiprocessing to uaktualniona wersja pakietu pyprocessing R Oudkerka
77ze zmienioną nazwą. Samodzielny wariant czerpie poprawki i
78usprawnienia z najświeższego Pythona, ponadto zawiera dodatkowe
79poprawki błędów i ulepszenia.
365e6511
JK
80
81%package apidocs
5a836b5c
JB
82Summary: API documentation for billiard module
83Summary(pl.UTF-8): Dokumentacja API modułu billiard
365e6511 84Group: Documentation
5a836b5c 85%{?noarchpackage}
365e6511
JK
86
87%description apidocs
5a836b5c 88API documentation for billiard module.
365e6511
JK
89
90%description apidocs -l pl.UTF-8
5a836b5c 91Dokumentacja API modułu billiard.
365e6511
JK
92
93%prep
94%setup -q -n %{module}-%{version}
365e6511
JK
95
96%build
97%if %{with python2}
5a836b5c 98%py_build
365e6511 99
5a836b5c
JB
100%if %{with tests}
101PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
102%{__python} -m pytest t/unit
365e6511
JK
103%endif
104%endif
105
106%if %{with python3}
5a836b5c
JB
107%py3_build
108
109%if %{with tests}
110PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
111%{__python3} -m pytest t/unit
112%endif
113%endif
114
115%if %{with doc}
116cd Doc
117PYTHONPATH=$(pwd)/../build-3/lib \
118sphinx-build -b html -d .build/doctrees . .build/html
119cd ..
365e6511
JK
120%endif
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125%if %{with python2}
747a9fbf 126%py_install
365e6511
JK
127
128%py_postclean
129%endif
130
131%if %{with python3}
747a9fbf 132%py3_install
365e6511
JK
133%endif
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%if %{with python2}
139%files
140%defattr(644,root,root,755)
5a836b5c 141%doc CHANGES.txt LICENSE.txt README.rst
365e6511
JK
142%dir %{py_sitedir}/%{module}
143%{py_sitedir}/%{module}/*.py[co]
144%dir %{py_sitedir}/%{module}/dummy
145%{py_sitedir}/%{module}/dummy/*.py[co]
5a836b5c 146%attr(755,root,root) %{py_sitedir}/_billiard.so
365e6511
JK
147%{py_sitedir}/%{module}-%{version}-py*.egg-info
148%endif
149
150%if %{with python3}
151%files -n python3-%{module}
152%defattr(644,root,root,755)
5a836b5c 153%doc CHANGES.txt LICENSE.txt README.rst
365e6511
JK
154%{py3_sitescriptdir}/%{module}
155%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
156%endif
157
158%if %{with doc}
159%files apidocs
160%defattr(644,root,root,755)
5a836b5c 161%doc Doc/.build/html/{_static,library,*.html,*.js}
365e6511 162%endif
This page took 0.10709 seconds and 4 git commands to generate.