]> git.pld-linux.org Git - packages/python-M2Crypto.git/blobdiff - python-M2Crypto.spec
perl -pi -e "s/pld-list\@pld.org.pl/feedback\@pld.org.pl/"
[packages/python-M2Crypto.git] / python-M2Crypto.spec
index b9b905ce40e5b777620cd985cd17153e374cd1de..f66a1b150ccd02357e8e238d449a5cb3576cc7ba 100644 (file)
@@ -1,26 +1,22 @@
 Summary:       Python interface to OpenSSL
+Summary(pl):   Interfejs Pythona do OpenSSL
 Name:          python-M2Crypto
 Version:       0.06
-Release:       1
+Release:       2
 License:       BSD-style
 Source0:       http://www.pobox.org.sg/home/ngps/m2/m2crypto-%{version}.zip
 URL:           http://www.pobox.org.sg/home/ngps/m2/
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
-Requires:      python >= 1.5.2
+%requires_eq   python
 BuildRequires: python-devel >= 1.5.2
 BuildRequires: openssl-devel >= 0.9.6
 BuildRequires: swig 
+BuildRequires: rpm-pythonprov
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
-%define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
-%define python_includedir  %{_includedir}/python%{python_version}
-%define python_libdir      %{python_prefix}/lib/python%{python_version}
-%define python_sitedir     %{python_libdir}/site-packages
-%define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
-%define python_compile     python -c "import compileall; compileall.compile_dir('.')"
+%include /usr/lib/rpm/macros.python
 
 %description
 M2Crypto makes accessible to the Python programmer the following:
@@ -31,21 +27,25 @@ M2Crypto makes accessible to the Python programmer the following:
 M2Crypto is released under a very liberal BSD-style licence. See 
 LICENCE for details.
 
+%description -l pl
+M2Crypto udostêpnia z poziomu Pythona nastêpuj±ce funkcje:
+- DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
+- SSL do implementacji klientów i serwerów
+- S/MIME v2.
+
 %prep
 %setup -q -n m2crypto-%{version}
 
 %build
-make -C swig INCLUDE="-I. -I%{python_includedir}"
-cd M2Crypto
-%{python_compile}
-%{python_compile_opt}
+%{__make} -C swig INCLUDE="-I. -I%{py_incdir}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{python_sitedir}
+install -d $RPM_BUILD_ROOT%{py_sitedir}
 
-find M2Crypto -name \*.py | xargs -r rm -f
-cp -a M2Crypto $RPM_BUILD_ROOT%{python_sitedir}
+cp -a M2Crypto $RPM_BUILD_ROOT%{py_sitedir}
+%{py_comp} $RPM_BUILD_ROOT%{py_sitedir}
+%{py_ocomp} $RPM_BUILD_ROOT%{py_sitedir}
 
 gzip -9nf BUGS CHANGES INSTALL LICENCE README STORIES
 
@@ -55,4 +55,4 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc *.gz doc/*.html demo 
-%{python_sitedir}/M2Crypto
+%{py_sitedir}/M2Crypto
This page took 0.133878 seconds and 4 git commands to generate.