]> git.pld-linux.org Git - packages/python-Cython.git/commitdiff
- new, based on python-Pyrex.
authorwitekfl <witekfl@pld-linux.org>
Sat, 3 May 2008 11:11:44 +0000 (11:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-Cython.spec -> 1.1

python-Cython.spec [new file with mode: 0644]

diff --git a/python-Cython.spec b/python-Cython.spec
new file mode 100644 (file)
index 0000000..4955374
--- /dev/null
@@ -0,0 +1,72 @@
+
+%define                module  Cython
+
+Summary:       Language for writing Python Extension Modules
+Summary(pl.UTF-8):     Język służący do pisania modułów rozszerzających Pythona
+Name:          python-%{module}
+Version:       0.9.6.14
+Release:       1
+License:       PSF
+Group:         Libraries/Python
+Source0:       http://www.cython.org/%{module}-%{version}.tar.gz
+# Source0-md5: 3fd3a8baa2deb0155ed8b37ee320d02b
+URL:           http://www.cython.org/
+BuildRequires: python >= 1:2.5
+BuildRequires: rpm-pythonprov
+%pyrequires_eq python-libs
+%pyrequires_eq python-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _noautocompressdoc      *.c
+
+%description
+Cython lets you write code that mixes Python and C data types any way
+you want, and compiles it into a C extension for Python.
+Cython is based on PyRex.
+
+%description -l pl.UTF-8
+Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
+w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
+Cython jest oparty na PyReksie.
+
+%package examples
+Summary:       Examples for Pyrex language
+Summary(pl.UTF-8):     Przykłady programów w języku Pyrex
+Group:         Libraries/Python
+Requires:      %{name} = %{version}-%{release}
+
+%description examples
+This package contains example programs for Pyrex language.
+
+%description examples -l pl.UTF-8
+Pakiet zawierający przykładowe programy napisane w języku Pyrex.
+
+%prep
+%setup -q -n %{module}-%{version}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%{__python} setup.py install \
+       --root=$RPM_BUILD_ROOT \
+       --install-purelib=%{py_sitescriptdir} \
+       -O2
+
+find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
+
+cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
+%attr(755,root,root) %{_bindir}/*
+%{py_sitescriptdir}/Cython
+%{py_sitescriptdir}/Cython-*.egg-info
+
+%files examples
+%defattr(644,root,root,755)
+%{_examplesdir}/%{name}-%{version}
This page took 0.061249 seconds and 4 git commands to generate.