]> git.pld-linux.org Git - packages/python-Cython.git/blobdiff - python-Cython.spec
- up to 0.29.24
[packages/python-Cython.git] / python-Cython.spec
index cb18e6c9bfffd62bdb0cdcea26bd6632313c858a..fce36913c3bf4252bbab8bd238780f3f0023c202 100644 (file)
@@ -2,31 +2,35 @@
 # Conditional build:
 %bcond_without python2         # CPython 2.x module
 %bcond_without python3         # CPython 3.x module
+%bcond_without apidocs         # Sphinx documentation
+%bcond_with    tests           # test suite (SLOOOOW)
 
 %define                module  Cython
 
 Summary:       Language for writing Python Extension Modules (Python 2.x version)
 Summary(pl.UTF-8):     Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 2.x)
 Name:          python-%{module}
-Version:       0.21
+Version:       0.29.24
 Release:       1
 License:       Apache v2.0
 Group:         Libraries/Python
-Source0:       http://www.cython.org/release/%{module}-%{version}.tar.gz
-# Source0-md5: 6c9c4d19ba485fe8cd88e23b57ac7886
-URL:           http://www.cython.org/
+#Source0Download: https://pypi.org/simple/cython/
+Source0:       https://files.pythonhosted.org/packages/source/c/cython/%{module}-%{version}.tar.gz
+# Source0-md5: 81aff945f5bfdfb86e7a5d24f5467668
+URL:           http://cython.org/
+BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
 BuildRequires: python >= 1:2.6
 BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3 >= 1:3.2
-BuildRequires: python3-2to3 >= 1:3.2
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-distribute
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3 >= 1:3.3
+BuildRequires: python3-devel >= 1:3.3
+BuildRequires: python3-setuptools
 %endif
 BuildRequires: rpm-pythonprov
+%{?with_apidocs:BuildRequires: sphinx-pdg-3 >= 1.8}
 Requires:      python-devel >= 1:2.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -50,7 +54,7 @@ Ten pakiet zawiera moduł Cython dla Pythona 2.x.
 Summary:       Language for writing Python Extension Modules (Python 3.x version)
 Summary(pl.UTF-8):     Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 3.x)
 Group:         Libraries/Python
-Requires:      python3-devel >= 1:3.2
+Requires:      python3-devel >= 1:3.3
 
 %description -n python3-Cython
 Cython lets you write code that mixes Python and C data types any way
@@ -66,6 +70,17 @@ Cython jest oparty na Pyreksie.
 
 Ten pakiet zawiera moduł Cython dla Pythona 3.x.
 
+%package apidocs
+Summary:       API documentation for Cython module
+Summary(pl.UTF-8):     Dokumentacja API modułu Cython
+Group:         Documentation
+
+%description apidocs
+API documentation for Cython module.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API modułu Cython.
+
 %package examples
 Summary:       Examples for Cython language
 Summary(pl.UTF-8):     Przykłady programów w języku Cython
@@ -83,17 +98,24 @@ Pakiet zawierający przykładowe programy napisane w języku Cython.
 
 %build
 %if %{with python2}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build \
-       --build-base build-2
+%py_build
+
+%if %{with tests}
+%{__python} runtests.py
+%endif
 %endif
 
 %if %{with python3}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build \
-       --build-base build-3
+%py3_build
+
+%if %{with tests}
+%{__python3} runtests.py \
+       SPHINXBUILD=sphinx-build-3
+%endif
+%endif
+
+%if %{with apidocs}
+%{__make} -C docs html
 %endif
 
 %install
@@ -101,13 +123,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %if %{with python3}
-%{__python3} setup.py \
-       build \
-               --build-base build-3 \
-       install \
-               --optimize=2 \
-               --skip-build \
-               --root=$RPM_BUILD_ROOT
+%py3_install
 
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cython{,3}
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cythonize{,3}
@@ -115,13 +131,7 @@ install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %endif
 
 %if %{with python2}
-%{__python} setup.py \
-       build \
-               --build-base build-2 \
-       install \
-               --optimize=2 \
-               --skip-build \
-               --root=$RPM_BUILD_ROOT
+%py_install
 
 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
 %endif
@@ -134,7 +144,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
+%doc CHANGES.rst COPYING.txt README.rst ToDo.txt USAGE.txt
 %attr(755,root,root) %{_bindir}/cython
 %attr(755,root,root) %{_bindir}/cythonize
 %attr(755,root,root) %{_bindir}/cygdb
@@ -147,7 +157,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-Cython
 %defattr(644,root,root,755)
-%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
+%doc CHANGES.rst COPYING.txt README.rst ToDo.txt USAGE.txt
 %attr(755,root,root) %{_bindir}/cython3
 %attr(755,root,root) %{_bindir}/cythonize3
 %attr(755,root,root) %{_bindir}/cygdb3
@@ -158,6 +168,12 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/Cython-%{version}-py*.egg-info
 %endif
 
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/build/html/{_images,_static,src,*.html,*.js}
+%endif
+
 %files examples
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
This page took 0.111 seconds and 4 git commands to generate.