]> git.pld-linux.org Git - packages/python-Cython.git/blobdiff - python-Cython.spec
- use rpm python macros
[packages/python-Cython.git] / python-Cython.spec
index cb18e6c9bfffd62bdb0cdcea26bd6632313c858a..c6862d3f8eb314b307be02627271d4431bc72a89 100644 (file)
@@ -8,23 +8,25 @@
 Summary:       Language for writing Python Extension Modules (Python 2.x version)
 Summary(pl.UTF-8):     Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 2.x)
 Name:          python-%{module}
-Version:       0.21
-Release:       1
+Version:       0.23.4
+Release:       3
 License:       Apache v2.0
 Group:         Libraries/Python
-Source0:       http://www.cython.org/release/%{module}-%{version}.tar.gz
-# Source0-md5: 6c9c4d19ba485fe8cd88e23b57ac7886
-URL:           http://www.cython.org/
+Source0:       http://cython.org/release/%{module}-%{version}.tar.gz
+# Source0-md5: 157df1f69bcec6b56fd97e0f2e057f6e
+URL:           http://cython.org/
+BuildRequires: rpmbuild(macros) >= 1.710
 %if %{with python2}
 BuildRequires: python >= 1:2.6
 BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
 BuildRequires: python3 >= 1:3.2
 BuildRequires: python3-2to3 >= 1:3.2
 BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-distribute
 BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-setuptools
 %endif
 BuildRequires: rpm-pythonprov
 Requires:      python-devel >= 1:2.6
@@ -83,17 +85,11 @@ Pakiet zawierający przykładowe programy napisane w języku Cython.
 
 %build
 %if %{with python2}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build \
-       --build-base build-2
+%py_build
 %endif
 
 %if %{with python3}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build \
-       --build-base build-3
+%py3_build
 %endif
 
 %install
@@ -101,13 +97,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %if %{with python3}
-%{__python3} setup.py \
-       build \
-               --build-base build-3 \
-       install \
-               --optimize=2 \
-               --skip-build \
-               --root=$RPM_BUILD_ROOT
+%py3_install
 
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cython{,3}
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cythonize{,3}
@@ -115,13 +105,7 @@ install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %endif
 
 %if %{with python2}
-%{__python} setup.py \
-       build \
-               --build-base build-2 \
-       install \
-               --optimize=2 \
-               --skip-build \
-               --root=$RPM_BUILD_ROOT
+%py_install
 
 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
 %endif
This page took 0.026917 seconds and 4 git commands to generate.