]> git.pld-linux.org Git - packages/python-Cython.git/blobdiff - python-Cython.spec
- updated to 0.28.4
[packages/python-Cython.git] / python-Cython.spec
index 29c736a2da60ce3c3ed52a756d3ff90840bb55f6..4e760c40033c26ae7f25c0c27f1aaa4bc74ddbfe 100644 (file)
@@ -2,18 +2,21 @@
 # Conditional build:
 %bcond_without python2         # CPython 2.x module
 %bcond_without python3         # CPython 3.x module
+%bcond_without apidocs         # Sphinx documentation
+%bcond_with    tests           # test suite (SLOOOOW)
 
 %define                module  Cython
 
 Summary:       Language for writing Python Extension Modules (Python 2.x version)
 Summary(pl.UTF-8):     Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 2.x)
 Name:          python-%{module}
-Version:       0.24
+Version:       0.28.4
 Release:       1
 License:       Apache v2.0
 Group:         Libraries/Python
-Source0:       http://cython.org/release/%{module}-%{version}.tar.gz
-# Source0-md5: 14fbc970f4a856845e633cbc09e61048
+#Source0Download: https://pypi.org/simple/cython/
+Source0:       https://files.pythonhosted.org/packages/source/c/cython/%{module}-%{version}.tar.gz
+# Source0-md5: fa01ba71b1e3136b0f12e3ed8958ea02
 URL:           http://cython.org/
 BuildRequires: rpmbuild(macros) >= 1.710
 %if %{with python2}
@@ -22,13 +25,12 @@ BuildRequires:      python-devel >= 1:2.6
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3 >= 1:3.2
-BuildRequires: python3-2to3 >= 1:3.2
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3 >= 1:3.3
+BuildRequires: python3-devel >= 1:3.3
 BuildRequires: python3-setuptools
 %endif
 BuildRequires: rpm-pythonprov
+%{?with_apidocs:BuildRequires: sphinx-pdg}
 Requires:      python-devel >= 1:2.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -52,7 +54,7 @@ Ten pakiet zawiera moduł Cython dla Pythona 2.x.
 Summary:       Language for writing Python Extension Modules (Python 3.x version)
 Summary(pl.UTF-8):     Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 3.x)
 Group:         Libraries/Python
-Requires:      python3-devel >= 1:3.2
+Requires:      python3-devel >= 1:3.3
 
 %description -n python3-Cython
 Cython lets you write code that mixes Python and C data types any way
@@ -68,6 +70,17 @@ Cython jest oparty na Pyreksie.
 
 Ten pakiet zawiera moduł Cython dla Pythona 3.x.
 
+%package apidocs
+Summary:       API documentation for Cython module
+Summary(pl.UTF-8):     Dokumentacja API modułu Cython
+Group:         Documentation
+
+%description apidocs
+API documentation for Cython module.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API modułu Cython.
+
 %package examples
 Summary:       Examples for Cython language
 Summary(pl.UTF-8):     Przykłady programów w języku Cython
@@ -86,10 +99,22 @@ Pakiet zawierający przykładowe programy napisane w języku Cython.
 %build
 %if %{with python2}
 %py_build
+
+%if %{with tests}
+%{__python} runtests.py
+%endif
 %endif
 
 %if %{with python3}
 %py3_build
+
+%if %{with tests}
+%{__python3} runtests.py
+%endif
+%endif
+
+%if %{with apidocs}
+%{__make} -C docs html
 %endif
 
 %install
@@ -118,7 +143,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
+%doc CHANGES.rst COPYING.txt README.rst ToDo.txt USAGE.txt
 %attr(755,root,root) %{_bindir}/cython
 %attr(755,root,root) %{_bindir}/cythonize
 %attr(755,root,root) %{_bindir}/cygdb
@@ -131,7 +156,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-Cython
 %defattr(644,root,root,755)
-%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
+%doc CHANGES.rst COPYING.txt README.rst ToDo.txt USAGE.txt
 %attr(755,root,root) %{_bindir}/cython3
 %attr(755,root,root) %{_bindir}/cythonize3
 %attr(755,root,root) %{_bindir}/cygdb3
@@ -142,6 +167,12 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/Cython-%{version}-py*.egg-info
 %endif
 
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/build/html/{_images,_static,src,*.html,*.js}
+%endif
+
 %files examples
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
This page took 0.078192 seconds and 4 git commands to generate.