]> git.pld-linux.org Git - packages/python-Cython.git/blob - python-Cython.spec
- build package in build stage
[packages/python-Cython.git] / python-Cython.spec
1
2 %define         module  Cython
3
4 Summary:        Language for writing Python Extension Modules
5 Summary(pl.UTF-8):      Język służący do pisania modułów rozszerzających Pythona
6 Name:           python-%{module}
7 Version:        0.20.1
8 Release:        1
9 License:        Apache v2.0
10 Group:          Libraries/Python
11 Source0:        http://www.cython.org/release/%{module}-%{version}.tar.gz
12 # Source0-md5:  52431696c64e618036537c4d9aa79d99
13 URL:            http://www.cython.org/
14 BuildRequires:  python >= 1:2.5
15 BuildRequires:  python-devel
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-libs
18 %pyrequires_eq  python-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _noautocompressdoc      *.c
22
23 %description
24 Cython lets you write code that mixes Python and C data types any way
25 you want, and compiles it into a C extension for Python. Cython is
26 based on Pyrex.
27
28 %description -l pl.UTF-8
29 Cython pozwala pisać kod zawierający dane Pythona i języka C połączone
30 w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
31 Cython jest oparty na Pyreksie.
32
33 %package examples
34 Summary:        Examples for Cython language
35 Summary(pl.UTF-8):      Przykłady programów w języku Cython
36 Group:          Libraries/Python
37 Requires:       %{name} = %{version}-%{release}
38
39 %description examples
40 This package contains example programs for Cython language.
41
42 %description examples -l pl.UTF-8
43 Pakiet zawierający przykładowe programy napisane w języku Cython.
44
45 %prep
46 %setup -q -n %{module}-%{version}
47
48 %build
49 CC="%{__cc}" \
50 CFLAGS="%{rpmcflags}" \
51 %{__python} setup.py build
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %{__python} setup.py install \
58         --root=$RPM_BUILD_ROOT \
59         --install-purelib=%{py_sitescriptdir} \
60         -O2
61
62 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
63
64 cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
72 %attr(755,root,root) %{_bindir}/cython
73 %attr(755,root,root) %{_bindir}/cygdb
74 %{py_sitedir}/cython.py[co]
75 %{py_sitedir}/Cython
76 %{py_sitedir}/pyximport
77 %{py_sitedir}/Cython-*.egg-info
78
79 %files examples
80 %defattr(644,root,root,755)
81 %{_examplesdir}/%{name}-%{version}
This page took 0.079505 seconds and 4 git commands to generate.