]> git.pld-linux.org Git - packages/python-Cython.git/blob - python-Cython.spec
- updated to 0.23.1
[packages/python-Cython.git] / python-Cython.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # CPython 2.x module
4 %bcond_without  python3         # CPython 3.x module
5
6 %define         module  Cython
7
8 Summary:        Language for writing Python Extension Modules (Python 2.x version)
9 Summary(pl.UTF-8):      Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 2.x)
10 Name:           python-%{module}
11 Version:        0.23.1
12 Release:        1
13 License:        Apache v2.0
14 Group:          Libraries/Python
15 Source0:        http://cython.org/release/%{module}-%{version}.tar.gz
16 # Source0-md5:  db3c5b365e1c3f71c7cd90e96473a3ab
17 URL:            http://cython.org/
18 %if %{with python2}
19 BuildRequires:  python >= 1:2.6
20 BuildRequires:  python-devel >= 1:2.6
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3 >= 1:3.2
25 BuildRequires:  python3-2to3 >= 1:3.2
26 BuildRequires:  python3-devel >= 1:3.2
27 BuildRequires:  python3-modules >= 1:3.2
28 BuildRequires:  python3-setuptools
29 %endif
30 BuildRequires:  rpm-pythonprov
31 Requires:       python-devel >= 1:2.6
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautocompressdoc      *.c
35
36 %description
37 Cython lets you write code that mixes Python and C data types any way
38 you want, and compiles it into a C extension for Python. Cython is
39 based on Pyrex.
40
41 This package contains Cython module for Python 2.x.
42
43 %description -l pl.UTF-8
44 Cython pozwala pisać kod zawierający dane Pythona i języka C połączone
45 w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
46 Cython jest oparty na Pyreksie.
47
48 Ten pakiet zawiera moduł Cython dla Pythona 2.x.
49
50 %package -n python3-Cython
51 Summary:        Language for writing Python Extension Modules (Python 3.x version)
52 Summary(pl.UTF-8):      Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 3.x)
53 Group:          Libraries/Python
54 Requires:       python3-devel >= 1:3.2
55
56 %description -n python3-Cython
57 Cython lets you write code that mixes Python and C data types any way
58 you want, and compiles it into a C extension for Python. Cython is
59 based on Pyrex.
60
61 This package contains Cython module for Python 3.x.
62
63 %description -n python3-Cython -l pl.UTF-8
64 Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
65 w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
66 Cython jest oparty na Pyreksie.
67
68 Ten pakiet zawiera moduł Cython dla Pythona 3.x.
69
70 %package examples
71 Summary:        Examples for Cython language
72 Summary(pl.UTF-8):      Przykłady programów w języku Cython
73 Group:          Libraries/Python
74 Obsoletes:      python3-Cython-examples
75
76 %description examples
77 This package contains example programs for Cython language.
78
79 %description examples -l pl.UTF-8
80 Pakiet zawierający przykładowe programy napisane w języku Cython.
81
82 %prep
83 %setup -q -n %{module}-%{version}
84
85 %build
86 %if %{with python2}
87 CC="%{__cc}" \
88 CFLAGS="%{rpmcflags}" \
89 %{__python} setup.py build \
90         --build-base build-2
91 %endif
92
93 %if %{with python3}
94 CC="%{__cc}" \
95 CFLAGS="%{rpmcflags}" \
96 %{__python3} setup.py build \
97         --build-base build-3
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103
104 %if %{with python3}
105 %{__python3} setup.py \
106         build \
107                 --build-base build-3 \
108         install \
109                 --optimize=2 \
110                 --skip-build \
111                 --root=$RPM_BUILD_ROOT
112
113 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cython{,3}
114 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cythonize{,3}
115 %{__mv} $RPM_BUILD_ROOT%{_bindir}/cygdb{,3}
116 %endif
117
118 %if %{with python2}
119 %{__python} setup.py \
120         build \
121                 --build-base build-2 \
122         install \
123                 --optimize=2 \
124                 --skip-build \
125                 --root=$RPM_BUILD_ROOT
126
127 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
128 %endif
129
130 cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %if %{with python2}
136 %files
137 %defattr(644,root,root,755)
138 %doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
139 %attr(755,root,root) %{_bindir}/cython
140 %attr(755,root,root) %{_bindir}/cythonize
141 %attr(755,root,root) %{_bindir}/cygdb
142 %{py_sitedir}/cython.py[co]
143 %{py_sitedir}/Cython
144 %{py_sitedir}/pyximport
145 %{py_sitedir}/Cython-%{version}-py*.egg-info
146 %endif
147
148 %if %{with python3}
149 %files -n python3-Cython
150 %defattr(644,root,root,755)
151 %doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
152 %attr(755,root,root) %{_bindir}/cython3
153 %attr(755,root,root) %{_bindir}/cythonize3
154 %attr(755,root,root) %{_bindir}/cygdb3
155 %{py3_sitedir}/cython.py
156 %{py3_sitedir}/__pycache__/cython.*
157 %{py3_sitedir}/Cython
158 %{py3_sitedir}/pyximport
159 %{py3_sitedir}/Cython-%{version}-py*.egg-info
160 %endif
161
162 %files examples
163 %defattr(644,root,root,755)
164 %{_examplesdir}/%{name}-%{version}
This page took 0.047056 seconds and 3 git commands to generate.