]> git.pld-linux.org Git - packages/python-Cython.git/blob - python-Cython.spec
8475cbae1f51b52e2b44e5b27686b68612558d16
[packages/python-Cython.git] / python-Cython.spec
1
2 %define         module  Cython
3
4 Summary:        Language for writing Python Extension Modules
5 Summary(pl.UTF-8):      Język służący do pisania modułów rozszerzających Pythona
6 Name:           python-%{module}
7 Version:        0.14
8 Release:        1
9 License:        PSF
10 Group:          Libraries/Python
11 Source0:        http://www.cython.org/release/%{module}-%{version}.tar.gz
12 # Source0-md5:  27fa072e8282431864543e008fd9a19b
13 URL:            http://www.cython.org/
14 BuildRequires:  python >= 1:2.5
15 BuildRequires:  python-devel
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-libs
18 %pyrequires_eq  python-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _noautocompressdoc      *.c
22
23 %description
24 Cython lets you write code that mixes Python and C data types any way
25 you want, and compiles it into a C extension for Python. Cython is
26 based on Pyrex.
27
28 %description -l pl.UTF-8
29 Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
30 w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
31 Cython jest oparty na Pyreksie.
32
33 %package examples
34 Summary:        Examples for Pyrex language
35 Summary(pl.UTF-8):      Przykłady programów w języku Pyrex
36 Group:          Libraries/Python
37 Requires:       %{name} = %{version}-%{release}
38
39 %description examples
40 This package contains example programs for Pyrex language.
41
42 %description examples -l pl.UTF-8
43 Pakiet zawierający przykładowe programy napisane w języku Pyrex.
44
45 %prep
46 %setup -q -n %{module}-%{version}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %{__python} setup.py install \
53         --root=$RPM_BUILD_ROOT \
54         --install-purelib=%{py_sitescriptdir} \
55         -O2
56
57 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
58
59 cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
67 %attr(755,root,root) %{_bindir}/cython
68 %attr(755,root,root) %{_bindir}/cygdb
69 %{py_sitedir}/cython.py[co]
70 %{py_sitedir}/Cython
71 %{py_sitedir}/pyximport
72 %{py_sitedir}/Cython-*.egg-info
73
74 %files examples
75 %defattr(644,root,root,755)
76 %{_examplesdir}/%{name}-%{version}
This page took 0.024551 seconds and 3 git commands to generate.