]> git.pld-linux.org Git - packages/python-Cython.git/blob - python-Cython.spec
4c46f7f397565755477c7b67a0c5ea5243d54f44
[packages/python-Cython.git] / python-Cython.spec
1
2 %define         module  Cython
3
4 Summary:        Language for writing Python Extension Modules
5 Summary(pl.UTF-8):      Język służący do pisania modułów rozszerzających Pythona
6 Name:           python-%{module}
7 Version:        0.9.6.14
8 Release:        1
9 License:        PSF
10 Group:          Libraries/Python
11 Source0:        http://www.cython.org/%{module}-%{version}.tar.gz
12 # Source0-md5:  3fd3a8baa2deb0155ed8b37ee320d02b
13 URL:            http://www.cython.org/
14 BuildRequires:  python >= 1:2.5
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-libs
17 %pyrequires_eq  python-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _noautocompressdoc      *.c
21
22 %description
23 Cython lets you write code that mixes Python and C data types any way
24 you want, and compiles it into a C extension for Python. Cython is
25 based on Pyrex.
26
27 %description -l pl.UTF-8
28 Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
29 w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
30 Cython jest oparty na Pyreksie.
31
32 %package examples
33 Summary:        Examples for Pyrex language
34 Summary(pl.UTF-8):      Przykłady programów w języku Pyrex
35 Group:          Libraries/Python
36 Requires:       %{name} = %{version}-%{release}
37
38 %description examples
39 This package contains example programs for Pyrex language.
40
41 %description examples -l pl.UTF-8
42 Pakiet zawierający przykładowe programy napisane w języku Pyrex.
43
44 %prep
45 %setup -q -n %{module}-%{version}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %{__python} setup.py install \
52         --root=$RPM_BUILD_ROOT \
53         --install-purelib=%{py_sitescriptdir} \
54         -O2
55
56 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
57
58 cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
66 %attr(755,root,root) %{_bindir}/*
67 %{py_sitescriptdir}/Cython
68 %{py_sitescriptdir}/Cython-*.egg-info
69
70 %files examples
71 %defattr(644,root,root,755)
72 %{_examplesdir}/%{name}-%{version}
This page took 0.057972 seconds and 3 git commands to generate.