]> git.pld-linux.org Git - packages/python-Cython.git/blame_incremental - python-Cython.spec
- updated to 0.19.1
[packages/python-Cython.git] / python-Cython.spec
... / ...
CommitLineData
1
2%define module Cython
3
4Summary: Language for writing Python Extension Modules
5Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona
6Name: python-%{module}
7Version: 0.19.1
8Release: 1
9License: Apache v2.0
10Group: Libraries/Python
11Source0: http://www.cython.org/release/%{module}-%{version}.tar.gz
12# Source0-md5: df4cfb2b8e3345272e3fc451b76bd630
13URL: http://www.cython.org/
14BuildRequires: python >= 1:2.5
15BuildRequires: python-devel
16BuildRequires: rpm-pythonprov
17%pyrequires_eq python-libs
18%pyrequires_eq python-devel
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _noautocompressdoc *.c
22
23%description
24Cython lets you write code that mixes Python and C data types any way
25you want, and compiles it into a C extension for Python. Cython is
26based on Pyrex.
27
28%description -l pl.UTF-8
29Cython pozwala pisać kod zawierający dane Pythona i języka C połączone
30w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
31Cython jest oparty na Pyreksie.
32
33%package examples
34Summary: Examples for Cython language
35Summary(pl.UTF-8): Przykłady programów w języku Cython
36Group: Libraries/Python
37Requires: %{name} = %{version}-%{release}
38
39%description examples
40This package contains example programs for Cython language.
41
42%description examples -l pl.UTF-8
43Pakiet zawierający przykładowe programy napisane w języku Cython.
44
45%prep
46%setup -q -n %{module}-%{version}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52%{__python} setup.py install \
53 --root=$RPM_BUILD_ROOT \
54 --install-purelib=%{py_sitescriptdir} \
55 -O2
56
57find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
58
59cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
67%attr(755,root,root) %{_bindir}/cython
68%attr(755,root,root) %{_bindir}/cygdb
69%{py_sitedir}/cython.py[co]
70%{py_sitedir}/Cython
71%{py_sitedir}/pyximport
72%{py_sitedir}/Cython-*.egg-info
73
74%files examples
75%defattr(644,root,root,755)
76%{_examplesdir}/%{name}-%{version}
This page took 0.029954 seconds and 4 git commands to generate.