]> git.pld-linux.org Git - packages/python-Cython.git/blame_incremental - python-Cython.spec
- python 3.5 rebuild
[packages/python-Cython.git] / python-Cython.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module Cython
7
8Summary: Language for writing Python Extension Modules (Python 2.x version)
9Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 2.x)
10Name: python-%{module}
11Version: 0.23.1
12Release: 2
13License: Apache v2.0
14Group: Libraries/Python
15Source0: http://cython.org/release/%{module}-%{version}.tar.gz
16# Source0-md5: db3c5b365e1c3f71c7cd90e96473a3ab
17URL: http://cython.org/
18%if %{with python2}
19BuildRequires: python >= 1:2.6
20BuildRequires: python-devel >= 1:2.6
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3 >= 1:3.2
25BuildRequires: python3-2to3 >= 1:3.2
26BuildRequires: python3-devel >= 1:3.2
27BuildRequires: python3-modules >= 1:3.2
28BuildRequires: python3-setuptools
29%endif
30BuildRequires: rpm-pythonprov
31Requires: python-devel >= 1:2.6
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define _noautocompressdoc *.c
35
36%description
37Cython lets you write code that mixes Python and C data types any way
38you want, and compiles it into a C extension for Python. Cython is
39based on Pyrex.
40
41This package contains Cython module for Python 2.x.
42
43%description -l pl.UTF-8
44Cython pozwala pisać kod zawierający dane Pythona i języka C połączone
45w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
46Cython jest oparty na Pyreksie.
47
48Ten pakiet zawiera moduł Cython dla Pythona 2.x.
49
50%package -n python3-Cython
51Summary: Language for writing Python Extension Modules (Python 3.x version)
52Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 3.x)
53Group: Libraries/Python
54Requires: python3-devel >= 1:3.2
55
56%description -n python3-Cython
57Cython lets you write code that mixes Python and C data types any way
58you want, and compiles it into a C extension for Python. Cython is
59based on Pyrex.
60
61This package contains Cython module for Python 3.x.
62
63%description -n python3-Cython -l pl.UTF-8
64Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
65w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
66Cython jest oparty na Pyreksie.
67
68Ten pakiet zawiera moduł Cython dla Pythona 3.x.
69
70%package examples
71Summary: Examples for Cython language
72Summary(pl.UTF-8): Przykłady programów w języku Cython
73Group: Libraries/Python
74Obsoletes: python3-Cython-examples
75
76%description examples
77This package contains example programs for Cython language.
78
79%description examples -l pl.UTF-8
80Pakiet zawierający przykładowe programy napisane w języku Cython.
81
82%prep
83%setup -q -n %{module}-%{version}
84
85%build
86%if %{with python2}
87CC="%{__cc}" \
88CFLAGS="%{rpmcflags}" \
89%{__python} setup.py build \
90 --build-base build-2
91%endif
92
93%if %{with python3}
94CC="%{__cc}" \
95CFLAGS="%{rpmcflags}" \
96%{__python3} setup.py build \
97 --build-base build-3
98%endif
99
100%install
101rm -rf $RPM_BUILD_ROOT
102install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103
104%if %{with python3}
105%{__python3} setup.py \
106 build \
107 --build-base build-3 \
108 install \
109 --optimize=2 \
110 --skip-build \
111 --root=$RPM_BUILD_ROOT
112
113%{__mv} $RPM_BUILD_ROOT%{_bindir}/cython{,3}
114%{__mv} $RPM_BUILD_ROOT%{_bindir}/cythonize{,3}
115%{__mv} $RPM_BUILD_ROOT%{_bindir}/cygdb{,3}
116%endif
117
118%if %{with python2}
119%{__python} setup.py \
120 build \
121 --build-base build-2 \
122 install \
123 --optimize=2 \
124 --skip-build \
125 --root=$RPM_BUILD_ROOT
126
127find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
128%endif
129
130cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%if %{with python2}
136%files
137%defattr(644,root,root,755)
138%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
139%attr(755,root,root) %{_bindir}/cython
140%attr(755,root,root) %{_bindir}/cythonize
141%attr(755,root,root) %{_bindir}/cygdb
142%{py_sitedir}/cython.py[co]
143%{py_sitedir}/Cython
144%{py_sitedir}/pyximport
145%{py_sitedir}/Cython-%{version}-py*.egg-info
146%endif
147
148%if %{with python3}
149%files -n python3-Cython
150%defattr(644,root,root,755)
151%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
152%attr(755,root,root) %{_bindir}/cython3
153%attr(755,root,root) %{_bindir}/cythonize3
154%attr(755,root,root) %{_bindir}/cygdb3
155%{py3_sitedir}/cython.py
156%{py3_sitedir}/__pycache__/cython.*
157%{py3_sitedir}/Cython
158%{py3_sitedir}/pyximport
159%{py3_sitedir}/Cython-%{version}-py*.egg-info
160%endif
161
162%files examples
163%defattr(644,root,root,755)
164%{_examplesdir}/%{name}-%{version}
This page took 0.060053 seconds and 4 git commands to generate.