]> git.pld-linux.org Git - packages/python-Cython.git/blame - python-Cython.spec
- PyRex -> Pyrex
[packages/python-Cython.git] / python-Cython.spec
CommitLineData
c851376d 1
2%define module Cython
3
4Summary: Language for writing Python Extension Modules
5Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona
6Name: python-%{module}
7Version: 0.9.6.14
8Release: 1
9License: PSF
10Group: Libraries/Python
11Source0: http://www.cython.org/%{module}-%{version}.tar.gz
12# Source0-md5: 3fd3a8baa2deb0155ed8b37ee320d02b
13URL: http://www.cython.org/
14BuildRequires: python >= 1:2.5
15BuildRequires: rpm-pythonprov
16%pyrequires_eq python-libs
17%pyrequires_eq python-devel
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _noautocompressdoc *.c
21
22%description
23Cython lets you write code that mixes Python and C data types any way
6f08c5d3 24you want, and compiles it into a C extension for Python. Cython is
25based on Pyrex.
c851376d 26
27%description -l pl.UTF-8
28Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
29w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
6f08c5d3 30Cython jest oparty na Pyreksie.
c851376d 31
32%package examples
33Summary: Examples for Pyrex language
34Summary(pl.UTF-8): Przykłady programów w języku Pyrex
35Group: Libraries/Python
36Requires: %{name} = %{version}-%{release}
37
38%description examples
39This package contains example programs for Pyrex language.
40
41%description examples -l pl.UTF-8
42Pakiet zawierający przykładowe programy napisane w języku Pyrex.
43
44%prep
45%setup -q -n %{module}-%{version}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51%{__python} setup.py install \
52 --root=$RPM_BUILD_ROOT \
53 --install-purelib=%{py_sitescriptdir} \
54 -O2
55
56find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
57
58cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
65%doc README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
66%attr(755,root,root) %{_bindir}/*
67%{py_sitescriptdir}/Cython
68%{py_sitescriptdir}/Cython-*.egg-info
69
70%files examples
71%defattr(644,root,root,755)
72%{_examplesdir}/%{name}-%{version}
This page took 0.120435 seconds and 4 git commands to generate.