]> git.pld-linux.org Git - packages/python-Cython.git/blame - python-Cython.spec
- updated to 0.17.1
[packages/python-Cython.git] / python-Cython.spec
CommitLineData
c851376d 1
2%define module Cython
3
4Summary: Language for writing Python Extension Modules
5Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona
6Name: python-%{module}
2f3f9df4 7Version: 0.17.1
52da8e1d 8Release: 1
e752d74b 9License: Apache v2.0
c851376d 10Group: Libraries/Python
81b5c351 11Source0: http://www.cython.org/release/%{module}-%{version}.tar.gz
2f3f9df4 12# Source0-md5: f0bd2494dbe080a1185b61fa358135f2
c851376d 13URL: http://www.cython.org/
14BuildRequires: python >= 1:2.5
455ac150 15BuildRequires: python-devel
c851376d 16BuildRequires: rpm-pythonprov
17%pyrequires_eq python-libs
18%pyrequires_eq python-devel
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _noautocompressdoc *.c
22
23%description
24Cython lets you write code that mixes Python and C data types any way
6f08c5d3 25you want, and compiles it into a C extension for Python. Cython is
26based on Pyrex.
c851376d 27
28%description -l pl.UTF-8
e752d74b 29Cython pozwala pisać kod zawierający dane Pythona i języka C połączone
c851376d 30w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
6f08c5d3 31Cython jest oparty na Pyreksie.
c851376d 32
33%package examples
e752d74b
JB
34Summary: Examples for Cython language
35Summary(pl.UTF-8): Przykłady programów w języku Cython
c851376d 36Group: Libraries/Python
37Requires: %{name} = %{version}-%{release}
38
39%description examples
e752d74b 40This package contains example programs for Cython language.
c851376d 41
42%description examples -l pl.UTF-8
e752d74b 43Pakiet zawierający przykładowe programy napisane w języku Cython.
c851376d 44
45%prep
46%setup -q -n %{module}-%{version}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52%{__python} setup.py install \
53 --root=$RPM_BUILD_ROOT \
54 --install-purelib=%{py_sitescriptdir} \
55 -O2
56
f7af39b5 57find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
c851376d 58
59cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
e752d74b 66%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
f7af39b5 67%attr(755,root,root) %{_bindir}/cython
52da8e1d 68%attr(755,root,root) %{_bindir}/cygdb
81b5c351 69%{py_sitedir}/cython.py[co]
f7af39b5 70%{py_sitedir}/Cython
71%{py_sitedir}/pyximport
72%{py_sitedir}/Cython-*.egg-info
c851376d 73
74%files examples
75%defattr(644,root,root,755)
76%{_examplesdir}/%{name}-%{version}
This page took 0.082819 seconds and 4 git commands to generate.