]> git.pld-linux.org Git - packages/python-Cython.git/blame - python-Cython.spec
- release 2 (by relup.sh)
[packages/python-Cython.git] / python-Cython.spec
CommitLineData
50da0181
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
c851376d 5
6%define module Cython
7
50da0181
JB
8Summary: Language for writing Python Extension Modules (Python 2.x version)
9Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 2.x)
c851376d 10Name: python-%{module}
760790ed 11Version: 0.23.4
55589942 12Release: 2
e752d74b 13License: Apache v2.0
c851376d 14Group: Libraries/Python
4194a06e 15Source0: http://cython.org/release/%{module}-%{version}.tar.gz
760790ed 16# Source0-md5: 157df1f69bcec6b56fd97e0f2e057f6e
4194a06e 17URL: http://cython.org/
50da0181 18%if %{with python2}
28c9083d
JB
19BuildRequires: python >= 1:2.6
20BuildRequires: python-devel >= 1:2.6
e44bbaad 21BuildRequires: python-setuptools
50da0181
JB
22%endif
23%if %{with python3}
28c9083d
JB
24BuildRequires: python3 >= 1:3.2
25BuildRequires: python3-2to3 >= 1:3.2
26BuildRequires: python3-devel >= 1:3.2
28c9083d 27BuildRequires: python3-modules >= 1:3.2
e44bbaad 28BuildRequires: python3-setuptools
50da0181 29%endif
c851376d 30BuildRequires: rpm-pythonprov
28c9083d 31Requires: python-devel >= 1:2.6
c851376d 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define _noautocompressdoc *.c
35
36%description
37Cython lets you write code that mixes Python and C data types any way
6f08c5d3 38you want, and compiles it into a C extension for Python. Cython is
39based on Pyrex.
c851376d 40
50da0181
JB
41This package contains Cython module for Python 2.x.
42
c851376d 43%description -l pl.UTF-8
e752d74b 44Cython pozwala pisać kod zawierający dane Pythona i języka C połączone
c851376d 45w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
6f08c5d3 46Cython jest oparty na Pyreksie.
c851376d 47
50da0181
JB
48Ten pakiet zawiera moduł Cython dla Pythona 2.x.
49
50%package -n python3-Cython
51Summary: Language for writing Python Extension Modules (Python 3.x version)
52Summary(pl.UTF-8): Język służący do pisania modułów rozszerzających Pythona (wersja dla Pythona 3.x)
53Group: Libraries/Python
28c9083d 54Requires: python3-devel >= 1:3.2
50da0181
JB
55
56%description -n python3-Cython
57Cython lets you write code that mixes Python and C data types any way
58you want, and compiles it into a C extension for Python. Cython is
59based on Pyrex.
60
61This package contains Cython module for Python 3.x.
62
63%description -n python3-Cython -l pl.UTF-8
64Pyrex pozwala pisać kod zawierający dane Pythona i języka C połączone
65w jakikolwiek sposób i kompiluje to jako rozszerzenie C dla Pythona.
66Cython jest oparty na Pyreksie.
67
68Ten pakiet zawiera moduł Cython dla Pythona 3.x.
69
c851376d 70%package examples
e752d74b
JB
71Summary: Examples for Cython language
72Summary(pl.UTF-8): Przykłady programów w języku Cython
c851376d 73Group: Libraries/Python
50da0181 74Obsoletes: python3-Cython-examples
c851376d 75
76%description examples
e752d74b 77This package contains example programs for Cython language.
c851376d 78
79%description examples -l pl.UTF-8
e752d74b 80Pakiet zawierający przykładowe programy napisane w języku Cython.
c851376d 81
82%prep
83%setup -q -n %{module}-%{version}
84
7f7a7361 85%build
50da0181 86%if %{with python2}
b0c5c878 87%py_build \
50da0181
JB
88 --build-base build-2
89%endif
90
91%if %{with python3}
b0c5c878 92%py3_build \
50da0181
JB
93 --build-base build-3
94%endif
7f7a7361 95
c851376d 96%install
97rm -rf $RPM_BUILD_ROOT
98install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
99
50da0181
JB
100%if %{with python3}
101%{__python3} setup.py \
102 build \
103 --build-base build-3 \
104 install \
105 --optimize=2 \
106 --skip-build \
107 --root=$RPM_BUILD_ROOT
108
109%{__mv} $RPM_BUILD_ROOT%{_bindir}/cython{,3}
28c9083d 110%{__mv} $RPM_BUILD_ROOT%{_bindir}/cythonize{,3}
50da0181
JB
111%{__mv} $RPM_BUILD_ROOT%{_bindir}/cygdb{,3}
112%endif
113
114%if %{with python2}
115%{__python} setup.py \
116 build \
117 --build-base build-2 \
118 install \
119 --optimize=2 \
120 --skip-build \
121 --root=$RPM_BUILD_ROOT
c851376d 122
f7af39b5 123find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -a ! -name 'Lexicon.py' -exec rm -f {} \;
50da0181 124%endif
c851376d 125
126cp -a Demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
50da0181 131%if %{with python2}
c851376d 132%files
133%defattr(644,root,root,755)
e752d74b 134%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
f7af39b5 135%attr(755,root,root) %{_bindir}/cython
28c9083d 136%attr(755,root,root) %{_bindir}/cythonize
52da8e1d 137%attr(755,root,root) %{_bindir}/cygdb
81b5c351 138%{py_sitedir}/cython.py[co]
f7af39b5 139%{py_sitedir}/Cython
140%{py_sitedir}/pyximport
50da0181
JB
141%{py_sitedir}/Cython-%{version}-py*.egg-info
142%endif
143
144%if %{with python3}
145%files -n python3-Cython
146%defattr(644,root,root,755)
147%doc COPYING.txt README.txt ToDo.txt USAGE.txt Doc/*.html Doc/*.c
148%attr(755,root,root) %{_bindir}/cython3
28c9083d 149%attr(755,root,root) %{_bindir}/cythonize3
50da0181
JB
150%attr(755,root,root) %{_bindir}/cygdb3
151%{py3_sitedir}/cython.py
152%{py3_sitedir}/__pycache__/cython.*
153%{py3_sitedir}/Cython
154%{py3_sitedir}/pyximport
155%{py3_sitedir}/Cython-%{version}-py*.egg-info
156%endif
c851376d 157
158%files examples
159%defattr(644,root,root,755)
160%{_examplesdir}/%{name}-%{version}
This page took 0.044174 seconds and 4 git commands to generate.