]> git.pld-linux.org Git - packages/pure-ftpd.git/commitdiff
Up to 1.0.51 master auto/th/pure-ftpd-1.0.51-11
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 28 Feb 2024 11:10:44 +0000 (12:10 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 28 Feb 2024 11:10:44 +0000 (12:10 +0100)
0003-Allow-having-both-options-and-config-file-on-command.patch
paths.patch
pure-ftpd-1.0.49-diraliases_uninitialized_pointer.patch [deleted file]
pure-ftpd-1.0.49-pure_strcmp_OOB_read.patch [deleted file]
pure-ftpd-allauth.patch [deleted file]
pure-ftpd.spec

index 7eb99b22ee84dcc29b666667ec21c8b132457cb2..25273de608126dc5daced1fe19fa534ae5a1600d 100644 (file)
@@ -12,15 +12,15 @@ diff --git a/src/ftpd.c b/src/ftpd.c
 index c5edac5..b13afc0 100644
 --- a/src/ftpd.c
 +++ b/src/ftpd.c
-@@ -5589,7 +5589,7 @@ int pureftpd_start(int argc, char *argv[], const char *home_directory_)
- #endif
+@@ -5528,7 +5528,7 @@ int pureftpd_start(int argc, char *argv[
+     {
+         static SimpleConfConfig config = { NULL, sc_special_handler };
  
- #ifndef MINIMAL
--    if (argc == 2 && *argv[1] != '-' &&
-+    if (argc >= 2 && *argv[1] != '-' &&
-         sc_build_command_line_from_file(argv[1], NULL, simpleconf_options,
-                                         (sizeof simpleconf_options) /
-                                         (sizeof simpleconf_options[0]),
+-        if (argc == 2 && *argv[1] != '-' &&
++        if (argc >= 2 && *argv[1] != '-' &&
+             sc_build_command_line_from_file(argv[1], &config,
+                                             simpleconf_options,
+                                             (sizeof simpleconf_options) /
 diff --git a/src/simpleconf.c b/src/simpleconf.c
 index f296f54..505aee1 100644
 --- a/src/simpleconf.c
index 0a08a3b2f975e2f3fe43c8d2e11a4d5948985fca..f336b97a85c5378efe26d5eeda933d7b6d7b4125 100644 (file)
@@ -1,6 +1,6 @@
---- pure-ftpd-1.0.48/src/ftpd.h~       2019-03-29 12:34:03.000000000 +0100
-+++ pure-ftpd-1.0.48/src/ftpd.h        2019-03-29 12:36:05.048180168 +0100
-@@ -412,18 +412,9 @@
+--- a/src/ftpd.h~      2021-12-16 13:12:17.000000000 +0100
++++ b/src/ftpd.h       2024-02-28 12:08:03.216568955 +0100
+@@ -397,15 +397,9 @@ extern int opt_a, opt_C, opt_d, opt_F, o
  #endif
  
  #ifdef WITH_TLS
@@ -14,9 +14,6 @@
 +#  define TLS_CERTIFICATE_FILE "/etc/pure-ftpd/ssl/pure-ftpd.pem"
  #  define TLS_KEY_FILE TLS_CERTIFICATE_FILE
 -# endif
--# ifndef TLS_DHPARAMS_FILE
--#  define TLS_DHPARAMS_FILE TLS_CONFDIR "/pure-ftpd-dhparams.pem"
--# endif
 +#  define TLS_DHPARAMS_FILE "/etc/pure-ftpd/ssl/dhparams.pem"
  #endif
  
diff --git a/pure-ftpd-1.0.49-diraliases_uninitialized_pointer.patch b/pure-ftpd-1.0.49-diraliases_uninitialized_pointer.patch
deleted file mode 100644 (file)
index 7e29934..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 8d0d42542e2cb7a56d645fbe4d0ef436e38bcefa Mon Sep 17 00:00:00 2001
-From: Frank Denis <github@pureftpd.org>
-Date: Tue, 18 Feb 2020 18:36:58 +0100
-Subject: [PATCH] diraliases: always set the tail of the list to NULL
-
-Spotted and reported by Antonio Norales from GitHub Security Labs.
-Thanks!
----
- src/diraliases.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/diraliases.c b/src/diraliases.c
-index 4002a36..fb70273 100644
---- a/src/diraliases.c
-+++ b/src/diraliases.c
-@@ -93,7 +93,6 @@ int init_aliases(void)
-                 (tail->dir = strdup(dir)) == NULL) {
-                 die_mem();
-             }
--            tail->next = NULL;
-         } else {
-             DirAlias *curr;
-@@ -105,6 +104,7 @@ int init_aliases(void)
-             tail->next = curr;
-             tail = curr;
-         }
-+        tail->next = NULL;
-     }
-     fclose(fp);
-     aliases_up++;
diff --git a/pure-ftpd-1.0.49-pure_strcmp_OOB_read.patch b/pure-ftpd-1.0.49-pure_strcmp_OOB_read.patch
deleted file mode 100644 (file)
index 4ed197e..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From 36c6d268cb190282a2c17106acfd31863121b58e Mon Sep 17 00:00:00 2001
-From: Frank Denis <github@pureftpd.org>
-Date: Mon, 24 Feb 2020 15:19:43 +0100
-Subject: [PATCH] pure_strcmp(): len(s2) can be > len(s1)
-
-Reported by Antonio Morales from GitHub Security Labs, thanks!
----
- src/utils.c | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/src/utils.c b/src/utils.c
-index f41492d..a7f0381 100644
---- a/src/utils.c
-+++ b/src/utils.c
-@@ -45,5 +45,11 @@ int pure_memcmp(const void * const b1_, const void * const b2_, size_t len)
- int pure_strcmp(const char * const s1, const char * const s2)
- {
--    return pure_memcmp(s1, s2, strlen(s1) + 1U);
-+    const size_t s1_len = strlen(s1);
-+    const size_t s2_len = strlen(s2);
-+
-+    if (s1_len != s2_len) {
-+        return -1;
-+    }
-+    return pure_memcmp(s1, s2, s1_len);
- }
diff --git a/pure-ftpd-allauth.patch b/pure-ftpd-allauth.patch
deleted file mode 100644 (file)
index 7a56b98..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- pure-ftpd-1.0.47/src/log_mysql.c~  2017-08-20 16:51:05.000000000 +0200
-+++ pure-ftpd-1.0.47/src/log_mysql.c   2017-10-28 20:17:43.638635689 +0200
-@@ -429,6 +429,7 @@ void pw_mysql_check(AuthResult * const r
-         crypto_mysql++;
-         crypto_md5++;
-         crypto_sha1++;
-+        crypto_plain++;
-     } else if (strcasecmp(crypto, PASSWD_SQL_ARGON2) == 0) {
-         crypto_argon2++;
-     } else if (strcasecmp(crypto, PASSWD_SQL_SCRYPT) == 0) {
---- pure-ftpd-1.0.47/src/log_pgsql.c~  2017-08-20 16:51:15.000000000 +0200
-+++ pure-ftpd-1.0.47/src/log_pgsql.c   2017-10-28 20:18:08.135958914 +0200
-@@ -504,6 +504,7 @@ void pw_pgsql_check(AuthResult * const r
-         crypto_crypt++;
-         crypto_md5++;
-         crypto_sha1++;
-+        crypto_plain++;
-     } else if (strcasecmp(crypto, PASSWD_SQL_ARGON2) == 0) {
-         crypto_argon2++;
-     } else if (strcasecmp(crypto, PASSWD_SQL_SCRYPT) == 0) {
index 6fdd6ef87c53b182e808d36425021dee19a693a6..6121e8f46514e4f235fb5930b56b3ef45becc3bf 100644 (file)
 Summary:       Small, fast and secure FTP server
 Summary(pl.UTF-8):     Mały, szybki i bezpieczny serwer FTP
 Name:          pure-ftpd
-Version:       1.0.49
+Version:       1.0.51
 Release:       %{rel}%{?with_extra:extra}
 License:       BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
 Group:         Daemons
 Source0:       http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: b7025f469711d88bd84a3518f67c1470
+# Source0-md5: 0e2f519fbc3a48143fb3a0409a09d863
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -27,7 +27,7 @@ Source4:      ftpusers.tar.bz2
 Source5:       http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
 # Source5-md5: 3f2ff6b00b5c38ee11ce588ee5af6cf6
 Patch0:                %{name}-config.patch
-Patch1:                %{name}-allauth.patch
+
 Patch2:                %{name}-pure-pw_passwd.patch
 Patch3:                %{name}-mysql_config.patch
 # from Fedora
@@ -36,8 +36,7 @@ Patch5:               paths.patch
 Patch6:                %{name}-apparmor.patch
 Patch7:                %{name}-mysql-utf8.patch
 Patch8:                caps.patch
-Patch9:                pure-ftpd-1.0.49-diraliases_uninitialized_pointer.patch
-Patch10:       pure-ftpd-1.0.49-pure_strcmp_OOB_read.patch
+
 Patch11:        keep-spaces.patch
 URL:           http://www.pureftpd.org/
 %{?with_extra:BuildRequires:   autoconf}
@@ -112,15 +111,14 @@ Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
 %prep
 %setup -q -a 5
 %patch0 -p0
-%patch1 -p1
+
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%patch9 -p1
-%patch10 -p1
+
 %patch11 -p1
 
 %{?with_extra:%patch2 -p1}
This page took 0.181077 seconds and 4 git commands to generate.