]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
73acd4a5795d2b9bdf6049d352526f8709cdc43b
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     5
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.48
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  4538d563fb4cbe755767c91b14ed2fd2
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 # from Fedora
34 Patch4:         0003-Allow-having-both-options-and-config-file-on-command.patch
35
36 Patch6:         %{name}-apparmor.patch
37 Patch7:         %{name}-mysql-utf8.patch
38 Patch8:         caps.patch
39 URL:            http://www.pureftpd.org/
40 %{?with_extra:BuildRequires:    autoconf}
41 %{?with_extra:BuildRequires:    automake}
42 BuildRequires:  libapparmor-devel
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 BuildRequires:  libsodium-devel
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  pam-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  rpmbuild(macros) >= 1.304
52 Requires(post,preun):   /sbin/chkconfig
53 Requires(postun):       /usr/sbin/groupdel
54 Requires(postun):       /usr/sbin/userdel
55 Requires(pre):  /bin/id
56 Requires(pre):  /usr/bin/getgid
57 Requires(pre):  /usr/sbin/groupadd
58 Requires(pre):  /usr/sbin/useradd
59 Requires:       pam >= 0.79.0
60 %{!?with_extra:Requires:        perl-base}
61 Requires:       rc-scripts
62 Provides:       ftpserver
63 Provides:       user(ftpauth)
64 Provides:       group(ftpauth)
65 Provides:       user(ftpcert)
66 Provides:       group(ftpcert)
67 Conflicts:      man-pages < 1.51
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _sysconfdir     /etc/ftpd
71 %define         _ftpdir         /home/services/ftp
72 %define         schemadir       /usr/share/openldap/schema
73
74 %description
75 Pure-FTPd is a fast, production-quality, standard-comformant FTP
76 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
77 has no known security flaw, it is really trivial to set up and it is
78 especially designed for modern Linux kernels (setfsuid, sendfile,
79 capabilities) . Features include PAM support, IPv6, chroot()ed home
80 directories, virtual domains, built-in LS, anti-warez system, bounded
81 ports for passive downloads...
82
83 %description -l pl.UTF-8
84 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
85 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
86 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
87 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
88 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
89 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
90 LS, system anty-warezowy, ograniczanie portów dla pasywnych
91 połączeń...
92
93 %package -n openldap-schema-pureftpd
94 Summary:        Pure-FTPd LDAP schema
95 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
96 Group:          Networking/Daemons
97 Requires(post,postun):  sed >= 4.0
98 Requires:       openldap-servers
99 Requires:       sed >= 4.0
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description -n openldap-schema-pureftpd
105 This package contains an Pure-FTPd openldap schema.
106
107 %description -n openldap-schema-pureftpd -l pl.UTF-8
108 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
109
110 %prep
111 %setup -q -a 5
112 %patch0 -p0
113 %patch1 -p1
114 %patch3 -p1
115 %patch4 -p1
116
117 %patch6 -p1
118 %patch7 -p1
119 %patch8 -p1
120
121 %{?with_extra:%patch2 -p1}
122
123 %build
124 %{__aclocal} -Im4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
130         --disable-silent-rules \
131         --with-boring \
132         --with-altlog \
133         --with-cookie \
134         --with-diraliases \
135         --with-extauth \
136         --with-ftpwho \
137         --with-language=english \
138         %{!?with_cap:--without-capabilities} \
139         %{?with_ldap:--with-ldap} \
140         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
141         --with-pam \
142         --with-peruserlimits \
143         %{?with_pgsql:--with-pgsql} \
144         --with-privsep \
145         %{?with_puredb:--with-puredb} \
146         --with-quotas \
147         --with-ratios \
148         --with-throttling \
149         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
150         --with-uploadscript \
151         --with-virtualchroot \
152         --with-virtualhosts \
153         --with-apparmor
154
155 %if %{with extra}
156 cd pure-config
157 %{__aclocal}
158 %{__autoconf}
159 %{__autoheader}
160 %{__automake}
161 %configure
162 %{__make}
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d,%{name}/{certd,authd,conf}} \
168         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
174 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
175 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
176
177 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
178 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
179 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
180 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
181
182 mv $RPM_BUILD_ROOT%{_sysconfdir}/{pure-ftpd,pureftpd}.conf
183
184 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
185
186 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
187
188 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
189 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
190
191 %if %{with extra}
192 %{__make} -C pure-config install \
193         DESTDIR=$RPM_BUILD_ROOT
194 %endif
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post
200 /sbin/chkconfig --add %{name}
201 %service %{name} restart "PureFTPD daemon"
202
203 %pre
204 %groupadd -g 326 ftpauth
205 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
206 %groupadd -g 335 ftpcert
207 %useradd -u 335 -d %{_ftpdir} -s /bin/false -c "FTP Cert daemon" -g ftpcert ftpcert
208
209 %preun
210 if [ "$1" = "0" ]; then
211         %service %{name} stop
212         /sbin/chkconfig --del %{name}
213 fi
214
215 %postun
216 if [ "$1" = "0" ]; then
217         %userremove ftpauth
218         %groupremove ftpauth
219         %userremove ftpcert
220         %groupremove ftpcert
221 fi
222
223 %post -n openldap-schema-pureftpd
224 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
225 %service -q ldap restart
226
227 %postun -n openldap-schema-pureftpd
228 if [ "$1" = "0" ]; then
229         %openldap_schema_unregister %{schemadir}/pureftpd.schema
230         %service -q ldap restart
231 fi
232
233 %triggerpostun -- %{name} < 1.0.41-2
234 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
235 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
236 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
237 exit 0
238
239 %files
240 %defattr(644,root,root,755)
241 %doc AUTHORS ChangeLog COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
242 %attr(755,root,root) %{_bindir}/*
243 %attr(755,root,root) %{_sbindir}/*
244 %attr(754,root,root) /etc/rc.d/init.d/%{name}
245 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
246 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
247 %attr(751,root,root) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}
248 %attr(750,root,ftpauth) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/authd
249 %attr(750,root,ftpcert) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/certd
250 # for future /etc/ftpd -> /etc/pure-ftpd/conf migration
251 #%attr(750,root,ftpcert) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/conf
252 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
253 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
254 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
255 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
256 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
257 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
258 %attr(710,root,ftp) %dir %{_sysconfdir}
259 %dir %{_sysconfdir}/vhosts
260 %dir %{_sysconfdir}/pure-ftpd
261 %dir %{_ftpdir}
262 %{_mandir}/man?/*
263 %lang(ja) %{_mandir}/ja/man5/ftpusers*
264 %lang(pl) %{_mandir}/pl/man5/ftpusers*
265 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
266 %lang(ru) %{_mandir}/ru/man5/ftpusers*
267
268 %files -n openldap-schema-pureftpd
269 %defattr(644,root,root,755)
270 %{schemadir}/pureftpd.schema
This page took 0.059772 seconds and 2 git commands to generate.