]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- rel 3; certd dir needs 770
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     3
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.49
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  b7025f469711d88bd84a3518f67c1470
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 # from Fedora
34 Patch4:         0003-Allow-having-both-options-and-config-file-on-command.patch
35 Patch5:         paths.patch
36 Patch6:         %{name}-apparmor.patch
37 Patch7:         %{name}-mysql-utf8.patch
38 Patch8:         caps.patch
39 URL:            http://www.pureftpd.org/
40 %{?with_extra:BuildRequires:    autoconf}
41 %{?with_extra:BuildRequires:    automake}
42 BuildRequires:  libapparmor-devel
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 BuildRequires:  libsodium-devel
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  pam-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  rpmbuild(macros) >= 1.304
52 Requires(post):         /usr/bin/openssl
53 Requires(post,preun):   /sbin/chkconfig
54 Requires(postun):       /usr/sbin/groupdel
55 Requires(postun):       /usr/sbin/userdel
56 Requires(pre):  /bin/id
57 Requires(pre):  /usr/bin/getgid
58 Requires(pre):  /usr/sbin/groupadd
59 Requires(pre):  /usr/sbin/useradd
60 Requires:       pam >= 0.79.0
61 %{!?with_extra:Requires:        perl-base}
62 Requires:       rc-scripts
63 Provides:       ftpserver
64 Provides:       user(ftpauth)
65 Provides:       group(ftpauth)
66 Provides:       user(ftpcert)
67 Provides:       group(ftpcert)
68 Conflicts:      man-pages < 1.51
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir     /etc/ftpd
72 %define         _ftpdir         /home/services/ftp
73 %define         schemadir       /usr/share/openldap/schema
74
75 %description
76 Pure-FTPd is a fast, production-quality, standard-comformant FTP
77 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
78 has no known security flaw, it is really trivial to set up and it is
79 especially designed for modern Linux kernels (setfsuid, sendfile,
80 capabilities) . Features include PAM support, IPv6, chroot()ed home
81 directories, virtual domains, built-in LS, anti-warez system, bounded
82 ports for passive downloads...
83
84 %description -l pl.UTF-8
85 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
86 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
87 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
88 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
89 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
90 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
91 LS, system anty-warezowy, ograniczanie portów dla pasywnych
92 połączeń...
93
94 %package -n openldap-schema-pureftpd
95 Summary:        Pure-FTPd LDAP schema
96 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
97 Group:          Networking/Daemons
98 Requires(post,postun):  sed >= 4.0
99 Requires:       openldap-servers
100 Requires:       sed >= 4.0
101 %if "%{_rpmversion}" >= "5"
102 BuildArch:      noarch
103 %endif
104
105 %description -n openldap-schema-pureftpd
106 This package contains an Pure-FTPd openldap schema.
107
108 %description -n openldap-schema-pureftpd -l pl.UTF-8
109 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
110
111 %prep
112 %setup -q -a 5
113 %patch0 -p0
114 %patch1 -p1
115 %patch3 -p1
116 %patch4 -p1
117 %patch5 -p1
118 %patch6 -p1
119 %patch7 -p1
120 %patch8 -p1
121
122 %{?with_extra:%patch2 -p1}
123
124 %build
125 %{__aclocal} -Im4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
131         --disable-silent-rules \
132         --with-boring \
133         --with-altlog \
134         --with-cookie \
135         --with-diraliases \
136         --with-extauth \
137         --with-ftpwho \
138         --with-language=english \
139         %{!?with_cap:--without-capabilities} \
140         %{?with_ldap:--with-ldap} \
141         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
142         --with-pam \
143         --with-peruserlimits \
144         %{?with_pgsql:--with-pgsql} \
145         --with-privsep \
146         %{?with_puredb:--with-puredb} \
147         --with-quotas \
148         --with-ratios \
149         --with-throttling \
150         %{?with_tls:--with-tls --with-certfile=/etc/pure-ftpd/ssl/pure-ftpd.pem} \
151         --with-uploadscript \
152         --with-virtualchroot \
153         --with-virtualhosts \
154         --with-apparmor
155
156 %if %{with extra}
157 cd pure-config
158 %{__aclocal}
159 %{__autoconf}
160 %{__autoheader}
161 %{__automake}
162 %configure
163 %{__make}
164 %endif
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d,%{name}/{certd,authd,conf,ssl}} \
169         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
175 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
176 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
177
178 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
179 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
180 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
181 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
182
183 mv $RPM_BUILD_ROOT%{_sysconfdir}/{pure-ftpd,pureftpd}.conf
184
185 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
186 :> $RPM_BUILD_ROOT/etc/pure-ftpd/ssl/dhparams.pem
187
188 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
189
190 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
191 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
192
193 %if %{with extra}
194 %{__make} -C pure-config install \
195         DESTDIR=$RPM_BUILD_ROOT
196 %endif
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post
202 if [ ! -s /etc/pure-ftpd/ssl/dhparams.pem ]; then
203         umask 027
204         %{_bindir}/openssl dhparam -out /etc/pure-ftpd/ssl/dhparams.pem 2048 || :
205 fi
206
207 /sbin/chkconfig --add %{name}
208 %service %{name} restart "PureFTPD daemon"
209
210 %pre
211 %groupadd -g 326 ftpauth
212 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
213 %groupadd -g 335 ftpcert
214 %useradd -u 335 -d %{_ftpdir} -s /bin/false -c "FTP Cert daemon" -g ftpcert ftpcert
215
216 %preun
217 if [ "$1" = "0" ]; then
218         %service %{name} stop
219         /sbin/chkconfig --del %{name}
220 fi
221
222 %postun
223 if [ "$1" = "0" ]; then
224         %userremove ftpauth
225         %groupremove ftpauth
226         %userremove ftpcert
227         %groupremove ftpcert
228 fi
229
230 %post -n openldap-schema-pureftpd
231 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
232 %service -q ldap restart
233
234 %postun -n openldap-schema-pureftpd
235 if [ "$1" = "0" ]; then
236         %openldap_schema_unregister %{schemadir}/pureftpd.schema
237         %service -q ldap restart
238 fi
239
240 %triggerpostun -- %{name} < 1.0.41-2
241 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
242 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
243 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
244 exit 0
245
246 %files
247 %defattr(644,root,root,755)
248 %doc AUTHORS ChangeLog COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
249 %attr(755,root,root) %{_bindir}/*
250 %attr(755,root,root) %{_sbindir}/*
251 %attr(754,root,root) /etc/rc.d/init.d/%{name}
252 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
253 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
254 %attr(751,root,root) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}
255 %attr(750,root,ftpauth) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/authd
256 %attr(750,root,ftpcert) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/certd
257 # for future /etc/ftpd -> /etc/pure-ftpd/conf migration
258 # %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/conf
259 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %dir /etc/%{name}/ssl
260 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost /etc/%{name}/ssl/dhparams.pem
261 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
262 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
263 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
264 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
265 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
266 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
267 %attr(710,root,ftp) %dir %{_sysconfdir}
268 %dir %{_sysconfdir}/vhosts
269 %dir %{_sysconfdir}/pure-ftpd
270 %dir %{_ftpdir}
271 %{_mandir}/man?/*
272 %lang(ja) %{_mandir}/ja/man5/ftpusers*
273 %lang(pl) %{_mandir}/pl/man5/ftpusers*
274 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
275 %lang(ru) %{_mandir}/ru/man5/ftpusers*
276
277 %files -n openldap-schema-pureftpd
278 %defattr(644,root,root,755)
279 %{schemadir}/pureftpd.schema
This page took 0.093809 seconds and 3 git commands to generate.