]> git.pld-linux.org Git - packages/pure-ftpd.git/blame_incremental - pure-ftpd.spec
- release 5
[packages/pure-ftpd.git] / pure-ftpd.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with extra # with additional, maybe useful, but unmaintained features
4%bcond_without ldap # disable LDAP auth
5%bcond_without longusername # with username length = 128 (default 32)
6%bcond_without mysql # disable MySQL auth but disables PAM auth
7%bcond_without pgsql # disable PostgreSQL support
8%bcond_without puredb # disable pure-db support
9%bcond_without tls # disable SSL/TLS support
10%bcond_without cap # disable capabilities
11#
12%define rel 5
13Summary: Small, fast and secure FTP server
14Summary(pl.UTF-8): Mały, szybki i bezpieczny serwer FTP
15Name: pure-ftpd
16Version: 1.0.29
17Release: %{rel}%{?with_extra:extra}
18Epoch: 0
19License: BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
20Group: Daemons
21Source0: ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
22# Source0-md5: 12a074824b509f9e7684fab333ed6915
23Source1: %{name}.pamd
24Source2: %{name}.init
25Source3: %{name}.sysconfig
26Source4: ftpusers.tar.bz2
27# Source4-md5: 76c80b6ec9f4d079a1e27316edddbe16
28Source5: http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
29# Source5-md5: 3f2ff6b00b5c38ee11ce588ee5af6cf6
30Patch0: %{name}-config.patch
31Patch1: %{name}-path_to_ssl_cert_in_config.patch
32Patch2: %{name}-pure-pw_passwd.patch
33Patch3: %{name}-mysql_config.patch
34Patch4: %{name}-allauth.patch
35Patch5: %{name}-passwd_location.patch
36Patch6: %{name}-additionalgid.patch
37Patch7: audit_cap.patch
38URL: http://www.pureftpd.org/
39%{?with_extra:BuildRequires: autoconf}
40%{?with_extra:BuildRequires: automake}
41%{?with_cap:BuildRequires: libcap-devel}
42%{?with_extra:BuildRequires: libcfg+-devel >= 0.6.2}
43%{?with_mysql:BuildRequires: mysql-devel}
44%{?with_ldap:BuildRequires: openldap-devel >= 2.3.0}
45%{?with_tls:BuildRequires: openssl-devel}
46BuildRequires: pam-devel
47%{?with_pgsql:BuildRequires: postgresql-devel}
48BuildRequires: rpmbuild(macros) >= 1.304
49Requires(post,preun): /sbin/chkconfig
50Requires: pam >= 0.79.0
51%{!?with_extra:Requires: perl-base}
52Requires: rc-scripts
53Provides: ftpserver
54Conflicts: man-pages < 1.51
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%define _sysconfdir /etc/ftpd
58%define _ftpdir /home/services/ftp
59%define schemadir /usr/share/openldap/schema
60
61%description
62Pure-FTPd is a fast, production-quality, standard-comformant FTP
63server, based upon Troll-FTPd. Unlike other popular FTP servers, it
64has no known security flaw, it is really trivial to set up and it is
65especially designed for modern Linux kernels (setfsuid, sendfile,
66capabilities) . Features include PAM support, IPv6, chroot()ed home
67directories, virtual domains, built-in LS, anti-warez system, bounded
68ports for passive downloads...
69
70%description -l pl.UTF-8
71Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
72FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
73nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
74konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
75(setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
76IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
77LS, system anty-warezowy, ograniczanie portów dla pasywnych
78połączeń...
79
80%package -n openldap-schema-pureftpd
81Summary: Pure-FTPd LDAP schema
82Summary(pl.UTF-8): Schemat LDAP dla Pure-FTPd
83Group: Networking/Daemons
84Requires(post,postun): sed >= 4.0
85Requires: openldap-servers
86Requires: sed >= 4.0
87
88%description -n openldap-schema-pureftpd
89This package contains an Pure-FTPd openldap schema.
90
91%description -n openldap-schema-pureftpd -l pl.UTF-8
92Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
93
94%prep
95%setup -q -a 5
96%patch0 -p0
97%patch3 -p1
98%patch4 -p1
99%patch5 -p1
100%patch6 -p1
101%patch7 -p1
102
103%{?with_extra:%patch1 -p1}
104%{?with_extra:%patch2 -p1}
105
106%build
107%configure \
108 CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
109 --with-boring \
110 --with-altlog \
111 --with-cookie \
112 --with-diraliases \
113 --with-extauth \
114 --with-ftpwho \
115 --with-language=english \
116 %{!?with_cap:--without-capabilities} \
117 %{?with_ldap:--with-ldap} \
118 %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
119 --with-pam \
120 --with-peruserlimits \
121 %{?with_pgsql:--with-pgsql} \
122 --with-privsep \
123 %{?with_puredb:--with-puredb} \
124 --with-quotas \
125 --with-ratios \
126 --with-throttling \
127 %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
128 --with-uploadscript \
129 --with-virtualchroot \
130 --with-virtualhosts
131
132%if %{with extra}
133cd pure-config
134%{__aclocal}
135%{__autoconf}
136%{__autoheader}
137%{__automake}
138%configure
139%{__make}
140%endif
141
142%install
143rm -rf $RPM_BUILD_ROOT
144install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
145 $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
146
147%{__make} install \
148 DESTDIR=$RPM_BUILD_ROOT
149
150install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
151install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
152install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
153
154%{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
155%{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
156%{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
157install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
158%{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
159install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
160
161touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
162
163ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
164
165bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
166rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
167
168%if %{with extra}
169%{__make} -C pure-config install \
170 DESTDIR=$RPM_BUILD_ROOT
171%endif
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%post
177/sbin/chkconfig --add %{name}
178%service %{name} restart "PureFTPD daemon"
179
180%preun
181if [ "$1" = "0" ]; then
182 %service %{name} stop
183 /sbin/chkconfig --del %{name}
184fi
185
186%post -n openldap-schema-pureftpd
187%openldap_schema_register %{schemadir}/pureftpd.schema -d core
188%service -q ldap restart
189
190%postun -n openldap-schema-pureftpd
191if [ "$1" = "0" ]; then
192 %openldap_schema_unregister %{schemadir}/pureftpd.schema
193 %service -q ldap restart
194fi
195
196
197%files
198%defattr(644,root,root,755)
199%doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
200%attr(755,root,root) %{_bindir}/*
201%attr(755,root,root) %{_sbindir}/*
202%attr(754,root,root) /etc/rc.d/init.d/%{name}
203%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
204%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
205%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
206%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
207%{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
208%{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
209%{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
210%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
211%attr(710,root,ftp) %dir %{_sysconfdir}
212%dir %{_sysconfdir}/vhosts
213%dir %{_sysconfdir}/pure-ftpd
214%dir %{_ftpdir}
215%{_mandir}/man?/*
216%lang(ja) %{_mandir}/ja/man5/ftpusers*
217%lang(pl) %{_mandir}/pl/man5/ftpusers*
218%lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
219%lang(ru) %{_mandir}/ru/man5/ftpusers*
220
221%files -n openldap-schema-pureftpd
222%defattr(644,root,root,755)
223%{schemadir}/pureftpd.schema
This page took 0.101005 seconds and 4 git commands to generate.