]> git.pld-linux.org Git - packages/pulseview.git/blobdiff - pulseview.spec
- rebuild with boost 1.56.0
[packages/pulseview.git] / pulseview.spec
index 1733008188f625f155c630042c0c6cc47875fd17..8c839d5e6c411aaf8018e545bd9a0dfc4bd5e54d 100644 (file)
@@ -1,41 +1,47 @@
 #
-%bcond_without tests
-#
-%define snap   a7553da
+# Conditional build:
+%bcond_with    tests   # "make test" call (requires functional libusb, i.e. accessible USB subsystem)
 #
 Summary:       Qt based logic analyzer GUI for sigrok
+Summary(pl.UTF-8):     Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu sigrok
 Name:          pulseview
-Version:       0.1
-Release:       0.%{snap}.2
-License:       GPL
+Version:       0.2.0
+Release:       3
+License:       GPL v3+
 Group:         X11/Applications/Graphics
-# Source0:     http://sigrok.org/gitweb/?p=pulseview.git;a=snapshot;h=%{snap};sf=tgz;/%{name}-%{snap}.tar.gz
-Source0:       %{name}-%{snap}.tar.gz
-# Source0-md5: 52527a78a1ee676546d63615bf1c1c8d
-Patch0:                %{name}-build.patch
+Source0:       http://sigrok.org/download/source/pulseview/%{name}-%{version}.tar.gz
+# Source0-md5: fe5586212671226afafe9d8d80ed10c6
 URL:           http://sigrok.org/wiki/PulseView
-BuildRequires: boost-devel
-%{?with_tests:BuildRequires:   boost-test}
-BuildRequires: boost-thread
-BuildRequires: glib2-devel
-BuildRequires: libsigrok-devel >= 0.2.0
-BuildRequires: libsigrokdecode-devel >= 0.1.0
+BuildRequires: QtCore-devel >= 4
+BuildRequires: QtGui-devel >= 4
+BuildRequires: boost-devel >= 1.42
+%{?with_tests:BuildRequires:   boost-test >= 1.42}
+BuildRequires: cmake >= 2.8.3
+BuildRequires: glib2-devel >= 2.0
+BuildRequires: libsigrok-devel >= 0.3.0
+BuildRequires: libsigrokdecode-devel >= 0.3.0
+BuildRequires: pkgconfig
+BuildRequires: qt4-qmake >= 4
+Requires:      libsigrok >= 0.3.0
+Requires:      libsigrokdecode >= 0.3.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Qt based logic analyzer GUI for sigrok.
 
+%description -l pl.UTF-8
+Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu
+sigrok.
+
 %prep
-%setup -q -n %{name}-%{snap}
-%patch0 -p1
+%setup -q
 
 %build
 install -d build
 cd build
-%cmake \
+%cmake .. \
        -DDISABLE_WERROR=ON \
-       %{?with_tests:-DENABLE_TESTS=ON} \
-       ../
+       %{?with_tests:-DENABLE_TESTS=ON}
 
 %{__make}
 
@@ -43,19 +49,21 @@ cd build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install doc/pulseview.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install -D contrib/pulseview.desktop $RPM_BUILD_ROOT%{_desktopdir}/pulseview.desktop
+install -D icons/sigrok-logo-notext.png $RPM_BUILD_ROOT%{_pixmapsdir}/sigrok-logo-notext.png
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc HACKING README
+%doc NEWS README
 %attr(755,root,root) %{_bindir}/pulseview
 %{_mandir}/man1/pulseview.1*
+%{_desktopdir}/pulseview.desktop
+%{_pixmapsdir}/sigrok-logo-notext.png
This page took 0.108617 seconds and 4 git commands to generate.