]> git.pld-linux.org Git - packages/pulseview.git/blob - pulseview.spec
f766e3af4d42b68e24db7fd4ba341dbbe62b9244
[packages/pulseview.git] / pulseview.spec
1 #
2 # Conditional build:
3 %bcond_with     qt4     # use Qt 4 instead of Qt 5
4 %bcond_with     tests   # "make test" call (requires functional libusb, i.e. accessible USB subsystem)
5 #
6 Summary:        Qt based logic analyzer GUI for sigrok
7 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu sigrok
8 Name:           pulseview
9 Version:        0.4.0
10 Release:        2
11 License:        GPL v3+
12 Group:          X11/Applications/Graphics
13 Source0:        http://sigrok.org/download/source/pulseview/%{name}-%{version}.tar.gz
14 # Source0-md5:  122ded293913ec773cd34cb68b93e0f9
15 URL:            http://sigrok.org/wiki/PulseView
16 BuildRequires:  boost-devel >= 1.53
17 %{?with_tests:BuildRequires:    boost-test >= 1.53}
18 BuildRequires:  cmake >= 2.8.6
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  libsigrok-c++-devel >= 0.5.0
21 BuildRequires:  libsigrok-devel >= 0.5.0
22 BuildRequires:  libsigrokdecode-devel >= 0.5.0
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  pkgconfig
25 %if %{with qt4}
26 BuildRequires:  QtCore-devel >= 4
27 BuildRequires:  QtGui-devel >= 4
28 BuildRequires:  QtSvg-devel >= 4
29 BuildRequires:  qt4-build >= 4
30 BuildRequires:  qt4-qmake >= 4
31 %else
32 BuildRequires:  Qt5Core-devel >= 5
33 BuildRequires:  Qt5Gui-devel >= 5
34 BuildRequires:  Qt5Svg-devel >= 5
35 BuildRequires:  Qt5Widgets-devel >= 5
36 BuildRequires:  qt5-build >= 5
37 BuildRequires:  qt5-qmake >= 5
38 Requires:       Qt5Gui-platform-xcb
39 %endif
40 Requires:       libsigrok >= 0.4.0
41 Requires:       libsigrok-c++-devel >= 0.4.0
42 Requires:       libsigrokdecode >= 0.5.0
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Qt based logic analyzer GUI for sigrok.
47
48 %description -l pl.UTF-8
49 Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu
50 sigrok.
51
52 %prep
53 %setup -q
54
55 %build
56 install -d build
57 cd build
58 %cmake .. \
59         -DDISABLE_WERROR=ON \
60         %{?with_tests:-DENABLE_TESTS=ON} \
61         %{?with_qt4:-DFORCE_QT4=ON}
62
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_mandir}/man1
70
71 %{__make} -C build install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc NEWS README
80 %attr(755,root,root) %{_bindir}/pulseview
81 %{_mandir}/man1/pulseview.1*
82 %{_desktopdir}/org.sigrok.PulseView.desktop
83 %{_iconsdir}/hicolor/*/apps/pulseview.png
84 %{_iconsdir}/hicolor/*/apps/pulseview.svg
85 %{_datadir}/metainfo/org.sigrok.PulseView.appdata.xml
This page took 0.045905 seconds and 2 git commands to generate.