]> git.pld-linux.org Git - packages/pulseaudio.git/commitdiff
fix crash when trying to use ldac or aptx codec; rel 2 auto/th/pulseaudio-16.0-2
authorJan Palus <atler@pld-linux.org>
Fri, 17 Jun 2022 14:05:46 +0000 (16:05 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 17 Jun 2022 14:06:57 +0000 (16:06 +0200)
gst-ldac-aptx-crash.patch [new file with mode: 0644]
pulseaudio.spec

diff --git a/gst-ldac-aptx-crash.patch b/gst-ldac-aptx-crash.patch
new file mode 100644 (file)
index 0000000..585e4f7
--- /dev/null
@@ -0,0 +1,39 @@
+From cfbbf27b8394fdc97992528caae12b412b22cf6e Mon Sep 17 00:00:00 2001
+From: Jan Palus <jpalus@fastmail.com>
+Date: Fri, 17 Jun 2022 14:36:36 +0200
+Subject: [PATCH] bluetooth/gst: Correct var type for GST_TYPE_BITMASK
+
+GST_TYPE_BITMASK is 64-bit bit mask while corresponding channel_mask in
+pulseaudio is int therefore usually 32-bit. Switch to uint64_t instead
+to match internal representation in gstreamer.
+
+Fixes pulseaudio crash on ARM 32-bit when pulseaudio is compiled with
+gstreamer and either LDAC or aptX support is available.
+---
+ src/modules/bluetooth/a2dp-codec-gst.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/modules/bluetooth/a2dp-codec-gst.c b/src/modules/bluetooth/a2dp-codec-gst.c
+index 8ef74be9c..11839c580 100644
+--- a/src/modules/bluetooth/a2dp-codec-gst.c
++++ b/src/modules/bluetooth/a2dp-codec-gst.c
+@@ -22,6 +22,7 @@
+ #endif
+ #include <arpa/inet.h>
++#include <stdint.h>
+ #include <pulsecore/log.h>
+ #include <pulsecore/macro.h>
+@@ -82,7 +83,7 @@ fail:
+ static GstCaps *gst_create_caps_from_sample_spec(const pa_sample_spec *ss) {
+     gchar *sample_format;
+     GstCaps *caps;
+-    int channel_mask;
++    uint64_t channel_mask;
+     switch (ss->format) {
+         case PA_SAMPLE_S16LE:
+-- 
+2.36.1
+
index 9eabfc60835b8d01146c829166220fde7cd31920..989a4c272614aeaaa978fe73d1ae801bea6987d7 100644 (file)
@@ -15,7 +15,7 @@ Summary:      Modular sound server
 Summary(pl.UTF-8):     Modularny serwer dźwięku
 Name:          pulseaudio
 Version:       16.0
-Release:       1
+Release:       2
 License:       GPL v2+ (server and libpulsecore), LGPL v2+ (libpulse)
 Group:         Libraries
 Source0:       https://freedesktop.org/software/pulseaudio/releases/%{name}-%{version}.tar.xz
@@ -25,6 +25,7 @@ Source2:      %{name}.sysconfig
 Source3:       %{name}.tmpfiles
 Patch0:                %{name}-pa-machine-id.patch
 Patch1:                mate-desktop.patch
+Patch2:                gst-ldac-aptx-crash.patch
 URL:           http://pulseaudio.org/
 BuildRequires: alsa-lib-devel >= 1.0.24
 BuildRequires: avahi-devel >= 0.6.0
@@ -375,6 +376,7 @@ Dokumentacja API PulseAudio.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__sed} -i -e '1s,#!/usr/bin/env python3,#!%{__python3},' src/utils/qpaeq
 
This page took 0.171653 seconds and 4 git commands to generate.