]> git.pld-linux.org Git - packages/pspp.git/commitdiff
- updated to 1.0.1 (fixes CVE-2017-10791, CVE-2017-10792, CVE-2017-12958, CVE-2017...
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 Dec 2017 10:04:09 +0000 (11:04 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 Dec 2017 10:04:09 +0000 (11:04 +0100)
- removed obsolete perl-no-dot-in-inc patch
- added perl patch, package perl-PSPP module
- package glade extension for PSPP developers

perl-no-dot-in-inc.patch [deleted file]
pspp-perl.patch [new file with mode: 0644]
pspp.spec

diff --git a/perl-no-dot-in-inc.patch b/perl-no-dot-in-inc.patch
deleted file mode 100644 (file)
index 218f19d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- pspp-0.10.2/perl-module/Makefile.PL~       2016-04-03 03:57:38.000000000 +0200
-+++ pspp-0.10.2/perl-module/Makefile.PL        2017-07-02 16:14:11.818358611 +0200
-@@ -4,7 +4,7 @@
- # the contents of the Makefile that is written.
--do 'pspp-module-config' || do {
-+do './pspp-module-config' || do {
-     my $build = prompt ("Enter the location of the build directory of the configured pspp source:", "" );
-     my $src = $top_srcdir;
diff --git a/pspp-perl.patch b/pspp-perl.patch
new file mode 100644 (file)
index 0000000..f757744
--- /dev/null
@@ -0,0 +1,11 @@
+--- pspp-1.0.1/perl-module/automake.mk.orig    2017-07-30 02:24:53.000000000 +0200
++++ pspp-1.0.1/perl-module/automake.mk 2017-12-02 10:35:47.151608731 +0100
+@@ -42,7 +42,7 @@
+        echo ');') > $(top_builddir)/perl-module/pspp-module-config
+ perl-module/Makefile: perl-module/Makefile.PL perl-module/pspp-module-config $(module_sources)
+-      $(AM_V_GEN)cd perl-module && $(PERL) Makefile.PL PREFIX=$(prefix) \
++      $(AM_V_GEN)cd perl-module && $(PERL) Makefile.PL INSTALLDIRS=vendor \
+                                                          OPTIMIZE="$(CFLAGS) $(CPPFLAGS)" \
+                                                          LD="`$(PERL) -V::ld:` $(LDFLAGS)"
index a641d9d853b0abf24700546dffed1ecc6b39aa2d..916ddf6569bfbe91319b2196a55e7153790b739e 100644 (file)
--- a/pspp.spec
+++ b/pspp.spec
@@ -1,35 +1,46 @@
+#
+# Conditional build:
+%bcond_without         glade   # Glade extensions for PSPP development
+%bcond_without perl    # Perl module
+
+%include       /usr/lib/rpm/macros.perl
 Summary:       GNU PSPP - program for statistical analysis of sampled data
 Summary(pl.UTF-8):     GNU PSPP - program do analizy statystycznej danych próbkowanych
 Name:          pspp
-Version:       0.10.2
+Version:       1.0.1
 Release:       1
 License:       GPL v3+
 Group:         Applications/Science
 Source0:       http://ftp.gnu.org/gnu/pspp/%{name}-%{version}.tar.gz
-# Source0-md5: 9c5a3295d59b07a9a4462148371723ae
+# Source0-md5: ac18c5da11915e59ec32fe00e541abb8
 Patch0:                %{name}-info.patch
-Patch1:                perl-no-dot-in-inc.patch
+Patch1:                %{name}-perl.patch
 URL:           http://www.gnu.org/software/pspp/
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake
 BuildRequires: cairo-devel >= 1.5
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 1:2.32
 BuildRequires: gsl-devel >= 1.13
-BuildRequires: gtk+3-devel >= 3.4.2
+BuildRequires: gtk+3-devel >= 3.14.5
 BuildRequires: gtksourceview3-devel >= 3.4.2
+%{?with_glade:BuildRequires:   libgladeui-devel >= 2.0}
+BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.0
-BuildRequires: ncurses-devel
 BuildRequires: openssl-devel
 BuildRequires: pango-devel >= 1:1.22
 BuildRequires: perl-base >= 5.005_03
+%{?with_perl:BuildRequires:    perl-devel >= 1:5.8}
 BuildRequires: pkgconfig
 BuildRequires: postgresql-devel
 BuildRequires: readline-devel
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: texinfo
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      cairo >= 1.5
 Requires:      glib2 >= 1:2.32
-Requires:      gtk+3 >= 3.4.2
+Requires:      gtk+3 >= 3.14.5
 Requires:      gtksourceview3 >= 3.4.2
 Requires:      pango >= 1:1.22
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -57,16 +68,50 @@ GNU PSP libraries command line tools.
 %description libs -l pl.UTF-8
 Biblioteki GNU PSPP i narzędzia linii poleceń.
 
+%package -n perl-PSPP
+Summary:       PSPP module for Perl
+Summary(pl.UTF-8):     Moduł PSPP dla Perla
+Group:         Development/Languages/Perl
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description -n perl-PSPP
+PSPP Perl module provides an interface to the libraries used by pspp
+to read and write system files.
+
+%description -n perl-PSPP -l pl.UTF-8
+Moduł Perla PSPP udostępnia interfejs do bibliotek wykorzystywanych
+przez pspp do odczytu i zapisu plików systemowych.
+
+%package -n glade3-pspp
+Summary:       Glade3 extensions for PSPP development
+Summary(pl.UTF-8):     Rozszerzenia Glade3 do rozwijania PSPP
+Group:         X11/Development/Libraries
+Requires:      libgladeui >= 2.0
+
+%description -n glade3-pspp
+Glade3 extensions for PSPP development.
+
+%description -n glade3-pspp -l pl.UTF-8
+Rozszerzenia Glade3 do rozwijania PSPP.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 
 %build
+#{__gettextize}
+%{__libtoolize}
+%{__aclocal} -I gl/m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        --disable-static \
+       %{?with_glade:--with-gui-tools} \
        --with-openssl \
-       --with-packager="PLD Linux (http://pld-linux.org)"
+       --with-packager="PLD Linux (http://pld-linux.org/)" \
+       %{!?with_perl:--without-perl-module}
 
 %{__make}
 
@@ -76,8 +121,17 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with perl}
+%{__make} -C perl-module install \
+       DESTDIR=$RPM_BUILD_ROOT
+%endif
+
 # API not exported
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pspp/lib{pspp,pspp-core}.{la,so}
+%if %{with glade}
+# loadable module
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/glade3/modules/*.la
+%endif
 
 %find_lang %{name}
 
@@ -108,3 +162,22 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/pspp/libpspp-core-%{version}.so
 %{_mandir}/man1/pspp-convert.1*
 %{_mandir}/man1/pspp-dump-sav.1*
+
+%if %{with perl}
+%files -n perl-PSPP
+%defattr(644,root,root,755)
+%{perl_vendorarch}/PSPP.pm
+%dir %{perl_vendorarch}/auto/PSPP
+%attr(755,root,root) %{perl_vendorarch}/auto/PSPP/PSPP.so
+%{_mandir}/man3/PSPP.3pm*
+%{_mandir}/man3/PSPP::Examples.3pm*
+%endif
+
+%if %{with glade}
+%files -n glade3-pspp
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/glade3/modules/libglade-psppire.so
+%{_datadir}/glade3/catalogs/psppire.xml
+%{_datadir}/glade3/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-*.png
+%{_datadir}/glade3/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-*.png
+%endif
This page took 0.183932 seconds and 4 git commands to generate.