]> git.pld-linux.org Git - packages/protobuf.git/commitdiff
- stop messing with memcpy version, we don't care and it breaks build on x32
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 6 Jun 2018 06:43:40 +0000 (08:43 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 6 Jun 2018 06:43:40 +0000 (08:43 +0200)
- rel 2

no-wrap-memcpy.patch [new file with mode: 0644]
protobuf.spec

diff --git a/no-wrap-memcpy.patch b/no-wrap-memcpy.patch
new file mode 100644 (file)
index 0000000..ed20e7a
--- /dev/null
@@ -0,0 +1,21 @@
+--- protobuf-3.5.1.1/ruby/ext/google/protobuf_c/extconf.rb~    2018-01-05 22:42:10.000000000 +0100
++++ protobuf-3.5.1.1/ruby/ext/google/protobuf_c/extconf.rb     2018-06-06 08:25:28.643970843 +0200
+@@ -2,16 +2,10 @@
+ require 'mkmf'
+-$CFLAGS += " -std=c99 -O3 -DNDEBUG"
++$CFLAGS += " -std=c99 -DNDEBUG"
+-if RUBY_PLATFORM =~ /linux/
+-  # Instruct the linker to point memcpy calls at our __wrap_memcpy wrapper.
+-  $LDFLAGS += " -Wl,-wrap,memcpy"
+-end
+-
+ $objs = ["protobuf.o", "defs.o", "storage.o", "message.o",
+-         "repeated_field.o", "map.o", "encode_decode.o", "upb.o",
+-         "wrap_memcpy.o"]
++         "repeated_field.o", "map.o", "encode_decode.o", "upb.o"]
+ create_makefile("google/protobuf_c")
index fc7744c937d679dbdd59945be226d21c9fb4093f..69512dd7b8af3014996f8ebb488e24ce206114c7 100644 (file)
@@ -9,15 +9,11 @@
 %bcond_without ruby    # Ruby bindings
 %bcond_without tests   # perform "make check"
 
-%ifarch x32
-%undefine with_ruby
-%endif
-
 Summary:       Protocol Buffers - Google's data interchange format
 Summary(pl.UTF-8):     Protocol Buffers - format wymiany danych Google
 Name:          protobuf
 Version:       3.5.1.1
-Release:       1
+Release:       2
 License:       BSD
 Group:         Libraries
 #Source0Download: https://github.com/google/protobuf/releases
@@ -25,6 +21,7 @@ Source0:      https://github.com/google/protobuf/archive/v%{version}/%{name}-%{versio
 # Source0-md5: 5005003ae6b94773c4bbca87a644b131
 Source1:       ftdetect-proto.vim
 Patch0:                system-gtest.patch
+Patch1:                no-wrap-memcpy.patch
 URL:           https://github.com/google/protobuf/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
@@ -208,6 +205,7 @@ opisów buforów protokołowych (Protocol Buffers).
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 ln -s /usr/src/gmock/src/gmock*.cc src
 
This page took 0.137819 seconds and 4 git commands to generate.