]> git.pld-linux.org Git - packages/protobuf.git/blame - protobuf.spec
- BR: rpm-pythonprov
[packages/protobuf.git] / protobuf.spec
CommitLineData
f132b5a5
JR
1#
2# TODO:
3# - add bindings for java and python
4# - add vim syntax package
5#
6Summary: Protocol Buffers - Google's data interchange format
7Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
8Name: protobuf
9db55fcc 9Version: 2.0.3
f132b5a5
JR
10Release: 1
11License: BSD
12Group: Libraries
13Source0: http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
9db55fcc 14# Source0-md5: 37e6e4d63434672c70bd977be9c372cb
f132b5a5 15URL: http://code.google.com/p/protobuf/
e2ad8a47 16BuildRequires: libstdc++-devel
ddf8d453 17BuildRequires: rpm-pythonprov
f132b5a5
JR
18Requires: %{name}-libs = %{version}-%{release}
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Protocol buffers are a flexible, efficient, automated mechanism
23for serializing structured data - similar to XML, but smaller,
24faster, and simpler. You define how you want your data to be
25structured once, then you can use special generated source code
26to easily write and read your structured data to and from
27a variety of data streams and using a variety of languages.
28You can even update your data structure without breaking deployed
29programs that are compiled against the "old" format.
30
31Google uses Protocol Buffers for almost all of its internal RPC
ddf8d453 32protocols and file formats.
f132b5a5 33
c7c7fabc
JB
34%description -l pl.UTF-8
35Bufory protokołowe to elastyczny, wydajny i zautomatyzowany sposób
36serializacji danych strukturalnych - podobny do XML-a, ale mniejszy,
37szybszy i prostszy. Definiuje się raz, jaką strukturę mają mieć dane,
38a następnie używa specjalnie wygenerowanego kodu źródłowego do łatwego
39zapisu i odczytu danych strukturalnych do i z różnych strumieni
40danych, z poziomu różnych języków. Można nawet uaktualniać strukturę
41danych bez psucia programów skompilowanych w oparciu o "stary" format.
42
43Google używa buforów protokołowych (Protocol Buffers) do prawie
44wszystkich wewnętrznych protokołów RPC i formatów plików.
f132b5a5
JR
45
46%package libs
47Summary: protobuf libraries
48Summary(pl.UTF-8): Biblioteki protobuf
49Group: Libraries
50
51%description libs
52protobuf libraries.
53
54%description libs -l pl.UTF-8
55Biblioteki protobuf.
56
57%package devel
58Summary: Header files for protobuf libraries
59Summary(pl.UTF-8): Pliki nagłówkowe bibliotek protobuf
60Group: Development/Libraries
61Requires: %{name}-libs = %{version}-%{release}
e2ad8a47 62Requires: libstdc++-devel
f132b5a5
JR
63
64%description devel
65Header files for protobuf libraries.
66
67%description devel -l pl.UTF-8
68Pliki nagłówkowe bibliotek protobuf.
69
70%package static
71Summary: Static protobuf libraries
72Summary(pl.UTF-8): Statyczne biblioteki protobuf
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75
76%description static
77Static protobuf libraries.
78
79%description static -l pl.UTF-8
80Statyczne biblioteki protobuf.
81
82%prep
83%setup -q
84
85%build
86%configure
87%{__make}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
96install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post libs -p /sbin/ldconfig
102%postun libs -p /sbin/ldconfig
103
104%files
105%defattr(644,root,root,755)
106%doc CHANGES.txt CONTRIBUTORS.txt README.txt
107%attr(755,root,root) %{_bindir}/protoc
108
109%files libs
110%defattr(644,root,root,755)
e5c615f2 111%attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
9db55fcc 112%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.3
e5c615f2 113%attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
9db55fcc 114%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.3
f132b5a5
JR
115
116%files devel
117%defattr(644,root,root,755)
e5c615f2
JB
118%attr(755,root,root) %{_libdir}/libprotobuf.so
119%attr(755,root,root) %{_libdir}/libprotoc.so
120%{_libdir}/libprotobuf.la
121%{_libdir}/libprotoc.la
f132b5a5 122%{_includedir}/google
f132b5a5
JR
123%{_examplesdir}/%{name}-%{version}
124
125%files static
126%defattr(644,root,root,755)
e5c615f2
JB
127%{_libdir}/libprotobuf.a
128%{_libdir}/libprotoc.a
This page took 0.087227 seconds and 4 git commands to generate.