]> git.pld-linux.org Git - packages/proftpd.git/commitdiff
- rel 2; fix FSCachePolicy parameter handling auto/th/proftpd-1.3.6a-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Nov 2019 20:17:53 +0000 (21:17 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Nov 2019 20:17:53 +0000 (21:17 +0100)
args.patch [new file with mode: 0644]
proftpd.spec

diff --git a/args.patch b/args.patch
new file mode 100644 (file)
index 0000000..d482c3b
--- /dev/null
@@ -0,0 +1,34 @@
+From bcaa485b4edbb4d1283b5d3ccdd0aa1ee02f0ae7 Mon Sep 17 00:00:00 2001
+From: TJ Saunders <tj@castaglia.org>
+Date: Thu, 7 Nov 2019 09:58:00 -0800
+Subject: [PATCH] Issue #863: Make sure we increment our index, for properly
+ processing the `FSCachePolicy` directive parameters.  Oops.
+
+---
+ modules/mod_core.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/modules/mod_core.c b/modules/mod_core.c
+index 1da6b4c80..c12425a1b 100644
+--- a/modules/mod_core.c
++++ b/modules/mod_core.c
+@@ -1450,7 +1450,8 @@ MODRET set_fscachepolicy(cmd_rec *cmd) {
+     if (strncasecmp(cmd->argv[i], "size", 5) == 0) {
+       int size;
+-      size = atoi(cmd->argv[i++]);
++      i++;
++      size = atoi(cmd->argv[i]);
+       if (size < 1) {
+         CONF_ERROR(cmd, "size parameter must be greater than 1");
+       }
+@@ -1460,7 +1461,8 @@ MODRET set_fscachepolicy(cmd_rec *cmd) {
+     } else if (strncasecmp(cmd->argv[i], "maxAge", 7) == 0) {
+       int max_age;
+-      max_age = atoi(cmd->argv[i++]);
++      i++;
++      max_age = atoi(cmd->argv[i]);
+       if (max_age < 1) {
+         CONF_ERROR(cmd, "maxAge parameter must be greater than 1");
+       }
index 76f94963158eb59ac5d437cc412fb031e9f4da22..9bf3d41d0eb9c916f74056efc6c28cba4d0a3934 100644 (file)
@@ -24,7 +24,7 @@ Summary(pt_BR.UTF-8): Servidor FTP profissional, com sintaxe de configuração s
 Summary(zh_CN.UTF-8):  易于管理的,安全的 FTP 服务器
 Name:          proftpd
 Version:       1.3.6a
-Release:       1
+Release:       2
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons
@@ -48,6 +48,7 @@ Patch0:               %{name}-paths.patch
 Patch1:                %{name}-noautopriv.patch
 Patch2:                %{name}-wtmp.patch
 Patch3:                %{name}-pool.patch
+Patch4:                args.patch
 URL:           http://www.proftpd.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
@@ -449,6 +450,7 @@ dodaje hosty do pliku /etc/hosts.deny.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 # mod_clamav
 patch -p0 < mod_clamav-%{mod_clamav_version}/proftpd.patch
This page took 0.133292 seconds and 4 git commands to generate.