]> git.pld-linux.org Git - packages/ppp.git/blame_incremental - ppp.spec
- disable mppc patch by default (changes existing configuration options and added...
[packages/ppp.git] / ppp.spec
... / ...
CommitLineData
1# TODO:
2# - check mppc patch
3# - check if %{_libdir}/pppd/%{version} path is needed, if not drop the symlink
4
5# Conditional build:
6%bcond_with mppc # MPPC/MPPE-56/LZS support (upstream-incompatible configuration, support not in mainline/PLD kernel)
7%bcond_without pppoatm # PPPoATM plugin (requires kernel 2.4+ and atm-devel)
8%bcond_with srp # SRP support
9%bcond_without systemd # systemd notifications
10#
11Summary: ppp daemon package for Linux
12Summary(de.UTF-8): ppp-Dämonpaket für Linux
13Summary(es.UTF-8): Servidor ppp para Linux
14Summary(fr.UTF-8): Paquetage du démon ppp pour Linux
15Summary(pl.UTF-8): Demon PPP dla Linuksa
16Summary(pt_BR.UTF-8): Servidor ppp para Linux
17Summary(ru.UTF-8): Демон ppp
18Summary(tr.UTF-8): PPP sunucu süreci
19Summary(zh_CN.UTF-8): PPP 配置和管理软件包
20Name: ppp
21Version: 2.5.0
22Release: 1
23Epoch: 3
24License: distributable
25Group: Networking/Daemons
26Source0: https://download.samba.org/pub/ppp/%{name}-%{version}.tar.gz
27# Source0-md5: ce5fd7b9f6e1095ae6c0c11365c444eb
28Source1: %{name}.pamd
29Source2: %{name}.pon
30Source3: %{name}.poff
31Source4: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32# Source4-md5: 3801b59005bef8f52856300fe3167a64
33Source5: %{name}.logrotate
34Patch2: %{name}-debian_scripts.patch
35Patch4: %{name}-pidfile-owner.patch
36# http://public.planetmirror.com/pub/mppe/pppd-2.4.2-chapms-strip-domain.patch.gz
37Patch7: pppd-2.4.2-chapms-strip-domain.patch
38# http://mppe-mppc.alphacron.de/%{name}-2.4.3-mppe-mppc-1.1.patch.gz
39Patch10: %{name}-2.4.3-mppe-mppc-1.1.patch
40URL: https://ppp.samba.org/
41BuildRequires: autoconf >= 2.69
42BuildRequires: automake
43BuildRequires: libpcap-devel >= 2:0.8.1
44BuildRequires: libtool >= 2:2
45%{?with_pppoatm:BuildRequires: linux-atm-devel}
46# <linux/if_pppol2tp.h>
47BuildRequires: linux-libc-headers >= 7:2.6.23
48BuildRequires: openssl-devel
49BuildRequires: pam-devel
50%{?with_srp:BuildRequires: srp-devel}
51%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
52Requires: pam >= 0.77.3
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%description
56This is the daemon and documentation for PPP support. It requires a
57kernel greater than 2.2.11 which is built with PPP support. The
58default kernels include PPP support as a module. This version supports
59IPv6, too.
60
61%description -l de.UTF-8
62Dies ist der Dämon und die Dokumentation für PPP-Support. Erfordert
63einen Kernel höher als 2.2.11, der mit PPP-Support gebaut ist. Die
64Standard-Kernel schließen PPP-Support als Modul ein. (IPv6)
65
66%description -l es.UTF-8
67Este es el servidor y la documentación para soporte PPP. Requiere un
68kernel superior al 2.0.
69
70%description -l fr.UTF-8
71Ceci est le démon et la documentation pour le support PPP. Cela
72réclame un noyau supérieur au 2.2.11 et construit avec le support PPP.
73
74%description -l pl.UTF-8
75Pakiet zawiera demona i dokumentację umożliwiającą korzystanie z
76protokołu PPP. Wymaga jądra 2.2.11 - lub późniejszego - z wkompilowaną
77obsługą protokołu PPP. Standardowe jądro z dystrybucji zawiera
78wsparcie dla PPP skompilowane jako moduł. (IPv6)
79
80%description -l pt_BR.UTF-8
81Este é o servidor e a documentação para suporte PPP. Ele requer um
82kernel superior ao 2.0.
83
84%description -l ru.UTF-8
85Демон, конфигурационные файлы и документация для поддержки PPP.
86
87%description -l tr.UTF-8
88Bu paket PPP desteği için belgeler ve sunucu sürecini içerir. Çekirdek
89sürümünun 2.2.11'dan daha yüksek olmasını gerektirir.
90
91%package plugin-devel
92Summary: Stuff needed to build plugins for pppd
93Summary(pl.UTF-8): Rzeczy potrzebne do budowania wtyczek dla pppd
94Group: Development/Libraries
95# doesn't require base but enforce new version
96Conflicts: %{name} < %{epoch}:%{version}-%{release}
97
98%description plugin-devel
99Development files needed to build plugins for pppd.
100
101%description plugin-devel -l pl.UTF-8
102Pliki nagłówkowe potrzebne do budowania wtyczek dla pppd.
103
104%package plugin-pppoatm
105Summary: PPPoATM plugin for pppd
106Summary(pl.UTF-8): Wtyczka PPPoATM dla pppd
107Group: Libraries
108Requires: %{name} = %{epoch}:%{version}-%{release}
109
110%description plugin-pppoatm
111PPPoATM plugin for pppd.
112
113%description plugin-pppoatm -l pl.UTF-8
114Wtyczka PPPoATM dla pppd.
115
116%prep
117%setup -q
118%patch2 -p1
119%patch4 -p1
120%patch7 -p1
121%if %{with mppc}
122%patch10 -p1
123%endif
124
125# use headers from llh instead of older supplied by ppp, incompatible with current llh
126%{__rm} include/linux/*.h
127
128%{__sed} -i -e 's,/usr/lib64/openssl/engines/,/%{_lib}/engines-3/,' \
129 -e 's,/usr/lib64/,%{_libdir}/,' etc.ppp/openssl.cnf
130
131%build
132%{__libtoolize}
133%{__aclocal} -I m4
134%{__autoconf}
135%{__autoheader}
136%{__automake}
137%configure \
138 --enable-cbcp \
139 --enable-mslanman \
140 --enable-multilink \
141 --disable-silent-rules \
142 %{?with_systemd:--enable-systemd} \
143 %{!?with_pppoatm:--without-atm} \
144 --with-plugin-dir=%{_libdir}/pppd/plugins \
145 %{!?with_srp:--without-srp}
146
147%{__make}
148
149%install
150rm -rf $RPM_BUILD_ROOT
151install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/ppp/peers,/var/log} \
152 $RPM_BUILD_ROOT/etc/{pam.d,logrotate.d}
153
154%{__make} install \
155 DESTDIR=$RPM_BUILD_ROOT
156
157%{__rm} $RPM_BUILD_ROOT%{_libdir}/pppd/plugins/*.la
158
159install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/pon
160install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poff
161install -p debian/plog $RPM_BUILD_ROOT%{_bindir}
162
163cp -p etc.ppp/chap-secrets $RPM_BUILD_ROOT%{_sysconfdir}/ppp
164cp -p debian/pap-secrets $RPM_BUILD_ROOT%{_sysconfdir}/ppp
165cp -p debian/options $RPM_BUILD_ROOT%{_sysconfdir}/ppp
166cp -p debian/options.ttyXX $RPM_BUILD_ROOT%{_sysconfdir}/ppp
167
168bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
169%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.ppp-non-english-man-pages
170
171cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/ppp
172> $RPM_BUILD_ROOT/var/log/ppp.log
173
174cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/ppp
175
176[ ! -d example-scripts ] || %{__rm} -r example-scripts # make install reentrant
177cp -pr scripts example-scripts
178%{__rm} example-scripts/Makefile*
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%pretrans
184# %{version} used to be directory
185if [ -d %{_libdir}/pppd/%{version} -a ! -L %{_libdir}/pppd/%{version} ]; then
186 set -e
187 rm -f %{_libdir}/pppd/plugins
188 mv -f %{_libdir}/pppd/{%{version},plugins}
189 ln -snf plugins %{_libdir}/pppd/%{version}
190fi
191
192%files
193%defattr(644,root,root,755)
194%doc Changes-2.3 FAQ NEWS README README.{MPPE,MSCHAP80,MSCHAP81,cbcp,eap-tls,linux,pppoe,pppol2tp,pwfd} %{?with_srp:README.eap-srp} SETUP debian/{README.debian,win95.ppp} example-scripts
195%attr(755,root,root) %{_bindir}/plog
196%attr(755,root,root) %{_bindir}/poff
197%attr(755,root,root) %{_bindir}/pon
198%attr(755,root,root) %{_sbindir}/chat
199%attr(755,root,root) %{_sbindir}/pppd
200%attr(755,root,root) %{_sbindir}/pppdump
201%attr(755,root,root) %{_sbindir}/pppoe-discovery
202%attr(755,root,root) %{_sbindir}/pppstats
203%{?with_srp:%attr(755,root,root) %{_sbindir}/srp-entry}
204%dir %{_libdir}/pppd
205%dir %{_libdir}/pppd/plugins
206%attr(755,root,root) %{_libdir}/pppd/plugins/minconn.so
207%attr(755,root,root) %{_libdir}/pppd/plugins/openl2tp.so
208%attr(755,root,root) %{_libdir}/pppd/plugins/passprompt.so
209%attr(755,root,root) %{_libdir}/pppd/plugins/passwordfd.so
210%attr(755,root,root) %{_libdir}/pppd/plugins/pppoe.so
211%attr(755,root,root) %{_libdir}/pppd/plugins/pppol2tp.so
212%attr(755,root,root) %{_libdir}/pppd/plugins/radattr.so
213%attr(755,root,root) %{_libdir}/pppd/plugins/radius.so
214%attr(755,root,root) %{_libdir}/pppd/plugins/radrealms.so
215%attr(755,root,root) %{_libdir}/pppd/plugins/winbind.so
216
217%{_mandir}/man8/chat.8*
218%{_mandir}/man8/pppd.8*
219%{_mandir}/man8/pppd-radattr.8*
220%{_mandir}/man8/pppd-radius.8*
221%{_mandir}/man8/pppdump.8*
222%{_mandir}/man8/pppoe-discovery.8*
223%{_mandir}/man8/pppstats.8*
224%lang(fr) %{_mandir}/fr/man8/*
225%lang(ja) %{_mandir}/ja/man8/*
226%lang(ko) %{_mandir}/ko/man8/*
227%lang(pl) %{_mandir}/pl/man8/*
228
229%attr(600,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/chap-secrets
230%attr(600,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/pap-secrets
231%attr(600,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/eaptls-client
232%attr(600,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/eaptls-server
233%attr(600,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/openssl.cnf
234%config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/options
235%config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ppp/options.ttyXX
236%dir %{_sysconfdir}/ppp/peers
237%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/ppp
238%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/ppp
239%attr(640,root,root) %ghost /var/log/ppp.log
240
241%files plugin-devel
242%defattr(644,root,root,755)
243%doc PLUGINS
244%{_includedir}/pppd
245%{_pkgconfigdir}/pppd.pc
246
247%if %{with pppoatm}
248%files plugin-pppoatm
249%defattr(644,root,root,755)
250%attr(755,root,root) %{_libdir}/pppd/plugins/pppoatm.so
251%endif
This page took 0.086202 seconds and 4 git commands to generate.