]> git.pld-linux.org Git - packages/povray.git/commitdiff
- fixed building with libpng 1.4.0 auto/th/povray-3_6_1-8 auto/ti/povray-3_6_1-8
authorArtur Frysiak <artur@frysiak.net>
Fri, 29 Jan 2010 20:45:46 +0000 (20:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    povray-png.patch -> 1.1
    povray.spec -> 1.66

povray-png.patch [new file with mode: 0644]
povray.spec

diff --git a/povray-png.patch b/povray-png.patch
new file mode 100644 (file)
index 0000000..6ba9e93
--- /dev/null
@@ -0,0 +1,29 @@
+--- povray-3.6.1/source/png_pov.cpp.wiget      2010-01-29 21:35:24.000000000 +0100
++++ povray-3.6.1/source/png_pov.cpp    2010-01-29 21:35:33.000000000 +0100
+@@ -782,7 +782,7 @@ PNG_Image::~PNG_Image()
+       {
+          // finished prematurely - trick into thinking done
+          png_ptr->num_rows = png_ptr->row_number;
+-         png_write_finish_row(png_ptr);
++         png_write_row(png_ptr, row_ptr);
+       }
+ #ifdef POV_COMMENTS // temporarily skip comment writing code 
+@@ -1428,7 +1428,7 @@ void Read_Png_Image(IMAGE *Image, char *
+               if(r_info_ptr->valid & PNG_INFO_tRNS)
+               {
+                       for (index = 0; index < r_info_ptr->num_trans; index++)
+-                              cmap[index].Transmit = 255 - r_info_ptr->trans[index];
++                              cmap[index].Transmit = 255 - r_info_ptr->trans_alpha[index];
+               }
+               Image->data.map_lines = (unsigned char **)POV_MALLOC(height * sizeof(unsigned char *), "PNG image");
+@@ -1461,7 +1461,7 @@ void Read_Png_Image(IMAGE *Image, char *
+               if(r_info_ptr->valid & PNG_INFO_tRNS)
+               {
+                       for (index = 0; index < r_info_ptr->num_trans; index++)
+-                              cmap[index].Transmit = 255 - r_info_ptr->trans[index];
++                              cmap[index].Transmit = 255 - r_info_ptr->trans_alpha[index];
+               }
+               Image->data.map_lines = (unsigned char **)POV_MALLOC(height * sizeof(unsigned char *), "PNG image");
index af9ae74cd5351c499117a4052bffebb641380c22..c374a6fa8f7adb6d189e3ef71b66bd6988ac3327 100644 (file)
@@ -10,7 +10,7 @@ Summary:      Persistence of Vision Ray Tracer
 Summary(pl.UTF-8):     Persistence of Vision Ray Tracer
 Name:          povray
 Version:       3.6.1
-Release:       7
+Release:       8
 Epoch:         1
 License:       distributable
 Group:         Applications/Graphics
@@ -24,11 +24,12 @@ Patch2:             %{name}-X-libs.patch
 Patch3:                %{name}-lib64.patch
 Patch4:                %{name}-no_svgalib.patch
 Patch5:                %{name}-m4.patch
+Patch6:                %{name}-png.patch
 URL:           http://www.povray.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libjpeg-devel
-BuildRequires: libpng-devel >= 1.0.8
+BuildRequires: libpng-devel >= 1.4.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 %{?with_pvm:BuildRequires:     pvm-devel >= 3.4.3-24}
@@ -112,6 +113,7 @@ PVM/xwin.
 ##%patch4 -p1
 %endif
 %patch5 -p1
+%patch6 -p1
 
 %build
 %{__aclocal}
This page took 0.155849 seconds and 4 git commands to generate.