]> git.pld-linux.org Git - packages/povray.git/commitdiff
- up to 3.8.0-beta.2
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Aug 2021 22:19:24 +0000 (00:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Aug 2021 22:19:24 +0000 (00:19 +0200)
povray-c++11.patch [deleted file]
povray.spec

diff --git a/povray-c++11.patch b/povray-c++11.patch
deleted file mode 100644 (file)
index da8ddbc..0000000
+++ /dev/null
@@ -1,184 +0,0 @@
---- povray-3.7.1-rc.1/unix/povconfig/syspovconfig.h.orig       2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/unix/povconfig/syspovconfig.h    2019-05-05 20:50:54.936577187 +0200
-@@ -50,13 +50,13 @@
- #include <exception>
- #include <limits>
- #include <list>
-+#include <memory>
- #include <stdexcept>
- #include <string>
- #include <vector>
- // boost headers
- #include <boost/intrusive_ptr.hpp>
--#include <boost/tr1/memory.hpp>
- #ifdef HAVE_CONFIG_H
- // from directory "." (generated by ./configure)
-@@ -91,12 +91,11 @@
- // to in a few other places.
- using std::runtime_error;
--// these may actually be the boost implementations, depending on what boost/tr1/memory.hpp has pulled in
--using std::tr1::shared_ptr;
--using std::tr1::weak_ptr;
--using std::tr1::dynamic_pointer_cast;
--using std::tr1::static_pointer_cast;
--using std::tr1::const_pointer_cast;
-+using std::shared_ptr;
-+using std::weak_ptr;
-+using std::dynamic_pointer_cast;
-+using std::static_pointer_cast;
-+using std::const_pointer_cast;
- using boost::intrusive_ptr;
---- povray-3.7.1-rc.1/source/base/precomp.h.orig       2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/base/precomp.h    2019-05-05 21:10:21.240868851 +0200
-@@ -62,6 +62,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -81,6 +82,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
---- povray-3.7.1-rc.1/source/backend/precomp.h.orig    2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/backend/precomp.h 2019-05-05 21:20:44.480101155 +0200
-@@ -60,6 +60,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -78,6 +79,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
---- povray-3.7.1-rc.1/source/core/precomp.h.orig       2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/core/precomp.h    2019-05-05 21:26:40.592038719 +0200
-@@ -60,6 +60,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -78,6 +79,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
---- povray-3.7.1-rc.1/source/core/shape/parametric.cpp.orig    2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/core/shape/parametric.cpp 2019-05-05 21:55:01.000916811 +0200
-@@ -37,8 +37,7 @@
- #include "core/shape/parametric.h"
- #include <algorithm>
--
--#include <boost/tr1/array.hpp>
-+#include <array>
- #include "core/math/matrix.h"
- #include "core/render/ray.h"
-@@ -441,7 +440,7 @@
-     Vector3d RU, RV;
-     Vector2d uv_vect;
--    std::tr1::array<GenericScalarFunctionInstance,3> aFn = {
-+    std::array<GenericScalarFunctionInstance,3> aFn = {
-         GenericScalarFunctionInstance(Function[0], Thread),
-         GenericScalarFunctionInstance(Function[1], Thread),
-         GenericScalarFunctionInstance(Function[2], Thread)
-@@ -919,7 +918,7 @@
-         throw POV_EXCEPTION_STRING("Cannot allocate memory for parametric precomputation data.");
-     PrecompLastDepth = 1 << (depth - 1);
--    std::tr1::array<GenericScalarFunctionInstance,3> aFn = {
-+    std::array<GenericScalarFunctionInstance,3> aFn = {
-         GenericScalarFunctionInstance(Function[0], Thread),
-         GenericScalarFunctionInstance(Function[1], Thread),
-         GenericScalarFunctionInstance(Function[2], Thread)
---- povray-3.7.1-rc.1/source/frontend/precomp.h.orig   2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/frontend/precomp.h        2019-05-06 05:16:59.760443675 +0200
-@@ -60,6 +60,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -78,6 +79,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
---- povray-3.7.1-rc.1/source/parser/precomp.h.orig     2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/parser/precomp.h  2019-05-06 05:24:59.805900707 +0200
-@@ -60,6 +60,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -78,6 +79,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
---- povray-3.7.1-rc.1/source/povms/precomp.h.orig      2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/povms/precomp.h   2019-05-06 05:29:58.565082232 +0200
-@@ -60,6 +60,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -78,6 +79,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
---- povray-3.7.1-rc.1/source/vm/precomp.h.orig 2017-06-22 20:42:33.000000000 +0200
-+++ povray-3.7.1-rc.1/source/vm/precomp.h      2019-05-06 05:30:54.058009990 +0200
-@@ -60,6 +60,7 @@
- #include <exception>
- #include <list>
- #include <map>
-+#include <memory>
- #include <new>
- #include <set>
- #include <stack>
-@@ -78,6 +79,5 @@
- #include <boost/thread.hpp>
- #include <boost/thread/condition.hpp>
- #endif
--#include <boost/tr1/memory.hpp>
- #include <boost/unordered_map.hpp>
index d511b0719f55375721f210573f29d922cb03e0f4..3cb46d52719f43ef912d59d2899780ff20bc8e28 100644 (file)
@@ -4,20 +4,19 @@
 %bcond_with    pvm     # - with PVM support
 %bcond_with    svga    # - with svgalib support (doesn't work on many platforms)
 #
 %bcond_with    pvm     # - with PVM support
 %bcond_with    svga    # - with svgalib support (doesn't work on many platforms)
 #
-%define        subver  rc.1
-%define        rel     4
+%define        subver  beta.2
+%define        rel     1
 Summary:       Persistence of Vision Ray Tracer
 Summary(pl.UTF-8):     Persistence of Vision Ray Tracer
 Name:          povray
 Summary:       Persistence of Vision Ray Tracer
 Summary(pl.UTF-8):     Persistence of Vision Ray Tracer
 Name:          povray
-Version:       3.7.1
+Version:       3.8.0
 Release:       0.%{subver}.%{rel}
 Epoch:         1
 License:       AGPL v3+
 Group:         Applications/Graphics
 #Source0Download: https://github.com/POV-Ray/povray/releases
 Source0:       https://github.com/POV-Ray/povray/archive/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
 Release:       0.%{subver}.%{rel}
 Epoch:         1
 License:       AGPL v3+
 Group:         Applications/Graphics
 #Source0Download: https://github.com/POV-Ray/povray/releases
 Source0:       https://github.com/POV-Ray/povray/archive/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: 6445dd620d709ad4b394aca1e7d976cb
-Patch0:                %{name}-c++11.patch
+# Source0-md5: f253c837495da02189723059236e9434
 Patch1:                x32.patch
 URL:           http://www.povray.org/
 BuildRequires: OpenEXR-devel >= 1.2
 Patch1:                x32.patch
 URL:           http://www.povray.org/
 BuildRequires: OpenEXR-devel >= 1.2
@@ -106,7 +105,6 @@ PVM/xwin.
 
 %prep
 %setup -q -n %{name}-%{version}-%{subver}
 
 %prep
 %setup -q -n %{name}-%{version}-%{subver}
-%patch0 -p1
 %ifarch x32
 %patch1 -p1
 %endif
 %ifarch x32
 %patch1 -p1
 %endif
This page took 0.195885 seconds and 4 git commands to generate.