]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
fa164732ca225fe4ecb64adb0c2ae1ea992b7d38
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 Summary:        Persistence of Vision Ray Tracer
8 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
9 Name:           povray
10 Version:        3.7.0.0
11 Release:        3
12 Epoch:          1
13 License:        distributable
14 Group:          Applications/Graphics
15 Source0:        https://github.com/POV-Ray/povray/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  c9473256677808e9e3246e6eb8f69a75
17 Source1:        %{name}-ax_boost_base.m4
18 Patch0:         boost-1.50.patch
19 URL:            http://www.povray.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel >= 1.4.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtiff-devel
26 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
27 %{?with_svga:BuildRequires:     svgalib-devel}
28 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %if %{with pvm}
33 %define         _pvmarch        %(/usr/bin/pvmgetarch)
34 %define         _pvmroot        /usr/%{_lib}/pvm3
35 %endif
36
37 %description
38 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
39 photo-realistic images using a rendering technique called ray-tracing.
40 It reads in a text file containing information describing the objects
41 and lighting in a scene and generates an image of that scene from the
42 view point of a camera also described in the text file. Ray-tracing is
43 not a fast process by any means, but it produces very high quality
44 images with realistic reflections, shading, perspective and other
45 effects.
46
47 %description -l pl.UTF-8
48 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
49 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
50 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
51 obiekty oraz światło przedstawianego świata, a następnie generuje
52 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
53 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
54 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
55 efektami, tj. odbicia światła, cienie, perspektywa i inne.
56
57 %package X11
58 Summary:        X Window povray executable
59 Summary(pl.UTF-8):      povray pod X Window
60 Group:          Applications/Graphics
61 Requires:       %{name} = %{epoch}:%{version}-%{release}
62
63 %description X11
64 The Persistence of Vision(tm) Ray-Tracer X Window executable.
65
66 %description X11 -l pl.UTF-8
67 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
68 Window.
69
70 %package pvm
71 Summary:        PVM/Unix povray executable
72 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
73 Group:          Applications/Graphics
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75
76 %description pvm
77 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
78
79 %description pvm -l pl.UTF-8
80 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
81 PVM/Unix.
82
83 %package pvm-X11
84 Summary:        PVM/xwin povray executable
85 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
86 Group:          Applications/Graphics
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88
89 %description pvm-X11
90 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
91
92 %description pvm-X11 -l pl.UTF-8
93 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
94 PVM/xwin.
95
96 %prep
97 %setup -q
98 cp %{SOURCE1} unix/config/ax_boost_base.m4
99 %patch0 -p1
100
101 %build
102 cd unix
103 ./prebuild.sh
104 cd ..
105
106 %{__automake}
107 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
108 %if %{with x} && %{with pvm}
109 %configure \
110         --libdir=%{_datadir} \
111         --enable-pvm \
112         --with-pvm-arch=%{_pvmarch} \
113         --with-pvm-libs=%{_libdir}
114 %{__make}
115 install unix/povray x-pvmpov
116 %endif
117
118 %if %{with pvm}
119 %{__make} clean
120
121 %configure \
122         --libdir=%{_datadir} \
123         --enable-pvm \
124         --with-pvm-arch=%{_pvmarch} \
125         --with-pvm-libs=%{_libdir} \
126         --without-x
127 %{__make}
128 install unix/povray pvmpov
129 %endif
130
131 %if %{with x}
132 %configure \
133         --libdir=%{_datadir}
134 %{__make}
135 install unix/povray x-povray
136 %{__make} clean
137 %endif
138
139 %configure \
140         --libdir=%{_datadir} \
141         --without-x
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
147 %if %{with pvm}
148 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
149 %endif
150
151 %{__make} install \
152         INSTALL="install -c -D" \
153         mkdir_p="mkdir -p" \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 %if %{with x}
157 install x-povray $RPM_BUILD_ROOT%{_bindir}
158 %endif
159
160 %if %{with x} && %{with pvm}
161 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
162 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
163 %endif
164
165 %if %{with pvm}
166 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
167 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
168 %endif
169
170 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
171 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS ChangeLog NEWS README* changes.txt
179 %attr(755,root,root) %{_bindir}/povray
180 %{_datadir}/povray*
181 %{_docdir}/povray*
182 %{_mandir}/man?/*
183 %dir %{_sysconfdir}/povray
184 %dir %{_sysconfdir}/povray/3.7
185 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
186 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
187
188 %if %{with x}
189 %files X11
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/x-povray
192 %endif
193
194 %if %{with pvm}
195 %files pvm
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
198 %attr(755,root,root) %{_bindir}/pvmpov
199 %endif
200
201 %if %{with pvm} && %{with x}
202 %files pvm-X11
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
205 %attr(755,root,root) %{_bindir}/x-pvmpov
206 %endif
This page took 0.030193 seconds and 2 git commands to generate.