]> git.pld-linux.org Git - packages/povray.git/blob - povray.spec
2a2c5b322a2716ad493c29ea287ae80c114f95b4
[packages/povray.git] / povray.spec
1 #
2 # Conditional build:
3 %bcond_without  x       # - without X11 subpackage
4 %bcond_with     pvm     # - with PVM support
5 %bcond_with     svga    # - with svgalib support (doesn't work on many platforms)
6 #
7 Summary:        Persistence of Vision Ray Tracer
8 Summary(pl.UTF-8):      Persistence of Vision Ray Tracer
9 Name:           povray
10 Version:        3.7.0.0
11 Release:        1
12 Epoch:          1
13 License:        distributable
14 Group:          Applications/Graphics
15 Source0:        https://github.com/POV-Ray/povray/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  c9473256677808e9e3246e6eb8f69a75
17 Source1:        %{name}-ax_boost_base.m4
18 Patch0:         %{name}-nouserfiles.patch
19 Patch1:         boost-1.50.patch
20 URL:            http://www.povray.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel >= 1.4.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtiff-devel
27 %{?with_pvm:BuildRequires:      pvm-devel >= 3.4.3-24}
28 %{?with_svga:BuildRequires:     svgalib-devel}
29 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %if %{with pvm}
34 %define         _pvmarch        %(/usr/bin/pvmgetarch)
35 %define         _pvmroot        /usr/%{_lib}/pvm3
36 %endif
37
38 %description
39 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
40 photo-realistic images using a rendering technique called ray-tracing.
41 It reads in a text file containing information describing the objects
42 and lighting in a scene and generates an image of that scene from the
43 view point of a camera also described in the text file. Ray-tracing is
44 not a fast process by any means, but it produces very high quality
45 images with realistic reflections, shading, perspective and other
46 effects.
47
48 %description -l pl.UTF-8
49 Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
50 fotorealistyczne obrazy za pomocą techniki renderingu zwanej
51 ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
52 obiekty oraz światło przedstawianego świata, a następnie generuje
53 rysunek z punktu widzenia kamery, która także jest definiowana w w/w
54 pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
55 ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
56 efektami, tj. odbicia światła, cienie, perspektywa i inne.
57
58 %package X11
59 Summary:        X Window povray executable
60 Summary(pl.UTF-8):      povray pod X Window
61 Group:          Applications/Graphics
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63
64 %description X11
65 The Persistence of Vision(tm) Ray-Tracer X Window executable.
66
67 %description X11 -l pl.UTF-8
68 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
69 Window.
70
71 %package pvm
72 Summary:        PVM/Unix povray executable
73 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/Unix
74 Group:          Applications/Graphics
75 Requires:       %{name} = %{epoch}:%{version}-%{release}
76
77 %description pvm
78 The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
79
80 %description pvm -l pl.UTF-8
81 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
82 PVM/Unix.
83
84 %package pvm-X11
85 Summary:        PVM/xwin povray executable
86 Summary(pl.UTF-8):      Plik wykonywalny povray dla PVM/xwin
87 Group:          Applications/Graphics
88 Requires:       %{name} = %{epoch}:%{version}-%{release}
89
90 %description pvm-X11
91 The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
92
93 %description pvm-X11 -l pl.UTF-8
94 Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
95 PVM/xwin.
96
97 %prep
98 %setup -q
99 cp %{SOURCE1} unix/config/ax_boost_base.m4
100 #%patch0 -p1
101 %patch1 -p1
102
103 %build
104 cd unix
105 ./prebuild.sh
106 cd ..
107
108 %{__automake}
109 COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
110 %if %{with x} && %{with pvm}
111 %configure \
112         --libdir=%{_datadir} \
113         --enable-pvm \
114         --with-pvm-arch=%{_pvmarch} \
115         --with-pvm-libs=%{_libdir}
116 %{__make}
117 install unix/povray x-pvmpov
118 %endif
119
120 %if %{with pvm}
121 %{__make} clean
122
123 %configure \
124         --libdir=%{_datadir} \
125         --enable-pvm \
126         --with-pvm-arch=%{_pvmarch} \
127         --with-pvm-libs=%{_libdir} \
128         --without-x
129 %{__make}
130 install unix/povray pvmpov
131 %endif
132
133 %if %{with x}
134 %configure \
135         --libdir=%{_datadir}
136 %{__make}
137 install unix/povray x-povray
138 %{__make} clean
139 %endif
140
141 %configure \
142         --libdir=%{_datadir} \
143         --without-x
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
149 %if %{with pvm}
150 install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
151 %endif
152
153 %{__make} install \
154         INSTALL="install -c -D" \
155         mkdir_p="mkdir -p" \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %if %{with x}
159 install x-povray $RPM_BUILD_ROOT%{_bindir}
160 %endif
161
162 %if %{with x} && %{with pvm}
163 install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
164 ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
165 %endif
166
167 %if %{with pvm}
168 install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
169 ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
170 %endif
171
172 ##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
173 ##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog NEWS README* changes.txt
181 %attr(755,root,root) %{_bindir}/povray
182 %{_datadir}/povray*
183 %{_docdir}/povray*
184 %{_mandir}/man?/*
185 %dir %{_sysconfdir}/povray
186 %dir %{_sysconfdir}/povray/3.7
187 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
188 ## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
189
190 %if %{with x}
191 %files X11
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_bindir}/x-povray
194 %endif
195
196 %if %{with pvm}
197 %files pvm
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
200 %attr(755,root,root) %{_bindir}/pvmpov
201 %endif
202
203 %if %{with pvm} && %{with x}
204 %files pvm-X11
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
207 %attr(755,root,root) %{_bindir}/x-pvmpov
208 %endif
This page took 0.063833 seconds and 2 git commands to generate.