]> git.pld-linux.org Git - packages/povray.git/blame_incremental - povray.spec
- obsolete
[packages/povray.git] / povray.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without x # - without X11 subpackage
4%bcond_with pvm # - with PVM support
5%bcond_with svga # - with svgalib support (doesn't work on many platforms)
6#
7%define _src_pov_ver 3.7.0.RC3
8
9Summary: Persistence of Vision Ray Tracer
10Summary(pl.UTF-8): Persistence of Vision Ray Tracer
11Name: povray
12Version: 3.7.0
13Release: 0.RC3.1
14Epoch: 1
15License: distributable
16Group: Applications/Graphics
17#Source0: http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
18Source0: http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.bz2
19# Source0-md5: 66480f1ca6b1b1b5198605b6caf3f8e8
20# based on sources from CVS at http://pvmpov.sourceforge.net/
21# Source0: %{name}-%{version}-%{snap}.tar.gz
22Source1: %{name}-ax_boost_base.m4
23URL: http://www.povray.org/
24BuildRequires: autoconf
25BuildRequires: automake
26BuildRequires: libjpeg-devel
27BuildRequires: libpng-devel >= 1.4.0
28BuildRequires: libstdc++-devel
29BuildRequires: libtiff-devel
30%{?with_pvm:BuildRequires: pvm-devel >= 3.4.3-24}
31%{?with_svga:BuildRequires: svgalib-devel}
32%{?with_x:BuildRequires: xorg-lib-libX11-devel}
33BuildRequires: zlib-devel
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%if %{with pvm}
37%define _pvmarch %(/usr/bin/pvmgetarch)
38%define _pvmroot /usr/%{_lib}/pvm3
39%endif
40
41%description
42The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
43photo-realistic images using a rendering technique called ray-tracing.
44It reads in a text file containing information describing the objects
45and lighting in a scene and generates an image of that scene from the
46view point of a camera also described in the text file. Ray-tracing is
47not a fast process by any means, but it produces very high quality
48images with realistic reflections, shading, perspective and other
49effects.
50
51%description -l pl.UTF-8
52Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
53fotorealistyczne obrazy za pomocą techniki renderingu zwanej
54ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
55obiekty oraz światło przedstawianego świata, a następnie generuje
56rysunek z punktu widzenia kamery, która także jest definiowana w w/w
57pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
58ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
59efektami, tj. odbicia światła, cienie, perspektywa i inne.
60
61%package X11
62Summary: X Window povray executable
63Summary(pl.UTF-8): povray pod X Window
64Group: Applications/Graphics
65Requires: %{name} = %{epoch}:%{version}-%{release}
66
67%description X11
68The Persistence of Vision(tm) Ray-Tracer X Window executable.
69
70%description X11 -l pl.UTF-8
71Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
72Window.
73
74%package pvm
75Summary: PVM/Unix povray executable
76Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/Unix
77Group: Applications/Graphics
78Requires: %{name} = %{epoch}:%{version}-%{release}
79
80%description pvm
81The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
82
83%description pvm -l pl.UTF-8
84Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
85PVM/Unix.
86
87%package pvm-X11
88Summary: PVM/xwin povray executable
89Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/xwin
90Group: Applications/Graphics
91Requires: %{name} = %{epoch}:%{version}-%{release}
92
93%description pvm-X11
94The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
95
96%description pvm-X11 -l pl.UTF-8
97Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
98PVM/xwin.
99
100%prep
101%setup -q -n %{name}-%{_src_pov_ver}
102cp %{SOURCE1} unix/config/ax_boost_base.m4
103
104%build
105%{__aclocal}
106%{__autoconf}
107%{__automake}
108COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
109%if %{with x} && %{with pvm}
110%configure \
111 --libdir=%{_datadir} \
112 --enable-pvm \
113 --with-pvm-arch=%{_pvmarch} \
114 --with-pvm-libs=%{_libdir} \
115 --x-includes=/usr/X11R6/include \
116 --x-libraries=/usr/X11R6/%{_lib}
117%{__make}
118install unix/povray x-pvmpov
119%endif
120
121%if %{with pvm}
122%{__make} clean
123
124%configure \
125 --libdir=%{_datadir} \
126 --enable-pvm \
127 --with-pvm-arch=%{_pvmarch} \
128 --with-pvm-libs=%{_libdir} \
129 --without-x
130%{__make}
131install unix/povray pvmpov
132%endif
133
134%if %{with x}
135%configure \
136 --libdir=%{_datadir} \
137 --x-includes=/usr/X11R6/include \
138 --x-libraries=/usr/X11R6/%{_lib}
139%{__make}
140install unix/povray x-povray
141%{__make} clean
142%endif
143
144%configure \
145 --libdir=%{_datadir} \
146 --without-x
147%{__make}
148
149
150%install
151rm -rf $RPM_BUILD_ROOT
152install -d $RPM_BUILD_ROOT{%{_sysconfdir},/usr/X11R6/bin}
153%if %{with pvm}
154install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
155%endif
156
157%{__make} install \
158 DESTDIR=$RPM_BUILD_ROOT
159
160%if %{with x}
161install x-povray $RPM_BUILD_ROOT%{_bindir}
162%endif
163
164%if %{with x} && %{with pvm}
165install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
166ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
167%endif
168
169%if %{with pvm}
170install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
171ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
172%endif
173
174##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
175##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
176
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180%files
181%defattr(644,root,root,755)
182%doc AUTHORS ChangeLog NEWS README* changes.txt
183%attr(755,root,root) %{_bindir}/povray
184%{_datadir}/povray*
185%{_docdir}/povray*
186%{_mandir}/man?/*
187%dir %{_sysconfdir}/povray
188%dir %{_sysconfdir}/povray/3.7
189%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
190## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
191
192%if %{with x}
193%files X11
194%defattr(644,root,root,755)
195%attr(755,root,root) %{_bindir}/x-povray
196%endif
197
198%if %{with pvm}
199%files pvm
200%defattr(644,root,root,755)
201%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
202%attr(755,root,root) %{_bindir}/pvmpov
203%endif
204
205%if %{with pvm} && %{with x}
206%files pvm-X11
207%defattr(644,root,root,755)
208%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
209%attr(755,root,root) %{_bindir}/x-pvmpov
210%endif
This page took 0.066037 seconds and 4 git commands to generate.