]> git.pld-linux.org Git - packages/povray.git/blame_incremental - povray.spec
- release 4 (by relup.sh)
[packages/povray.git] / povray.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without x # - without X11 subpackage
4%bcond_with pvm # - with PVM support
5%bcond_with svga # - with svgalib support (doesn't work on many platforms)
6#
7%define _rc RC7
8%define _src_pov_ver 3.7.0.%{_rc}
9%define rel 4
10
11Summary: Persistence of Vision Ray Tracer
12Summary(pl.UTF-8): Persistence of Vision Ray Tracer
13Name: povray
14Version: 3.7.0
15Release: 0.%{_rc}.%{rel}
16Epoch: 1
17License: distributable
18Group: Applications/Graphics
19#Source0: http://www.povray.org/ftp/pub/povray/Official/Unix/%{name}-%{_src_pov_ver}.tar.bz2
20Source0: http://www.povray.org/redirect/www.povray.org/beta/source/%{name}-%{_src_pov_ver}.tar.bz2
21# Source0-md5: 7d24ec051af67bcf040a898a267d920a
22# based on sources from CVS at http://pvmpov.sourceforge.net/
23# Source0: %{name}-%{version}-%{snap}.tar.gz
24Source1: %{name}-ax_boost_base.m4
25Patch0: %{name}-nouserfiles.patch
26Patch1: boost-1.50.patch
27URL: http://www.povray.org/
28BuildRequires: autoconf
29BuildRequires: automake
30BuildRequires: libjpeg-devel
31BuildRequires: libpng-devel >= 1.4.0
32BuildRequires: libstdc++-devel
33BuildRequires: libtiff-devel
34%{?with_pvm:BuildRequires: pvm-devel >= 3.4.3-24}
35%{?with_svga:BuildRequires: svgalib-devel}
36%{?with_x:BuildRequires: xorg-lib-libX11-devel}
37BuildRequires: zlib-devel
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%if %{with pvm}
41%define _pvmarch %(/usr/bin/pvmgetarch)
42%define _pvmroot /usr/%{_lib}/pvm3
43%endif
44
45%description
46The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
47photo-realistic images using a rendering technique called ray-tracing.
48It reads in a text file containing information describing the objects
49and lighting in a scene and generates an image of that scene from the
50view point of a camera also described in the text file. Ray-tracing is
51not a fast process by any means, but it produces very high quality
52images with realistic reflections, shading, perspective and other
53effects.
54
55%description -l pl.UTF-8
56Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
57fotorealistyczne obrazy za pomocą techniki renderingu zwanej
58ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
59obiekty oraz światło przedstawianego świata, a następnie generuje
60rysunek z punktu widzenia kamery, która także jest definiowana w w/w
61pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
62ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
63efektami, tj. odbicia światła, cienie, perspektywa i inne.
64
65%package X11
66Summary: X Window povray executable
67Summary(pl.UTF-8): povray pod X Window
68Group: Applications/Graphics
69Requires: %{name} = %{epoch}:%{version}-%{release}
70
71%description X11
72The Persistence of Vision(tm) Ray-Tracer X Window executable.
73
74%description X11 -l pl.UTF-8
75Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
76Window.
77
78%package pvm
79Summary: PVM/Unix povray executable
80Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/Unix
81Group: Applications/Graphics
82Requires: %{name} = %{epoch}:%{version}-%{release}
83
84%description pvm
85The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
86
87%description pvm -l pl.UTF-8
88Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
89PVM/Unix.
90
91%package pvm-X11
92Summary: PVM/xwin povray executable
93Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/xwin
94Group: Applications/Graphics
95Requires: %{name} = %{epoch}:%{version}-%{release}
96
97%description pvm-X11
98The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
99
100%description pvm-X11 -l pl.UTF-8
101Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
102PVM/xwin.
103
104%prep
105%setup -q -n %{name}-%{_src_pov_ver}
106cp %{SOURCE1} unix/config/ax_boost_base.m4
107%patch0 -p1
108%patch1 -p1
109
110%build
111%{__aclocal}
112%{__autoconf}
113%{__automake}
114COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
115%if %{with x} && %{with pvm}
116%configure \
117 --libdir=%{_datadir} \
118 --enable-pvm \
119 --with-pvm-arch=%{_pvmarch} \
120 --with-pvm-libs=%{_libdir}
121%{__make}
122install unix/povray x-pvmpov
123%endif
124
125%if %{with pvm}
126%{__make} clean
127
128%configure \
129 --libdir=%{_datadir} \
130 --enable-pvm \
131 --with-pvm-arch=%{_pvmarch} \
132 --with-pvm-libs=%{_libdir} \
133 --without-x
134%{__make}
135install unix/povray pvmpov
136%endif
137
138%if %{with x}
139%configure \
140 --libdir=%{_datadir}
141%{__make}
142install unix/povray x-povray
143%{__make} clean
144%endif
145
146%configure \
147 --libdir=%{_datadir} \
148 --without-x
149%{__make}
150
151%install
152rm -rf $RPM_BUILD_ROOT
153install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
154%if %{with pvm}
155install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
156%endif
157
158%{__make} install \
159 INSTALL="install -c -D" \
160 mkdir_p="mkdir -p" \
161 DESTDIR=$RPM_BUILD_ROOT
162
163%if %{with x}
164install x-povray $RPM_BUILD_ROOT%{_bindir}
165%endif
166
167%if %{with x} && %{with pvm}
168install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
169ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
170%endif
171
172%if %{with pvm}
173install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
174ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
175%endif
176
177##install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
178##install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%files
184%defattr(644,root,root,755)
185%doc AUTHORS ChangeLog NEWS README* changes.txt
186%attr(755,root,root) %{_bindir}/povray
187%{_datadir}/povray*
188%{_docdir}/povray*
189%{_mandir}/man?/*
190%dir %{_sysconfdir}/povray
191%dir %{_sysconfdir}/povray/3.7
192%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.7/povray.*
193## %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/povray.*
194
195%if %{with x}
196%files X11
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_bindir}/x-povray
199%endif
200
201%if %{with pvm}
202%files pvm
203%defattr(644,root,root,755)
204%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
205%attr(755,root,root) %{_bindir}/pvmpov
206%endif
207
208%if %{with pvm} && %{with x}
209%files pvm-X11
210%defattr(644,root,root,755)
211%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
212%attr(755,root,root) %{_bindir}/x-pvmpov
213%endif
This page took 0.037658 seconds and 4 git commands to generate.